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Learning Objectives
· Define a computer

· Identify the characteristics of a computer

· Appreciate the evolution of computer through five generations

· Classification of  computers

· Functionality of  various parts of computer through the Block diagram

· Types of number systems
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· Binary, octal, decimal and  Hexa-decimal number systems

· Conversions from one system to another system

· Explain the concept  input, output

· Explain various input devices

· Explain various output devices

· What is main memory

· What is memory size

· What is secondary memory

· What are RAM, ROM, PROM, EAPROM, Cache memory and
registers

· Secondary storage devices such as magnetic tape, disk, cd’s, flash drive
Etc.,

· Explain the concept  of software

· Distinguish between different types of software

· Differentiate application software from system software

· Define a language

· Differentiate between different types of language

· Distinguish between compiler and interpreter

1.1 Introduction
The term Computer is derived from  ‘compute’ which  means ‘to calculate’.

We  are all familiar with calculations in our day-to-day life. We apply
mathematical operations like addition, subtraction, multiplication, etc. and many
other formulae for calculations. Simple calculations take less time. But complex
calculations take much longer time. Another factor is accuracy in calculations.
So man explored with the idea to develop a machine, which can perform this
type of arithmetic calculation faster, and with full accuracy. This gave birth to a
machine called ‘computer’.

What is a Computer

You have already experienced the impact of computers in our day to-day
life. Reservation of tickets in Air Lines and Railways, Payment of telephone and
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electricity bills, Deposits and withdrawals of money from banks, Business data
processing, Medical diagnosis, Weather forecasting, etc. are some of the areas
where computer has become extremely useful.

But as you will see later it does much more than that. It can be compared to
a magic box, which serves different purpose to different people.

Computer : It is an electronic device which processes given data to derive
the required and useful information. During the processing the computer has to
perform various functions like receives data(input) processes data(process)
produces output(information) stores results (storage)

1.1.2 Characteristics of  Computers
      The characteristics which make computer make indispensable are

1. Speed

The computer is able to process  the data and gives  the output in fractions
of seconds, such that required information is given to the user on time enabling
the user to take right decisions on right time. A powerful computer is capable of
executing about 3 million calculations per second.

2. Accurancy

 The accuracy of computers  is consistently high enough which avoids any
errors.  If it all there are errors, they are due to errors in instructions given by the
programmer.

3. Reliable

The output generated by the computer is very reliable, but it is reliable only
when the data, which is passing as input to the computer and the program,
which gives instructions are correct and reliable.

4. Storage Capacity

The computer has a provision to store large volumes  of data in the small
storage devices, which have capacity to store huge  amounts of data and help
the retrieval of data an easy task.

5. Versatile

Computers are very versatile machines. Computers are capable of
performing almost any task ,provided the task can be reduced to a series of
logical steps.



      Computer Graphics and Animation4

6. Automation

Once the instructions fed into computer it works automatically without any
human intervention until the completion of execution of program or  meets logical
instructions to terminate the job.

7. Diligent

 A computer is free from tiredness, lack of concentration, fatigue, etc. It
can work for hours without creating any error. If millions of calculations are to
be performed, a computer will perform every calculation with the same accuracy.
Due to this capability it overpowers human being in routine type of work.

1.1.3 The Computer Generations :

The evolution of computer started from 16th century and resulted in the
form that we see today. The present day computer, however, has also undergone
rapid change during the last fifty years. This period, during which the evolution
of computer took place, can be divided into five distinct phases, basis of the
type of switching circuits known as Generations of Computers.

1. First Generation Computers (1950’s)

These computers which used vacuum tubes (valves) as major electronic
component . The advantage of vacuum tubes technology is that it made the
advent of Electronic digital computer. Vacuum tubes were only electronic devices
available during those days which made computing possible.

2. Second Generation Computers (1960’s)

Around 1955 a device called Transistor replaced the bulky electric tubes
in the first generation computer. Transistors are smaller than electric tubes and
have higher operating speed. They have no filament and require no heating.
Manufacturing cost was also very low. Thus the size of the computer got reduced
considerably.

3.Third Generation Computers (1970’s)

The third generation computers were introduced in 1964. They used
Integrated Circuits (ICs). These ICs are popularly known as Chips. A single IC
has many transistors, registers and capacitors built on a single thin slice of silicon.
So it is quite obvious that the size of the computer got further reduced. Computers
of this generation were small in size, low cost, large memory and processing
speed is very high.
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4. Fourth Generation (1980’s)

The present day computers that you see today are the fourth generation
computers that started around 1975. It uses large scale Integrated Circuits (LSIC)
built on a single silicon chip called microprocessors. Due to the development of
microprocessor it is possible to place computer’s central processing unit (CPU)
on single chip. These computers are called microcomputers. Later very large
scale Integrated Circuits (VLSIC) replaced LSICs.

Thus the computer which was occupying a very large room in earlier days
can now be placed on a table. The personal computer (PC) that you see in your
college  is a Fourth Generation Computer.

5. Fifth Generation (Late 1990’s)

These computers use optic fiber  technology to handle Artificial Intelligence,
expert systems, Robotics etc., these computers have high  processing speeds
and are more reliable.

1.2 Classification of Computers
The computers are classified into various types depends on their purpose,

operation and size.

Classification of Computers

In general computers are classified  into  major categories based on.

(a) According to the purpose of the computer.

(b) According to the operation  of computer.

(c) According to the size  of computer.

(a) Classification as per purpose of the computer

1. General purpose  computers.

2. Special purpose  computer.

1. General Purpose  Computers : These computers are theoretically
used for any type of applications. These computers can be used in solving a
business Problem and also used to solve mathematical equation with same
accuracy and consistency. Most of the computer now are general purpose digital
computers. All the P.C’s, which have become household affair.

2. Special Purpose Computers : These digital computer are designed,
made and used for any specific job. These are usually used for those purposes
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which are critical and need great accuracy and response like Satellite launching,
weather forecasting etc.

According to the  operational principle of computers, they are categorized
as analog, digital and hybrid computers.

Analog Computers: These are almost extinct today. These are different
from a digital computer because an analog computer can perform several
mathematical operations simultaneously. It uses continuous variables for
mathematical operations and utilizes mechanical or electrical energy.

Digital Computers: They use digital circuits and are designed to operate
on two states, namely bits 0 and 1. They are analogous to states ON and OFF.
Data on these computers is represented as a series of 0s and 1s. Digital computers
are suitable for complex computation and have higher processing speeds. They
are programmable. Digital computers are either general purpose computers or
special purpose ones. General purpose computers, as their name suggests, are
designed for specific types of data processing while general purpose computers
are meant for general use.

Hybrid Computers: These computers are a combination of both digital
and analog computers. In this type of computers, the digital segments perform
process control by conversion of analog signals to digital ones.

According to the  sizes of the computers ,the computers are classified as
follows.

Supercomputers: The highly calculation-intensive tasks can be effectively
performed by means of supercomputers. Quantum physics, mechanics, weather
forecasting, molecular theory are best studied by means of supercomputers.
Their ability of parallel processing and their well-designed memory hierarchy
give the supercomputers, large transaction processing powers.

Ex. PARAM developed in India.

Servers: They are computers designed to provide services to client
machines in a computer network. They have larger storage capacities and
powerful processors. Running on them are programs that serve client requests
and allocate resources like memory and time to client machines. Usually they
are very large in size, as they have large processors and many hard drives. They
are designed to be fail-safe and resistant to crash.
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Mainframe Computers: Large organizations use mainframes for highly
critical applications such as bulk data processing and ERP. Most of the mainframe
computers have capacities to host multiple operating systems and operate as a
number of virtual machines. They can substitute for several small servers.

Wearable Computers: A record-setting step in the evolution of computers
was the creation of wearable computers. These computers can be worn on the
body and are often used in the study of behavior modeling and human health.
Military and health professionals have incorporated wearable computers into
their daily routine, as a part of such studies. When the users’ hands and sensory
organs are engaged in other activities, wearable computers are of great help in
tracking human actions. Wearable computers do not have to be turned on and
off and remain in operation without user intervention

Minicomputers: In terms of size and processing capacity, minicomputers
lie in between mainframes and microcomputers. Minicomputers are also called
mid-range systems or workstations. The term began to be popularly used in the
1960s to refer to relatively smaller third generation computers. They took up
the space that would be needed for a refrigerator or two and used transistor and
core memory technologies. The 12-bit PDP-8 minicomputer of the Digital
Equipment Corporation was the first successful minicomputer.

Microcomputers: A computer with a microprocessor and its central
processing unit is known as a microcomputer. They do not occupy space as
much as mainframes do. When supplemented with a keyboard and a mouse,
microcomputers can be called personal computers. A monitor, a keyboard and
other similar input-output devices, computer memory in the form of RAM and a
power supply unit come packaged in a microcomputer. These computers can fit
on desks or tables and prove to be the best choice for single-user tasks.

Desktops: A desktop is intended to be used on a single location. The
spare parts of a desktop computer are readily available at relatively lower costs.
Power consumption is not as critical as that in laptops. Desktops are widely
popular for daily use in the workplace and households.

Laptops: Similar in operation to desktops, laptop computers are miniaturized
and optimized for mobile use. Laptops run on a single battery or an external
adapter that charges the computer batteries. They are enabled with an inbuilt
keyboard, touch pad acting as a mouse and a liquid crystal display. Their
portability and capacity to operate on battery power have proven to be of great
help to mobile users.
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Notebooks: They fall in the category of laptops, but are inexpensive and
relatively smaller in size. They had a smaller feature set and lesser capacities in
comparison to regular laptops, at the time they came into the market. But with
passing time, notebooks too began featuring almost everything that notebooks
had. By the end of 2008, notebooks had begun to overtake notebooks in terms
of market share and sales.

Personal Digital Assistants (PDAs): It is a handheld computer and
popularly known as a palmtop. It has a touch screen and a memory card for
storage of data. PDAs can also be used as portable audio players, web browsers
and smart phones. Most of them can access the Internet by means of Bluetooth
or Wi-Fi communication.

Tablet Computers: Tablets are mobile computers that are very handy to
use. They use the touch screen technology. Tablets come with an onscreen
keyboard or use a stylus or a digital pen. Apple’s iPad redefined the class of
tablet computers.

1.3 Anatomy of Computers
 The Computer mainly consists the functions input, process, output and

storage. These functions were described in the manner of diagram as follows.

The Block diagram of computer consists mainly  i.e.,

Fig. 1.1 Block Diagram of Computer
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· Input unit

· CPU(Control unit, Main Memory and ALU)

· Output unit,

· Secondary Storage unit

1. Input: This is the process of entering data and programs in to the
computer system.  Therefore, the input unit takes data from us to the computer
in an organized manner for processing through an input device such as keyboard,
mouse, MICR, OCR, Etc.,

2. Main Memory: It is also known as internal memory. It is very
fast in operation. It is used to store   data and instructions. Data has to be fed
into the system before the actual processing starts.  It contains a part of the
operating system Software, one or more execution programs being executed,
the data being processed and required by the programs for execution , and
processed data awaiting output.

3. Output: This is the process of producing results from the data for getting
useful information. Similarly the output produced by the computer after processing
must also be kept somewhere inside the computer before being given to you in
human readable form through the screen or printer.  Again the output is also
stored inside the computer for further processing.

4. Control Unit (CU)  : The next component of computer is the Control
Unit, which acts like the supervisor seeing  that things are done in proper fashion.
Control Unit is responsible  for  co-ordinating various operations using time
signal. The control unit determines the sequence in which computer programs
and instructions are executed. Things like processing of programs stored in the
main memory, interpretation of the instructions and issuing of signals for other
units of the computer to execute them. It also acts as a switch board operator
when several users access the computer simultaneously. Thereby it coordinates
the activities of computer’s peripheral equipment as they perform the input and
output.

5. Arithmetic Logical Unit (ALU) :  After you enter data through the
input device it is stored in the primary storage. The actual processing of the data
and instruction are performed by Arithmetic Logical Unit. The major operations
performed by the ALU are addition, subtraction, multiplication, division, logic
and comparison. Data is transferred to ALU from storage unit when required.
After processing the output is returned back to storage unit for further processing
or getting stored.
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6. Secondary storage: It is  also known as auxiliary memory. It is closely
linked with the main memory. Since main memory can’t be flooded with unwanted
data at particular moment, same is stored in auxiliary memory from which desired
data is fed to main memory as and when required by it. Thus secondary storage
is used to hold mass of information i.e., system software, application programs,
cinemas, games and data files.  Obviously the capacity of secondary storage is
very high compared to main memory. Auxiliary memory usually in the form of
Magnetic disk, Magnetic tape, CD’s, Memory cards, Pen drives Etc.,

1.4 Number Systems
The data representation of computer  consists alphabets, numerals, and

special symbols. Here we discuss about the numerals(numbers). In our daily life
we use decimal system ,where as computer use only binary system .But there
are four types of number systems.

The number system

Basically Number system is divided in to four types

1. Binary Number System

2. Octal Number system

3. Decimal Number system

4. Hexa-decimal Number System

1. Binary Number System:-It is base(radix) of  2 and it has only   two
digits i.e 0 and 1. The value of the numbers is represented as power of 2 i.e. the
radix of the system. These power increases with the position of the digits as
follows

2.Octal Number System :- It is base of  8 and it has only eight  digits i.e
0 ,1,2,3,4,5,6 and 7. The value of the numbers is represented as power of 8 i.e.
the radix of the system. These power increases with the position of the digits as
follows.

Ex : (1011)2  (11010)2
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3. Decimal Number system:-  It is base of 10 and it has only ten  digits
i.e 0 ,1,2,3,4,5,6,7,8 and 9. The value of the numbers is represented as power
of 10 i.e. the radix of the system. These power increases with the position of the
digits as follows.

4. Hexa Decimal Number System:- :-  It is base of 16 and it has only
sixteen  digits i.e  0 ,1,2,3,4,5,6,7,8,9, A(10),B(11), C(12), D(13),E(14)  and
F(15). The value of the numbers is represented as power of 16 i.e. the radix of
the system. These power increases with the position of the digits as follows

Conversions

We can convert from any system to any other system as follows.

1.  Decimal to Binary

 Divide the decimal number by 2 repeatedly and note the remainders from
bottom to top.

Ex : (259)10  (184)10

Ex : (5D)16  (1A5)16
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Ex1 : Convert (13)10 to (?)2

   2       13

   2        6          1

   2        3          0

        1           1

Ex2:   Convert (37)10 to (?)2

  2       37

  2       18          1

  2        9           0

  2        4           1

  2       2            0

          1             0

2.Decimal to Octal:

        Divide the decimal number by 8 repeatedly and note the remainders
from bottom to top.

Ex1: convert (50)10 to (?)8

   8       50

        6          2

(62)8

 

(1101)2

(100101)2
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Ex2: convert (124)10 to (?)8

   8       124

   8 15          4

1            7

3.Decimal to hexadecimal:

Divide the decimal number by 16 repeatedly and note the remainders
from bottom to top.

Ex1: Convert (50)10 to (?)16

     16       50

                3          2

(32)16

Ex2: Convert (380)10 to (?)16

    16       380

    16 23          C

1            7              (17C)16

 4. Binary to Decimal:  Multiply the binary number with the weights of
binary system according to theirposition   and note the sum.

Ex1:  Convert (11010)2   to (?)10

11010 = 1 x 2 4 +1 x 23 + 0 x 22 +1 x 21 + 0 x 20

           = 1 x  16 + 1 x 8 + 0 x 4 + 1 x 2 + 0 x 1

 

(174)8
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           = 16 + 8 + 0 +2 + 0 = (26)10

Ex2: Convert (1101)2 into (?)10

   1101 =  1 x 23 + 1 x 22 +0 x 21 + 1 x 20

           =   1 x 8 + 1  x 4 + 0 x 2 + 1 x 1

           =    8 + 4 + 0 +1 = (13)10

5.Octal  to Decimal:  Multiply the Octal  number with the weights of octal
system  according to their position  and note the sum.

Ex1: Convert (62)8  into (?)10

   (62)8   =  6 x 81 + 2 x 80

              =  6 x 8 + 2 x 1

              =   48 + 2 =  (50)10

Ex2:  Convert (174)8  into (?)10

   (174)8   =  1 x 82 + 7 x 81 + 4 x 80

              =  1 x 64 + 7 x 8 + 4 x 1

              =   64 + 56 + 4  =  (124)10

6. Hexadecimal  to Decimal:  Multiply the hexadecimal  number with the
weights of hexadecimal system according to their position   and note the sum.

Ex1: Convert  (5D)16  into  (?)10

(5D)16      =  5 x 161 + D x 160

                       =    5 x 16 + 13 x 1

                =   80   + 13   = (93)10

Ex2: Convert  (1A5)16  into  (?)10

(1A5)16   =  1 x 162 + A x 161 + 5 x 160

              =    1 x 256 + 10  x 16 + 5 x 1

         =   256   + 160 + 5   = (421)10
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 1.5 Input-output Devices
Generally, we give data and program to the computer. So what we give to

the Computer is known as input. Through which device we give the input is
called input device.

Generally we get information from the computer, So what we get from the
computer is called output.

Through which device we get output is called output device.

1.5.2 Input devices

An input device presents data to the processing unit in a machine-readable
form. Although the keyboard is a common input device for a small computer, a
system may also support various other input devices such as Optical Character

Recognition (OCR), Magnetic Ink Character Recognition (MICR), mark
sense reader, etc.

1.5.2.1  Key board

The keyboard is very much like a standard typewriter keyboard with a few
additional keys. The basic QWERTY layout of characters is maintained to make
it easy for the trained typist to use the system. The additional keys are included
to perform certain special functions such as loading a program, edition a text,
etc. These are known as function keys that vary in number from system to
system.

1.5.2.2 Optical Character Recognition

Often abbreviated as OCR, optical character recognition involves reading
text from paper and translating the images into a form that the computer can
manipulate. An OCR system enables you to take a book or a magazine article
and feed it directly into an electronic computer file.

1.5.2.3 Magnetic Ink Character Recognition (MICR)

An MICR can identify characters printed with a special ink that contain
particles of magnetic material. This device particularly finds applications in banking
industry. Since the MICR system can recognise only certain character styles,
the characters have to be accurately formed.

1.5.2.4 Optical Mark Recognition (OMR)

Optical mark recognition, also called mark sense reader, is a technology
where an OMR device senses the presence or absence of a mark, such as
pencil mark.
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OMR is widely used in tests such as aptitude tests.

1.5.4.5 Bar Code Reader

These devices are generally available in super markets, bookshops, etc.
Bar-code readers are photoelectric scanners that read the bar codes or vertical
zebra striped marks, printed on product containers. Supermarkets use a bar
code system called the Universal Product Code (UPC). The bar code identifies
the product to the supermarket’s computer which has a description and the
latest price of the product. The computer automatically tells the Point of Sales
(POS) terminal what the price is.

1.5.2.6 Digitizing Tablet

This is an input device that enables you to enter drawings and sketches into
a computer. A digitizing tablet consists of an electronic tablet and a cursor or
pen. A cursor (also called a puck) is similar to a mouse, except that it has a
window with cross hairs for pinpoint placement, and it can have as many as 16
buttons. A pen (also called a stylus) looks like a simple ballpoint pen but uses an
electronic head instead of ink. The tablet contains electronic field that enables it
to detect movement of the cursor or pen and translate the movements into digital
signals that it sends to the computer. Digitizing tables are also called digitizers,
graphics tables, touch tables or simply tables.

1.5.2.7 Scanner

Scanner is an input device that can read text or illustrations printed on
paper and translate the information into a form that the computer can use. A
scanner works by digitizing an image - dividing it into a grid of boxes and
representing each box with either a zero or a one, depending on whether the
box is filled in. The resulting matrix of bits, called a bit map, can then be stored
in a file, displayed on a screen and manipulated by programs. Optical scanners
do not distinguish text from illustrations, they represent all images as bit maps.
Therefore, you cannot directly edit text that has been scanned. To edit text read
by an optical scanner, you need an optical character recognition (OCR) system
to translate the image into ASCII characters. Most optical scanners sold today
come with OCR packages.

1.5.2.8 Mouse

Mouse is a device that controls the movement of the cursor or pointer on a
display screen. It is a small object you can roll along a hard and flat surface. As
you move the mouse, the pointer on the display screen moves in the same direction.
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Mouse contains at least one button and sometimes as many as three, which
have different functions depending on what program is running.

1.5.2.9 Light Pen

Light pen is an input device that utilizes a light-sensitive detector to
selectobjects on a display screen.

1.5.2.10 Speech input devices

Speech or voice input devices convert a person’s speech into digital form.
These input devices, when combined with appropriate software, form voice
recognition systems. These systems enable users to operate microcomputers
using voice commands.

1.5.3 Output Devices

Output devices receive information from the CPU and present it to the user
in  the desired form. Output devices include display screen, loudspeakers,
printers, plotters, etc.

1.5.3.1 Display Screen

When a program is keyed in, the screen (which is similar to a television
screen) displays the characters. The user can read the program line by line and
make corrections before it is stored or printed on a printer. It is also possible to
bring to the screen a portion of the program stored in the external storage for
editing. Screen sizes differ from system to system. The standard size is 24 lines
by 80 characters. Most systems have provision for scrolling. This facilitates the
user to move the text vertically or horizontally on the screens thus bringing to the
screen the hidden text. Thus the user can scan through the entire file either to
review or to select a particular portion. The cursor on the screen is controlled
by the cursor keys on the keyboard,

1.5.3.2 Printer

Printer is a device that prints text or illustrations on paper and in many
cases on transparencies and other media. There are many different types of
printers. In terms of the technology utilized, printer fall into the following categories.

(i) Ink-jet Printer

Ink-jet printers work by spraying ionized ink on a sheet of paper. Magnetized
plates in the ink’s path direct the ink onto the paper in the desired shapes. Inkjet
printers are capable of producing high quality print approaching to that produced
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by laser printers. A typical ink-jet printer provides a resolution of 300 dots per
inch, although some newer models offer higher resolutions.

In general, the price of ink-jet printers is lower than that of laser printers.

However, they are also considerably slower. Another drawback of ink-jet
printers is that they require a special type of ink that is apt to smudge on inexpensive
copier paper.

Because ink-jet printers require smaller mechanical parts than laser printers,
they are specially popular as portable printers. In addition, colour ink-jet printers
provide an inexpensive way to print full-colour documents.

Fig. 1.2 Ink - Jet Printer

(ii) Laser Printer

Laser Printer utilizes a laser beam to produce an image on a drum. The light
of the laser alters the electrical charge on the drum wherever it hits. The drum is
then rolled through a reservoir of toner, which is picked up by the charged
portions of the drum. Finally, the toner is transferred to the paper through a
combination of heat and pressure. This is also the way copy machines work.

Because an entire page is transmitted to a drum before the toner is applied,
laser printers are sometimes called page printers. There are two other types of
page printers that fall under the category of laser printers even though they do
not use lasers at all. One uses an array of LEDs to expose the drum, and the
other uses LCDs. Once the drum is charged, however, they both operate like a
real laser printer.

One of the chief characteristics of laser printers is their resolution - how
many dots per inch (dpi) they lay down. The available resolutions range from
300 dpi at the low end to 1,200 dpi at the high end. By comparison, offset
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printing usually prints at 1,200 or 2,400 dpi. Some laser printers achieve higher
resolutions with special techniques known generally as resolution enhancement.

In addition to text, laser printers are very adept at printing graphics.
However, you need significant amounts of memory in the printer to print high-
resolution graphics. To print a full-page graphic at 300 dpi, for example, you
need at least 1 MB (megabyte) of printer RAM. For a 600-dpi graphic, you
need at least 4 MB RAM.

The speed of laser printers ranges from about 4 to 20 pages of text per
minute (ppm). A typical rate of 6 ppm is equivalent to about 40 characters per
second (cps).

(iii) Line Printer

Line printers are high-speed printers capable of printing an entire line at
one time. A fast line printer can print as many as 3,000 lines per minute. The
disadvantages of line printers are that they can print only one font, they cannot
print graphics, the print quality is low, and they are very noisy.

(iv) Thermal printer

Thermal printers are printers that produce images by pushing electrically
heated pins against special heat-sensitive paper. Thermal printers are inexpensive
and are used in most calculators and many fax machines. They produce low-
quality print, and the paper tends to curl and fade after a few weeks or months.

1.5.3.3 Plotter

Plotter is a device that draws pictures on paper based on commands from
a computer. Plotters differ from printers in that they draw lines using a pen. As a
result, they can produce continuous lines, whereas printers can only simulate
lines by printing a closely spaced series of dots. Multicolour plotters use different-
coloured pens to draw different colours.

Fig. 1.2 Plotter
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In general, plotters are considerably more expensive than printers. They
are used in engineering applications where precision is mandatory.

1.5.3.4 Sound Cards & Speakers

An expansion board that enables a computer to manipulate and output
sounds. Sound cards are necessary for nearly all CD-ROMs and have become
commonplace on modern personal computers. Sound cards enable the computer
to output sound through speakers connected to the board, to record sound
input from a microphone connected to the computer, and manipulate sound
stored on a disk.

Nearly all sound cards support MIDI, a standard for representing music
electronically. In addition, most sound cards are Sound Blaster-compatible, which
means that they can process commands written for a Sound Blaster card, the de
facto standard for PC sound.

 Fig. 1.3 Sound Card and Speakers

1.5.3.5   3D-Audio

3D audio is a technique for giving more depth to traditional stereo sound.

Typically, 3D sound, or 3D audio, is produced by placing a device in a
room with stereo speakers. The device dynamically analyses the sound coming
from the speakers and sends feedback to the sound system so that it can readjust
the sound to give the impression that the speakers are further apart.

3D audio devices are particularly popular for improving computer audio
where the speakers tend to be small and close together. There are a number of
3D audio devices that can be attached to a computer’s sound card.
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 1.6 Memory unit
Memory means storage of data and the program. In computer’s memory

both data and programs are stored in the binary form. The binary system has
only two values 0 and 1. These are called bits.

As human beings we all understand decimal system  but the computer can
only understand binary system. It is because a large number of integrated circuits
inside the computer can be considered as switches, which can be made ON, or
OFF. If a switch is ON it is considered 1 and if it is OFF it is 0. A number of
switches in different states will give you a message like this: 110101......10. So
the computer takes input in the form of 0 and 1 and gives output in the same
form, i.e., 0 and 1 only.  Every number in binary system can be converted to
decimal system and vice versa; for example, decimal number 9 means 1001 .
Therefore, it is the computer that takes information or data in decimal form from
you, converts it into binary form, processes it, producing output in binary form
and finally again converts the output to decimal form.

 A bit is an acronym for binary digit, which stands for one binary piece of
information. This can be either 0 or 1. Memory unit is made up of several small
storage locations called cells. Each of these cells can store a fixed number of
bits called word length.

Each cell has a unique number assigned to it called the address of the cell
and it is used to identify the cells. The address starts at 0 and goes up to (N-1).
You should know that the memory is like a large cabinet containing as many
drawers as there are addresses of  memory. Each drawer contains a word and
the address is written on outside of the drawer.

Memory sizes(Capacity):

The size  of  memory is termed in terms  KB,MB,GB etc.,

  1 Byte = 8 bits

  1 Kilo Byte(KB) = 1024 Bytes(210)

  1 Mega Byte(MB) =  1024 KB

  1 Giga Byte(GB) = 1024 MB

  1 Tera Byte(TB) = 1024 GB

  1 Peta Byte(PB) = 1024 TB

  1 Exa Byte(EB) = 1024 PB
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  1 Zetta Byte(ZB) = 1024 EB

  1 Yotta Byte(YB) = 1024 ZB

Byte is used to store one character such as (alphabets (a-z),digits (0-9) or
special symbols +,-,$,% etc).You know that each cell of memory contains  one
character or 1 byte of data. So the capacity is defined in terms of  byte  or
words. Thus 64 kilobyte (KB) memory is capable of storing 64 x 1024 = 32,768
bytes. (1 kilobyte is equal to 1024 bytes). A memory size ranges from few
kilobytes in small systems to several thousands of Giga bytes  in large mainframe
and super computers.

Suppose a memory card size is 2 GB means that it can store

2GB =       2 x 1024 MB

=       2 x 1024 x 1024 KB

=        2 x 1024 x 1024 x 1024 Bytes

=         2147483648 bytes

There are two kinds of computer memory: primary and secondary.

Primary Memory

Primary Memory is also known as internal memory or main memory.

As soon as the computer is switched off, the contents of the primary memory
is lost. You can store and retrieve data much faster with primary memory
compared to secondary memory.  Primary memory is more expensive than
secondary memory. When the computer is doing any job,  the data that have to
be processed are stored in the primary memory. This data  may come from an
input device like keyboard or from a secondary storage device  like a floppy
disk, memory card or pen drive etc.,.

The primary memory itself is implemented by two types of memory
technologies. The first is called Random Access Memory (RAM) and the other
is read only memory (ROM). A more appropriate name for RAM is RWM
(Read Write Memory), the CPU can write and read information from any primary
memory location implemented using RAM. The other part of primary memory
is implemented using ROM which stands for Read Only Memory.

(a) Random Access Memory (RAM) : The primary storage is referred
to as Random Access Memory (RAM) because it is possible to randomly select
and use any location of the memory directly to store and retrieve data. It takes
same time to any address of the memory as the first address. It is also called
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read/write memory. The storage of data and instructions inside the primary storage
is temporary. It disappears from RAM as soon as the power to the computer is
switched off. The memories, which loose their content on failure of power supply,
are known as volatile memories. So now we can say that RAM is volatile memory.

(b) Read Only Memory (ROM) : There is another memory in computer,
which is called Read Only Memory (ROM). Again it is the ICs inside the PC
that form the ROM. The storage of program and data in the ROM is permanent.
The ROM stores some standard processing programs supplied by the
manufacturers to operate the personal computer. The ROM can only be read
by the CPU but it cannot be changed. The basic input/output program is stored
in the ROM that examines and initializes various equipment attached to the PC
when the switch is turned ON. The memories, which do not lose their content
on failure of power supply, are known as non-volatile memories. ROM is non-
volatile memory.

(c) PROM : There is another type of primary memory in computer, which
is called Programmable Read Only Memory (PROM). You know that it is not
possible to modify or erase programs stored in ROM, but it is possible for you
to store your program in PROM chip. Once the programs are written it cannot
be changed and remain intact even if power is switched off. Therefore, programs
or instructions written in PROM or ROM cannot be erased or changed.

(d) EPROM : This stands for Erasable Programmable Read Only Memory,
which overcome the problem of PROM and ROM. EPROM chip can be
programmed time and again by erasing the information stored earlier in it.
Information stored in EPROM can be erased by exposing it to ultraviolet light.
This memory can be reprogrammed using a special programming facility. When
the EPROM is in use, information can only be read.

(e) EAPROM : This stands for Electrically Alterable Programmable Read
Only Memory. This concept is same as that of EPROM. The only difference is
that the memory can be altered using electrical signals. The whole of the memory
need not be erased.

(f) Cache Memory : The speed of CPU is extremely high compared to
the access time of main memory. Therefore, the performance of CPU decreases
due to the slow speed of main memory. The decreases the mismatch in operating
speed, a small memory chip is attached between CPU and Main memory whose
access time is very close to the processing speed of CPU. It is called CACHE
memory. CACHE memories are accessed much faster than conventional RAM.
It is used to store programs or data currently being executed or temporary data
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frequently used by the CPU. It is also very expensive to have bigger size of
cache memory. Its size is therefore, normally kept small.

(g) Registers : The CPU processes data and instruction with high speed.
There is also movement of data between various units of the computer. It is
necessary to transfer the processed data with high speed. So the computer uses
a number of special memory units called registers. They are not part of the main
memory but they store data or information temporarily and pass it on as directed
by the control unit.

Secondary Storage(Auxiliary Memory)

You are now clear that the operating speed of primary memory or main
memory should be as fast as possible to cope up with the CPU speed. These
high-speed storage devices are very expensive and hence the cost per bit of
storage is also very high. Again, the storage capacity of the main memory is also
very limited.

Often it is necessary to store hundreds of millions of bytes of data for the
CPU to process. Therefore, additional memory is required in all the computer
systems. This memory is called auxiliary memory or secondary storage.

In this type of memory the cost per bit of storage is low. However, the
operating speed is slower than that of the primary memory. Huge volume of
data are stored here on permanent basis and transferred to the primary storage
as and when required. Most widely used secondary storage devices are magnetic
tapes, magnetic disks and floppy disks, Compact disks and  Pen drives etc.,

Magnetic Tape

Magnetic tapes are used for large computers like mainframe computers
where large volume of data is stored for a longer time. In PCs also you can use
tapes in the form of cassettes. The cost of storing data in tapes is inexpensive.
Tapes consist of magnetic materials that store data permanently. It can be 12.5
mm to 25 mm wide plastic film-type and 500 meter to 1200 meter long which is
coated with magnetic material. The deck is connected to the central processor
and information is fed into or read from the tape through the processor. It is
similar to cassette tape recorder.

Advantages of Magnetic Tape

 Compact : A 10-inch diameter reel of tape is 2400 feet long and is able to
hold 800, 1600 or 6250 characters in each inch of its length. The maximum
capacity of such type is 180 million characters. Thus data are stored much more
compact on tape
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Economical : The cost of storing characters on tape is very less as compared
to other storage devices.

Fast : Copying of data is easier and fast.

Long term Storage and Re-usability : Magnetic tapes can be used forlong
term storage and a tape can be used repeatedly with out loss of data.

Fig. 1.4 Magnetic Tape

Magnetic Disk

You might have seen the gramophone record, which is circular like a disk
and coated with magnetic material. Magnetic disks used in computer are made
on the same principle. It rotates with very high speed inside the disk drive. Data
are stored on both the surface of the disk. Magnetic disks are most popular for
direct access storage. Each disk consists of a number of invisible concentric
circles called tracks. Information is recorded on tracks of a disk surface in the
form of tiny magnetic sports. The presence of a magnetic sport represents one
bit (1) and its absence represents zero bit (0). The information stored in a disk
can be read many times without affecting the stored data. So the reading operation
is non-destructive. But if you want to write a new data, then the existing data is
erased from the disk and new data is recorded.

Floppy Disk

Fig. 1.5  Floppy Diskette
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It is similar to magnetic disk discussed above. It is 3.5 inch in diameter. The
capacity of a 3.5 inch floppy is 1.44 mega bytes. It is cheaper than any other
storage devices and is portable. The floppy is a low cost device particularly
suitable for personal computer system.

 Optical Disk

With every application and software there is greater demand for memory
capacity. It is the necessity to store large volume of data that has led to the
development of optical disk storage medium. Optical disks can be divided intothe
following categories.

(i) Compact Disk/Read Only Memory (CD-ROM): CD-ROM disks
are made of reflective metals. CD-ROM is written during the process of
manufacturing by high power laser beam. Here the storage density is very high,
storage cost is very low and access time is relatively fast. Eachdisk is
approximately 4 1/2 inches in diameter and can hold over 600 MB of data. As
the CD-ROM can be read only we cannot write or make changes into the data
contained in it.

(ii) Write Once Read Many (WORM): The inconvenience that we can
not write any thing in to a CD-ROM is avoided in WORM. A WORM allowsthe
user to write data permanently on the disk. Once the data is written it can never
be erased without physically damaging the disk. Here data can be recorded
from keyboard, video scanner, OCR equipment and other devices. The advantage
of WORM is that it can store vast amount of data amounting to gigabytes. Any
document in a WORM can be accessed very fast.

(iii) Erasable Optical Disk : These are optical disks where data can be
written, erased and re-written. This also applies a laser beam to write and re-
write the data. These disks may be used as alternatives to traditional disks.
Erasable optical disks are based on a technology known as magnetic optical
(MO). To write a data bit on the erasable optical disk the MO drive’s laser
beam heats a tiny, precisely defined point on the disk’s surface and magnetizes
it.

Flash drive:  Flash drives have many names — jump drives, thumb drives,
pen drives, and USB keychain drives. Regardless of what you call them, they all
refer to the same thing, which is a small data storage device that uses flash
memory and has a built-in USB connection.

Flash drives are typically no more than two to three inches in length and
less than an inch in width. Their size and shape may resemble a thumb or a small
pen (which is where the names “thumb drive” and “pen drive” come from).
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Flash drives are also very thin, often having a depth of less than a centimeter.
Because of their small form factor, they are highly portable and can easily fit in a
pocket or on a keychain (hence the name “keychain drive”).

Nowadays flash drives can store several gigabytes of information. Since
they are small in size but have large storage capacities, flash drives have replaced
most previous portable data storage mediums such as floppy disks and removable
hard disks like Zip disks. Because they have a built-in USB connection, flash
drives also don’t require a special disk drive to be used. Instead, they can be
used on any computer with a USB port, which nearly all modern computers
have. Below  is the diagram of a pen drive.

Fig. 1.6 Pen Drive

1.7 Language / Software
1.7.1 Introduction

In the previous lessons we discussed about the different parts and
configurations of computer. It has been mentioned that programs or instructions
have to be fed to the computer to do specific task. So it is necessary to provide
sequence of instructions so that your work can be done. We can divide the
computer components into two major areas, namely, hardware and software.
Hardware is the machine itself and its various individual equipment. It includes
all mechanical, electronic and magnetic devices such as monitor, printer, electronic
circuit, floppy and hard disk. The physical parts, which you can see and touch,
are collectively called hardware. Software, on the other hand, refers to the
instructions, or programs, that tell the hardware what to do. In this lesson we
will discuss about the other part, namely, software.

1.7.2 What is Software ?

As you know computer cannot do anything without instructions from the
user. In order to do any specific job you have to give a sequence of instructions
to the computer. This set of instructions is called a computer program. Software
refers to the set of computer programs, procedures that describe the programs,
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how they are to be used. We can say that it is the collection of programs, which
increase the capabilities of the hardware. Software guides the computer at every
step where to start and stop during a particular job. The process of software
development is called programming.

You should keep in mind that software and hardware are complementary
to each other. Both have to work together to produce meaningful result. Another
important point you should know that producing software is difficult and
expensive.

1.7.3 Software Types

Computer software is normally classified into two broad categories.

· Application Software

· System software

Application Software: Application Software is a set of programs to carry
out operations for a specific application. For example, payroll is an application
software for an organization to produce pay slips as an output. Application
software is useful for word processing, billing system, accounting, producing
statistical report, analysis of numerous data in research, weather forecasting,
etc. In later modules you will learn about MS WORD, Excel, Power Point, etc.
All these are application softwares.

Another example of application software is programming language. Among
the programming languages COBOL (Common Business Oriented Language)
is more suitable for business application whereas FORTRAN (Formula
Translation) is useful for scientific application. We will discuss about languages
in next section.

System Software: You know that an instruction is a set of programs that
has to be fed to the computer for operation of computer system as a whole.
When you switch on the computer the programs written in ROM is executed
which activates different units of your computer and makes it ready for you to
work on it. This set of program can be called system software. Therefore system
software may be defined as a set of one or more programs designed to control
the operation of computer system.

System software are general programs designed for performing tasks such
as controlling all operations required to move data into and out of the computer.
It communicates with printers, card reader, disk, tapes etc. monitor the use of
various hardware like memory, CPU etc. Also system software are essential for
the development of applications software. System Software allows application
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packages to be run on the computer with less time and effort. Remember that
it is not possible to run application software without system software.

Development of system software is a complex task and it requires extensive
knowledge of computer technology.  Due to its complexity it is not developed in
house. Computer manufactures build and supply this system software with the
computer system. DOS, UNIX and WINDOWS are some of the widely used
system software. Out of these UNIX and Windows-NT are  multi-user operating
systems whereas DOS and WINDOWS are single-user systems.

1.7.4 What is Language ?

You are aware with the term language. It is a system of communication
between you and me. Some of the basic natural languages that we are familiar
with are English, Hindi, Oriya etc. These are the languages used to communicate
among various categories of persons. But how you will communicate with your
computer. Your computer will not understand any of these natural languages for
transfer of data and instruction. So there are programming languages specially
developed so that you could pass your data and instructions to the computer to
do specific job. You must have heard names like FORTRAN, BASIC, COBOL
etc. These are programming languages. So instructions or programs are written
in a particular language based on the type of job. As an example, for scientific
application FORTRAN and C languages are used. On the other hand COBOL
is used for business applications.

1.7.5  Programming Languages

There are two major types of programming languages. These are Low
Level Languages and High Level Languages. Low Level languages are further
divided in to Machine language and Assembly language.

 Low Level Languages

The term low level means closeness to the way in which the machine has
been built. Low level languages are machine oriented and require extensive
knowledge of computer hardware and its configuration.

(a) Machine Language

 Machine Language is the only language that is directly understood by the
computer. It does not needs any translator program. We also call it machine
code and it is written as strings of 1’s (one) and 0’s (zero). When this sequence
of codes is fed to the computer, it recognizes the codes and converts it in to
electrical signals needed to run it. For example, a program instruction may look
like this:
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1011000111101

It is not an easy language for you to learn because of its difficult to understand.
It is efficient for the computer but very inefficient for programmers. It is considered
to the first generation language. It is also difficult to debug the program written in
this language.

Advantage

 The only advantage is that program of machine language run very fast
because no translation program is required for the CPU.

Disadvantages

1. It is very difficult to program in machine language. The programmer has
to know details of hardware to write program.

2. The programmer has to remember a lot of codes to write a program
which results in program errors.

3. It is difficult to debug the program.

 (b)  Assembly Language

It is the first step to improve the programming structure. You should know
that computer can handle numbers and letter. Therefore some combination of
letters can be used to substitute for number of machine codes.

The set of symbols and letters forms the Assembly Language and a translator
program is required to translate the Assembly Language to machine language.
This translator program is called ‘Assembler’. It is considered to be a second-
generation language.

Advantages

1. The symbolic programming of Assembly Language is easier to understand
and saves a lot of time and effort of the programmer.

2. It is easier to correct errors and modify program instructions.

3. Assembly Language has the same efficiency of execution as the machine
level language. Because this is one-to-one translator between assembly language
program and its corresponding machine language program.

Disadvantages:

1. One of the major disadvantages is that assembly language is machine
dependent. A program written for one computer might not run in other computers
with different hardware configuration.
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High Level Languages
You know that assembly language and machine level language require deep

knowledge of computer hardware where as in higher language you have to
know only the instructions in English words and logic of the problem irrespective
of the type of computer you are using.

Higher level languages are simple languages that use English and
mathematical symbols like +, -, %, / etc. for its program construction.

You should know that any higher level language has to be converted to
machine language for the computer to understand.

Higher level languages are problem-oriented languages because the
instructions are suitable for solving a particular problem. For example COBOL
(COmmon Business Oriented Language) is mostly suitable for business oriented
language where there is very little processing and huge output. There are
mathematical oriented languages like FORTRAN (Formula Translation) and
BASIC (Beginners All-purpose Symbolic Instruction Code) where very large
processing is required.

Thus a problem oriented language designed in such a way that its instruction
may be written more like the language of the problem. For example, businessmen
use business term and scientists use scientific terms in their respective languages.

Advantages of High Level Languages

Higher level languages have a major advantage over machine and assembly
languages that higher level languages are easy to learn and use. It is because that
they are similar to the languages used by us in our day to day life.

 Compiler

It is a program translator that translates the instruction of a higher level
language to machine language. It is called compiler because it compiles machine
language instructions for every program instructions of higher level language.
Thus compiler is a program translator like assembler but more sophisticated. It
scans the entire program first and then translates it into machine code.

The programs written by the programmer in higher level language is called
source program. After this program is converted to machine languages by the
compiler it is called object program.

A compiler can translate only those source programs, which have been
written, in that language for which the compiler is meant for.   For example
FORTRAN compiler will not compile source code written in COBOL language.
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Object program generated by compiler is machine dependent. It means
programs compiled for one type of machine will not run in another type. Therefore
every type of machine must have its personal compiler for a particular language.
Machine independence is achieved by using one higher level language in different
machines.

Interpreter

An interpreter is another type of program translator used for translating
higher level language into machine language. It takes one statement of higher
level languages, translate it into machine language and immediately execute it.
Translation and execution are carried out for each statement. It differs from
compiler, which translate the entire source program into machine code and does
involve in its execution.

The advantage of interpreter compared to compiler is its fast response to
changes in source program. It eliminates the need for a separate compilation
after changes to each program. Interpreters are easy to write and do not require
large memory in computer. The disadvantage of interpreter is that it is time
consuming method because each time a statement in a program is executed then
it is first translated. Thus compiled machine language program runs much faster
than an interpreted program.

1.8 Utilities
Utility: A program that performs a specific task related to the management

of computer functions, resources, or files, as password protection, memory
management, virus protection, and file compression.

Viruses: There are far too many nasty computer critters out there trying to
get into your computer. The most common term we call it virus but it may be
virus, Trojan horse , worm and blended threat.

Virus:   A virus is a program that replicates itself. It spreads by making
copies of itself on a computer or by inserting computer code into program or
operating system files. Viruses don’t always damage files or computers, but
they usually affect a computer’s performance and stability.

Are all Viruses harmful?

Yes, to varying degrees. Virus damage can range from slowing computer
performance to a loss of information and programs. In the worst case, viruses
delete or modify information and programs on your computer. Some e mail
viruses send confidential information in messages when spreading. Even when a
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virus is not directly damaging information, the process of replication can slow
your computer and Internet connection.

Worm

An unwanted  computer  program  that  duplicates  itself  across  a  computer
network. It uses up the  network’s  storage space and resources and can interfere
with the ability of network to function at all.  Most worms begin as e mail
attachments that infect a computer when they’re opened.

Trojan horse

A Trojan horse is a malicious software program that hides inside other
programs. It enters a computer hidden inside a legitimate program, such as a
screen saver. It then puts code into the operating system, which enables a hacker
to access the infected computer. Trojan horses do not usually spread by
themselves; they are spread by viruses, worms, or downloaded software.

Blended threat

A blended threat is a combination of some or all of the malicious programs
discussed in the sections above. Blended threats often begin when someone
interacts with a virus (such as opening an unsafe e mail attachment). The virus
automatically propagates using worm behavior, and then installs a Trojan horse
on the infected computer.

How do I prevent viruses?

Prevention of infection is much better.  Install an antivirus program. To be
most effective, an antivirus program should always be turned on, should scan
incoming e mail, and should scan file access.

 How do I know if my computer has a virus?

There is no single indicator of a virus infection, but some of the more common
effects include poor computer performance, pop-up ads displaying (even when
you have turned on a pop-up blocker or disconnected from the Internet).

Summary
The difference between  Computers and human beings  are:

1) Computer is a dumb machine and it cannot do any work without instruction
from the user.  It is you to decide what you want to do and in what sequence. So
a computer cannot take its own decision as you can.
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2) It does not have feelings or emotion, taste, knowledge and experience.
It does not distinguish between users.  Computers cannot learn by experience
as like humans.

These were some of the different types of computers used today. Looking
at the rate of advancement in technology, we can definitely look forward to
many more types of computers in the near future.

As like a digestive system of a human body ,With the block diagram of
computer we can have a basic idea of operations in computer .

Computer knows only two states that is ON and OFF. Binary system has
only two digits  0 and 1. So the Binary system is adopted in computers.

Difference between a Number and digit as follows

Number  means  set of digits where as digit means 0,1,2,3,4,5,6,7,8 or 9.
Suppose 56 is a number and it has only two digits 5 and 6.

We can convert from any system to any other system as follows.

Suppose if we want to convert from binary to octal system , first we convert
from binary to decimal system and then convert from decimal to octal system.

There are some  direct methods to convert from any system to any other
system.

Input is given to the computer not only through  input  devices , we can also
give input from remote  area through internet. We also get output(information)
from remote area through internet.

Printer  is used to  print many more things as we require. The printed copy
is known as printout. The storage devices are becoming many more types in
day to day changes of our lives. In future very small storage devices can store
very much large amount of data.

    In this unit we discussed about two types of software, namely, system
software and application software. System software controls the hardware part
of the computer. It is designed for performing tasks such as controlling all
operations required to move data into and out of the computer. It communicates
with printer, card reader, disk, tapes, etc. and monitors the use of various
components like memory, CPU, etc. DOS, UNIX and WINDOWS are three
important system softwares. Application software is a set of programs written
for specific purpose. Examples of application softwares are MS WORD, Lotus
1-2-3, COBOL, BASIC and FORTRAN. We have discussed about levels of
computer language.
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1. Both compiler and interpreter are program translators used for translating
higher level language into machine language. While compiler scans the entire
program first and  then translates it into machine code, an Interpreter translates
the program line by line.

2. FORTRAN (Formula Translation) and BASIC (Beginners All-purpose
Symbolic Instruction Code) are some of the high level languages.

To improve the system performance and to maintain standards we must
use utilities such as File management programs, Disk management programs,
Memory management software, Backup programs, data recovery programs ,
Data compression programs and Anti virus programs.

Short Answer Type Questions
1. What is a Computer?

2. What are the components used in Second generation computers?

3. What are the types  computers based on purpose?

4. What are the types  computers based on operation?

5. What are the different number systems?

6. Convert (42)10 into (?)2

7. Convert (84)10 into (?)8

8. Convert (143)10 into (?)16

9.  Convert(1100)2 into (?)10

10. Convert(253)8 into (?)10

11. Convert(2B)16 into (?)10

12. Convert(120)8 into (?)2

13. Convert(7F)16 into (?)2

14. Convert(111010)2 into (?)8

15. Convert(111110)2  into (?)16

16. Convert(4C)16 into (?)8

17. Convert (125)8 into (?)16

18. Why binary numbers are used in computers.
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19. Define input device.

20. Define output device.

21. Write the names of  two input and two output devices.

22. What is a scanner?

23. What is a light pen?

24. What is a printer and printout?

25. . Distinguish between bit and byte.

26. Define volatile and non-volatile memory.

27.  how many bytes for 1 GB memory?

28.  Expand RAM,ROM,PROM and EAPROM

29.  Write the names auxiliary storage devices.

30.  What is cache memory?

31.  What are registers?

32.  What is software and hardware?

33. What is computer Language?

34. Name the three different categories of computer languages.

35. What is machine language? Why is it required?

36. What are advantages and disadvantages of machine language .

37. What is assembly language? What are its advantages over machine
languages?

38. What is the difference between source program and object program?

39. What is higher level languages? Why are higher level languages are
easier to use.?

40. What is compiler? Why is it required?

41. What is interpreter? How does it differ from compiler?

42. What is an utility?

43. What is a virus?

44. What is a worm?
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45. What is Trojan horse?

46. What is blended threat?

Long Answer  Type Questions
1. Write about the generations of computers.

2. Explain the characteristics of computers.

3. Explain various computers based on purpose.(3 marks)

4. Explain various computers based on operation(3 marks)

5. Explain various computers based on size.(6 marks)

6. Draw the Block diagram of digital computer and explain each unit neatly.

7. Write about number systems.

8. Write about input devices.

9. Write about output devices.

10. Write about primary memory and secondary memory.

11.Write about secondary storage devices.

12. Write about RAM and ROM.

13. Write about different types of software  in details
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 Structure
2.1 Introduction to operating system, functions and its types

2.2  Features of DOS

2.3 Working with DOS Commands

2.4 Features of Windows

2.5 Components of Windows

Learning Objectives
After going through this unit you will be able to

explain the basic functions of operating system

explain the main functions of operating system

explain the types of operating system

explain GUI and CUI

explain the Booting process of msdos operating system

explain about the command prompt

Internal and external commands

 

2UNIT

Introduction to Operating System,
Functions
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 explain some internal commands

explain some  external commands

explain the aero snap features

brief discussion about taskbar

explain the gadgets

explain windows Help and support

explain the multitasking

file system

desktop components

control panel

device manager

taskbar properties.

2.1 Introduction to Operating System, Functions and Its
      Types

The job of the operating system(OS) is to operate the computer. The
operating system is a collection of programs that control the operation of all
hardware and other resources in the computer system.

The basic functions of  the Operating system are

1. Assigning processors for performing tasks.

2. Allocating  and managing memory, and other storage area

3. Command interpretation

4. Handling job transactions.

5. Maintains internal clock

6. Scheduling of various tasks.

7. Establishing and enforcing priorities for different jobs.

8. Co-ordinating and managing peripheral devices.

9. Input-output management
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10. Establishing data security and integrity.

Operating System Concepts

User programs interact with operating system using set of extended
instructions. These instructions are called “system calls”. These system calls are
used to create, delete and use various software objects that are manages by the
Operating systems. The following are common in any Operating system.

1. Process

2. Files

3. System Calls

4. The shell

5. Booting Process i. Boot Strap Loader

i. Check Programs

ii. Monitor Program

iii. Basic input/output System(BIOS) Program

iv. Utility Programs

v. File Maintenance Programs

Types of Operating systems

Operating systems are basically capable  to do all functions but the way of
processing or approach of the systems may vary from one Operating systems to
another. The following basic types of operating systems are

1. Batch Processing Systems

2. Interactive Operating systems

3. Multi-Programming Operating Systems

4. Multi-Processing Operating Systems

5. Multitasking systems

6. Multi-user Operating systems

7. Virtual storage systems

Basing on the features of the operating systems and the interface provided
they can be classified as
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a. User Friendly Operating System :- These Operating systems provide
a pleasant and easy to work environment, they are usually graphical based,
where the various options are represented as icons, menus etc. Windows 95,
Windows 98, Windows-NT are some of the user friendly Operating systems.

b.  Programming friendly Operating systems:- The programmer is
anyone who has fair knowledge about programming concepts and he is expected
to know the computer in a detailed manner. The programmer much concerned
about various utilities, functionalities, flexibility and powerful environment. UNIX,
XENIX,LINUX etc. are some of the character based interfaces which are very
powerful and programming friendly.

Character User Interfaces( CUI)

This user interface is character based, one gets prompts in characters and
a user has to type the characters. These were the interfaces which enabled the
programmers to do work easy, but they it is difficult to work in as we have to
type every instruction and commands . MS-DOS,UNIX,LINUX etc. are some
of the most popular character based operating systems.

Graphical User Interface(GUI)

This interface is graphical i.e. there are pictures, graphical objects, images,
menus etc . which have specific functionality’s. This interface provides very
pleasant environment to work on it. Here almost every action is automated, at
click of a button can get desired action done. Windows XP, Windows7, Windows-
NT are some of very popular GUI based Operating systems.

Functions of Operating System

There are Many Functions those are Performed by the Operating System
But the Main Goal of Operating System is to Provide the Interface between the
user and the hardware Means Provides the Interface for Working on the System
by the user. The various Functions those are Performed by the Operating System
are as Explained below:-

1. Resource management: Means Operating System will Manages all
the Resources those are Attached to the System means all the Resource like
Memory and Processor and all the Input output Devices those are Attached to
the System are Known as the Resources of the Computer System and the
Operating system will Manage all the Resources of the System. The Operating
System will identify at which Time the CPU will perform which Operation and in
which Time the Memory is used by which Programs. And which Input Device
will respond to which Request of the user means When the Input and Output
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Devices are used by the which Programs. So this will manage all the Resources
those are attached to the Computer System.

2  Storage Management: Operating System also Controls the all the
Storage Operations means how the data or files will be Stored into the computers
and how the Files will be Accessed by the users etc. All the Operations those
are Responsible for Storing and Accessing the Files is determined by the
Operating System Operating System also Allows us Creation of Files, Creation
of Directories and Reading and Writing the data of Files and Directories and
also Copy the contents of the Files and the Directories from One Place to Another
Place.

3.  Process Management : The Operating System also Treats the Process
Management means all the Processes those are given by the user or the Process
those are System ‘s own Process are Handled by the Operating System . The
Operating System will Create the Priorities for the user and also Start or Stops
the Execution of the Process and Also Makes the Child Process after dividing
the Large Processes into the Small Processes.

4.  Memory Management: Operating System also Manages the Memory
of the Computer System means Provide the Memory to the Process and Also
Deallocate the Memory from the Process. And also defines that if a Process
gets completed then this will deallocate the Memory from the Processes.

5.  Security management: Operating System also  Provides us Sharing
of Files between Multiple Users, and also Provides Security among users by
using user names and passwords for login.

2.2 Features of DOS
Introduction

Short for Microsoft Disk operating system, MS-DOS is a non-graphical
command line operating system derived from 86-DOS that was created for
IBM compatible computers. MS-DOS was first introduced by Microsoft in
August 1981 and was last updated in 1994 when MS-DOS 6.22 was released.
Today, MS-DOS is no longer used; however, the command shell, more commonly
known as the Windows command line is still used by many users. In the picture
to the right, is an example of what a MS-DOS window more appropriately
referred to as the Windows command line looks like under Microsoft Windows.

Disk Operating System

As the name suggests, the operating System is used for operating the
system or the computer. It is a set of computer programs and also known as
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DOS (Disk Operating System). The main functions of DOS  are to manage
disk files, allocate system resources according to the requirement. DOS provides
features essential to control hardware devices such as Keyboard, Screen, Disk
 Devices,  Printers, Modems and programs.

Basically, DOS is the medium through which the user and external devices
attached to the system communicate with the system. DOS translate the command
issued by the user in the format that is understandable by the computer and
instruct computer to work accordingly. It also translates the result and any error
message in the format for the user to understand.

DOS Boot-up  Sequence: When we switch on the computer , if the system
is MSDOS based ,then the sequence of files to be executed as follows. The
process is called Booting Process.

IO.SYS: A hidden file in the root directory of the primary drive. This file
provides the basic I/O capabilities for the system, allowing it the ability to
communicate with the different peripherals. IO.SYS directs the overall process
of loading the Operating System.

MSDOS.SYS: Also a hidden file in the root directory sometimes called
the kernal for DOS. When an application needs to access a device or peripheral,
this file translates the request into actions that IO.SYS can perform.

CONFIG.SYS: A user-configurable text file that usually contains device
drivers and system setup values.

COMMAND.COM: This is the Command Interpreter. It can accept
commands from the user, launch programs and pass this Information to
MSDOS.SYS.

AUTOEXEC.BAT: Another user-configurable text file that is used to set
system variables and load TSRs.

Command Prompt

After Completion of  booting  process, the Command prompt appears.
Command Prompt  provides an entry point for typing MSDOS commands and
other computer commands. The most important thing to know is that by typing
commands, you can perform tasks on your computer . Command Prompt is
typically only used by advanced users.

When you’re using Command Prompt, the term command prompt also
refers to the right angle bracket (>, also known as the greater than character)
that indicates the command line interface can accept commands. It looks like
C:\>.
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For an example , if we want to clear the screen , give the command as
C:\>CLS

2.3 Working with DOS commands
2.3.1 Introduction

There are two types of commands in MSDOS. They internal and external
commands.

2.3.2 Internal Commands
The internal commands reside in COMMAND.COM, which loads into

memory when the computer system is started; these commands do not reside
on disk. Commands  are executed from the MS-DOS prompt only.

? is used to know the details of any command followed by the command.

Ex: dir/? Displays the syntax of directory command.

Here some internal commands as follows

CLS: CLS is a command that allows a user to clear the complete contents
of the screen and leave only a prompt.

DATE: Display the current date and prompt for a new one. If no date is
entered, the current date

will be kept.

 TIME:Allows the user to view and edit the computer’s time(system time).

VER: It displays the version of MSDOS.

REN:Used to rename files and directories from the original name to a new
name.

TYPE: Displays the contents of text files.

DEL: DEL is a command used to delete one or more files from the computer.

2.3.3 External Commands
The external commands are files that do reside on disk and have an

extension of .COM, .EXE, or .BAT.

Format : Format is used to erase information off of a computer diskette or
fixed drive.
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The syntax of format as follows.

FORMAT volume [/FS:file-system] [/V:label] [/Q] [/A:size] [/C] [/X]

FORMAT volume [/V:label] [/Q] [/F:size]

FORMAT volume [/V:label] [/Q] [/T:tracks /N:sectors]

FORMAT volume [/V:label] [/Q] [/1] [/4]

FORMAT volume [/Q] [/1] [/4] [/8]

Volume Specifies the drive letter (followed by a colon), mount point,
or volume name.

/FS:filesystem Specifies the the file system (FAT, FAT32, or NTFS).

/V:label Specifies the volume label.

/Q Performs a quick format.

/C Files created on the new volume will be compressed by default.

/X Forces the volume to dismount first if necessary. All opened
handles to the volume would no longer be valid.

Examples

When using the format command, remember all information on the drive
you wish to format will be completely erased.

format a:

Would erase all the contents off a disk. Commonly used on a diskette that
has not been formatted or on a diskette you wish to erase.

format a: /q

Quickly erases all the contents of a floppy diskette. Commonly used to
quickly erase all information on the diskette.

format c:

This would erase the contents of your C: hard disk drive. In other words,
unless you wish to erase all your computer’s information, this command should
not be done unless you’re planning to start over.

FDISK:  Fdisk is used to delete and create partitions on the harddisk drive
in earlier versions of MS-DOS and Windows.
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Syntax

FDISK [/STATUS] /X

/Status Displays partition information

/X Ignores extended disk-access support (will not use LBA
support). Use this switch if you receive one of the below symptoms

Unable to access a drive from DOS versions prior to 7

Disk access messages.

Stack overflow messages

High amounts of data corruption

Extra drive letters

2.4 Features  of  Windows
Introduction

What is Windows 7?

 

Windows 7 is the latest version of a series of Operating Systems that
Microsoft has produced for use on personal computers. It is the follow-up to
the Windows Vista Operating System which was released in 2006. An operating
system allows your computer to manage software and perform essential tasks.
It is also a Graphical User Interface (GUI) that allows you to visually interact
with your computer’s functions in a logical, fun and easy way.

For example, in Windows 7 you can view two windows side by side by
using the Aero Snap feature.

 Fig 2.1 Two Windows Overlapping
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This feature automatically sizes or snaps two windows to fit together on the
screen thus allowing you the convenience of viewing them next to each other.

   Fig 2.1 Aero Snap View

 What Can You Do on Windows 7?

  Fig 2.2 Aero Flip 3D

Aero

Sort through open windows with Aero Flip 3D.

Aero is an interface that makes your visual interactions with the desktop
fun and easy.
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 Aero Peek makes your open windows transparent so you may see
your desktop. It also allows you to peek at items in your taskbar for a thumbnail
preview.

 Aero Snap is a quick way to resize your windows to make them easier
to read, organize and compare.

 Aero Flip allows you to preview all your open windows from a central
window or 3D view that you can flip through.

 Aero Shake allows you to take your mouse and shake only the open
window you want to focus on and the rest will disappear.

Taskbar

Fig 2.3 Taskbar

Get immediate access with Jump List

The taskbar is now more convenient to use with larger views and easier
access.

 Jump Lists allow you to right click on an icon in the taskbar and
immediately access items like music, videos or web pages that you use on a
regular basis.
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 Pin allows you to place programs on the taskbar and rearrange the
order of the icons as you wish.

 Action Center allows you to control the alerts and pop-ups you receive
regarding maintenance and security.Search Find documents fast with the new
Search

Fig 2.4 Search Bar

As soon as you start typing in the Search bar of the Start Menu you will
instantly see a list of relevant options grouped by categories with highlighted
keywords and text. This allows you to easily scan for the documents, music,
pictures and email you are looking for.

Desktop Gadgets (Overview)

Fig 2.5 Desktop Gadgets

Windows contains mini-programs called gadgets, which offer information
at a glance and provide easy access to frequently used tools. For example, you
can use gadgets to display a picture slide show, view continuously updated
headlines, or look up contacts.
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Why use desktop gadgets?

Desktop gadgets can keep information and tools readily available for you
to use. For example, you can display news headlines right next to your open
programs. This way, if you want to keep track of what’s happening in the news
while you work, you don’t have to stop what you’re doing to switch to a news
website.

You can use the Feed Headlines gadget to show the latest news headlines
from sources you choose. You don’t have to stop working on your document,
because the headlines are always visible. If you see a headline that interests you,
you can click that headline, and your web browser will open directly to the
story.

Getting started with gadgets

To understand how to use gadgets, let’s explore three gadgets: the Clock,
Slide Show, and Feed Headlines.

How does the Clock work?

When you right-click the Clock, you’ll see a list of things you can do with
the gadget, including closing the Clock, keeping it on top of your open windows,
and changing the Clock’s options (such as its name, time zone, and appearance).

You can right-click a gadget to see a list of things you can do with it.

Tip

 If you point to the Clock gadget, a Close button and an Options button
will appear near its upper-right corner.

1. Right-click Slide Show and click Options.

2. In the Show each picture list, select the number of seconds to show
each picture.

3. In the Transition between pictures list, select the transition you want and
click OK.

1. Right-click Feed Headlines and click Options.

2. In the Display this feed list, click the feed you want to display and click
OK.

Note

• To scroll through the headlines, click the arrows on the lower edge of the
Feed Headlines gadget.
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Adding and removing gadgets

You can add any gadget that’s installed on your computer to the desktop.
If you want, you can add multiple instances of a gadget. For example, if you are
keeping track of time in two time zones, you can add two instances of the Clock
gadget and set the time of each accordingly.

 Right-click the gadget, and then click Close Gadget.

Organizing gadgets

You can drag a gadget to a new position anywhere on the desktop.

Help and support

At some point, you’re likely to run into a computer problem or confusing
task. To figure it out, you’ll need to know how to get the right help. This article
provides an overview of the best techniques.

Windows Help and Support is the built-in help system for Windows. It’s a
place to get quick answers to common questions, suggestions for troubleshooting,
and instructions for how to do things. If you need help with a program that’s not
part of Windows, you’ll need to consult that program’s Help (see “Getting help
with a program” below).

To open Windows Help and Support, click the Start button , and
then click Help and Support.

Get the latest Help content

If you’re connected to the Internet, make sure Windows Help and Support
is set to Online Help. Online Help includes new Help topics and the latest versions
of existing topics.

1. On the toolbar in Windows Help and Support, click Options, and then
click Settings.

2. Under Search results, select the Improve my search results by using
online Help (recommended) check box, and then click OK. The words Online
Help will be displayed in the lower-right corner of the Help and Support window
when you are connected.

Search Help

The fastest way to get help is to type a word or two in the search box. For
example, to get information about wireless networking, type gadgets, and then
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press Enter. A list of results appears, with the most useful results shown at the
top. Click one of the results to read the topic.

Fig 2.6 Search Help

Tip

• You can also access Help by pressing F1. This function key opens Help
in almost any program.

2.5 Components of Windows
Introduction

In this chapter we discuss the about multitasking , file system, desktop
components,device manager, etc.,

2.5.1 Multitasking
Multitasking allows the user to activate and accomplish more than one task

at a time. For example, work on a document file in MSWORD programs, while
copying file from other computer available in the network, and also can listen
songs through Windows Media Player. With Windows 7 environment, the user
can do more than one task a time.

2.5.2 File system
File system means creating, copying, moving, saving, opening, finding,

renaming ,deleting of files or folders.

Working with files and folders

A file is an item that contains information—for example, text or images or
music. When opened, a file can look very much like a text document or a picture



 Paper - I   Computer Fundamentals and MS-Office 53

that you might find on someone’s desk or in a filing cabinet. On your computer,
files are represented with icons;(icon is a small picture that represents file, folder,
program or other object or function) this makes it easy to recognize a type of file
by looking at its icon. Here is an  icon:

      Tooba

     A folder is a container you can use to store files in. If you had thousands
of paper files on your desk, it would be nearly impossible to find any particular
file when you needed it. That’s why people often store paper files in folders
inside a filing cabinet. On your computer, folders work the same way. Here are
some typical folder icons:

  

An empty folder (left); a folder containing files (right)

Folders can also store other folders. A folder within a folder is usually
called a subfolder. You can create any number of subfolders, and each can hold
any number of files and additional subfolders.

Using libraries to access your files and folders

When it comes to getting organized, you don’t need to start from scratch.
You can use libraries  a feature new to this version of Windows, to access your
files and folders, and arrange them in different ways. Here’s a list of the four
default  libraries and what they’re typically used for:

Documents library. Use this library to organize and arrange word-
processing documents, spreadsheets, presentations, and other text-related files.

Pictures library. Use this library to organize and arrange your digital
pictures, whether you get them from your camera, scanner, or in e mail from
other people.

Music library. Use this library to organize and arrange your digital
music, such as songs that you rip from an audio CD or that you download  from
the Internet.

Videos library. Use this library to organize and arrange your videos,
such as clips from your digital camera or camcorder, or video files that you
download from the Internet.
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To open the Documents, Pictures, or Music libraries, click the Start

button ,  and then click Documents, Pictures, or Music.

Viewing and arranging files and folders

When you open a folder or library, you can change how the files look in the
window. For example, you might prefer larger (or smaller) icons or a view that
lets you see different kinds of information about each file. To make these kinds
of changes, use the Views button in the toolbar.

Fig 2.7 Arranging Files and Folders

Each time you click the left side of the Views button, it changes the way
your files and folders are displayed by cycling through five different views: Large
Icons, List, a view called Details that shows several columns of information
about the file, a smaller icon view called Tiles, and a view called Content that
shows some of the content from within the file.

Finding files

Depending on how many files you have and how they are organized, finding
a file might mean browsing through hundreds of files and subfolders—not an
easy task. To save time and effort, use the search box to find your file.

Fig 2.8 Finding Files



 Paper - I   Computer Fundamentals and MS-Office 55

The search box is located at the top of every window. To find a file, open
the folder or library that makes the most sense as a starting point for your search,
click the search box, and start typing. The search box filters the current view
based on the text that you type. Files are displayed as search results if your
search term matches the file’s name, tags or other properties, or even the text
inside a text document.

Copying and moving files and folders

Occasionally, you might want to change where files are stored on your
computer. You might want to move files to a different folder, for example, or
copy them to  CDs or memory cards.

Copying

1. Select the folder to be copied,

2. Click on Copy

3. Move the pointer(cursor) to the desired location to where you want

4. Click on Paste

Moving

1. Select the folder to be copied,

2. Click on Cut

3. Move the pointer(cursor) to the desired location to where you want

4.  Click on Paste

Most people copy and move files using a method called drag and drop.
Start by opening the folder that contains the file or folder you want to move.
Then, open the folder where you want to move it to in a different window.
Position the windows side by side on the desktop so that you can see the contents
of both.

Creating and deleting files

The most common way to create new files is by using a program. For
example, you can create a text document in a word-processing program or a
movie file in a video-editing program.

Saving    After creation of a file , it has to be  saved for  need in the future.

When you are ready to save your work, click the Save button . In the
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dialog box that appears, type a file name that will help you find the file again in
the future, and then click Save.

By default, most programs save files in common folders like My Documents
and My Pictures, which makes it easy to find the files again next time. You can
also save your files in the desired location.

Deleting

When you no longer need a file, you can remove it from your computer to
save space and to keep your computer from getting cluttered with unwanted
files. To delete a file, open the folder or library that contains the file, and then
select the file. Press Delete on your keyboard and then, in the Delete File dialog
box, click Yes.

When you delete a file, it’s temporarily stored in the Recycle Bin. Think of
the Recycle Bin as a safety net that allows you to recover files or folders that
you might have accidentally deleted.

Opening an existing file

To open a file, double-click it. The file will usually open in the program that
you used to create or change it. For example, a text file will open in your word-
processing program.

That’s not always the case, though. Double-clicking a picture file, for
example, will usually open a picture viewer. To change the picture, you need to
use a different program. Right-click the file, click Open with, and then click the
name of the program that you want to use.

2.5.3 The Desktop Components(Overview)
The desktop is the main screen area that you see after you turn on your

computer and log on to Windows. Like the top of an actual desk, it serves as a
surface for your work. When you open programs or folders, they appear on the
desktop. You can also put things on the desktop, such as files and folders, and
arrange them however you want.

The desktop is sometimes defined more broadly to include the taskbar.
The taskbar sits at the bottom of your screen. It shows you which programs are
running and allows you to switch between them. It also contains the Start
button  , which you can use to access programs, folders, and computer
settings.
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Working with desktop icons

Icons are small pictures that represent files, folders, programs, and other
items. When you first start Windows, you’ll s ee at least one icon on your
desktop: The Recycle Bin (more on that later). Your computer manufacturer
might have added other icons to the desktop. Some examples of desktop icons
are shown below.

Examples of desktop icons

Fig 2.9 Desktop Icons

Double-clicking a desktop icon starts or opens the item it represents.

Adding and removing icons from the desktop

You can choose which icons appear on the desktop—you can add or
remove an icon at any time. Some people like a clean, uncluttered desktop with
few or no icons. Others place dozens of icons on their desktop to give them
quick access to frequently used programs, files, and folders.

If you want easy access from the desktop to your favorite files or programs,
you can create shortcuts to them. A shortcut is an icon that represents a link to
an item, rather than the item itself. When you double-click a shortcut, the item
opens. If you delete a shortcut, only the shortcut is removed, not the original
item. You can identify shortcuts by the arrow on their icon.

Fig 2.10 A file icon(left) and a shortcut icon(right)

A file icon (left) and a shortcut icon (right)
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 Right-click the icon, and then click Delete. If the icon is a shortcut, only
the shortcut is removed; the original item is not deleted.

Moving icons around

Windows stacks icons in columns on the left side of the desktop. But you’re
not stuck with that arrangement. You can move an icon by dragging it to a new
place on the desktop.

You can also have Windows automatically arrange your icons. Right-click
an empty area of the desktop, click View, and then click Auto arrange icons.
Windows stacks your icons in the upper-left corner and locks them in place. To
unlock the icons so that you can move them again, click Auto arrange icons
again, clearing the check mark next to it.

Selecting multiple icons

To move or delete a bunch of icons at once, you must first select all of
them. Click an empty area of the desktop and drag the mouse. Surround the
icons that you want to select with the rectangle that appears. Then release the
mouse button. Now you can drag the icons as a group or delete them.

Fig 2.11 Selecting Multiple Icons

Select multiple desktop icons by dragging a rectangle around them

Hiding desktop icons

If you want to temporarily hide all of your desktop icons without actually
removing them, right-click an empty part of the desktop, click View, and then
click Show desktop items to clear the check mark from that option. Now no
icons are displayed on the desktop. You can get them back by clicking Show
desktop items again.

The Recycle Bin

When you delete a file or folder, it doesn’t actually get deleted right away—
it goes to the Recycle Bin. That’s a good thing, because if you ever change your
mind and decide you need a deleted file, you can get it back.
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Fig 2.12 The Recycle Bin when full (left) and empty (right)

If you’re sure that you won’t need the deleted items again, you can empty
the Recycle Bin. Doing that will permanently delete the items and reclaim any
disk space they were using.

2.5.4  Control Panel
You can use Control Panel to change settings for Windows. These settings

control nearly everything about how Windows looks and works, and they allow
you to set up Windows so that it’s just right for you.

Fig 2.13 Control Panel

Tip

If you browse Control Panel by icons, you can quickly jump ahead to an
item in the list by typing the first letter of the item’s name. For example, to jump
ahead to Gadgets, type G, and the first Control Panel item beginning with the
letter G is selected in the window.
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2.5.5  Device Manager
Using Device Manager, you can view and update the device drivers  installed

on your computer, check to see if hardware is working properly, and modify
hardware settings.

 

Fig 2.14 Device Manager

If you are prompted for an administrator password or confirmation, type
the password or provide confirmation.

Note

 Here’s another way to open Device Manager: Click the Start button
. In the search box, type Device Manager, and then, in the list of results,

click Device Manager.

2.5.6 The Taskbar (Overview)
The taskbar is the long horizontal bar at the bottom of your screen. Unlike

the desktop, which can get obscured by open windows, the taskbar is almost
always visible. It has three main sections:

a) The Start button  , which opens the Start menu.

b) The middle section, which shows you which programs and files you
have open and allows you to quickly switch between them.
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c) The notification, which includes a clock and icons (small pictures) that
communicate the status of certain programs and computer settings.

a. Start menu

Fig 2.15 Start Menu

b. Middle section

You’re likely to use the middle section of the taskbar the most, so let’s look
at it first.

If you open more than one program or file at a time, you can quickly start
piling up open windows on your desktop. Because windows often cover each
other or take up the whole screen, it’s sometimes hard to see what else is
underneath or remember what you’ve already opened.

Fig 2.16  Each program has its own button on the  taskbar

Click a taskbar button to switch to that window
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That’s where the taskbar comes in handy. Whenever you open a program,
folder, or file, Windows creates a corresponding button on the taskbar. The
button shows an icon that represents the open program. In the picture below,
two files are  opened  in ms word named “2.5  multitasking” and one more file
“the taskbar”.

Minimize and restore windows

When a window is active (its taskbar button is highlighted), clicking its
taskbar button minimizes the window. That means that the window disappears
from the desktop. Minimizing a window doesn’t close it or delete its contents—
it temporarily removes it from the desktop.

c. The Notification Area

The notification area, on the far right side of the taskbar, includes a clock
and a group of icons. It looks like this.

Fig 2.17 Notification Area

These icons communicate the status of something on your computer or
provide access to certain settings. The set of icons you see depends on which
programs or services you have installed and how your computer manufacturer
set up your computer.

When you move your pointer to a particular icon, you will see that icon’s
name or the status of a setting. For example, pointing to the volume icon shows
the current volume level of your computer. Pointing to the network icon displays
information about whether you are connected to a network, the connection
speed, and the signal strength.

Double-clicking an icon in the notification area usually opens the program
or setting associated with it. For example, double-clicking the volume icon opens
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the volume controls. Double-clicking the network icon opens Network and
Sharing Center.

To reduce clutter, Windows hides icons in the notification area when you
haven’t used them in a while. If icons become hidden, click the Show hidden
icons button to temporarily display the hidden icons.Click the Show hidden
icons button to display all icons in the notification area

Customize the Taskbar

There are many ways to customize the taskbar to suit your preferences.
For example, you can move the entire taskbar to the left, right, or top edge of
the screen. You can make the taskbar larger, have Windows automatically hide
it when you’re not using it, and add toolbars to it.

Summary
Mastermind

Operating System also performs Many Functions and for those Reasons
we can say that Operating System is a Mastermind. It provides Booting without
an Operating System and Provides Facility to increase the Logical Memory of
the Computer System by using the Physical Memory of the Computer System
and also provides various Types of Formats Like NTFS and FAT File Systems.
And Operating System also controls the Errors those have been Occurred into
the Program and Also Provides Recovery of the System when the System gets
Damaged Means When due to Some Hardware Failure , if System Doesn’t
Works properly then this Recover the System and also Correct the System and
also Provides us the Backup Facility. And Operating System also breaks the
large program into the Smaller Programs those are also called as the threads.
And execute those threads one by one.

       Today, most computer users are only familiar with how to navigate
Microsoft Windows using the mouse. Unlike Windows, MS-DOS is a
command-line and is navigated by using MS-DOS commands. For example, if
you wanted to see all the files in a folder in Windows you would double-click
the folder to open the folder in Windows. In MS-DOS to view that same folder
you would navigate to the folder using the cd command and then list the files in
that folder using the dir command.

                     Before introduction of windows users operated MSDOS.
But Nowadays MSDOS operating system is used in very rare case.  Every
body familiar with Windows because it is Graphical User Interface(GUI),where
as in msdos user has to remember the commands .
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There are many commands both internal and external. Here we can not
explain all the commands. But there is a facility to know about any command by
using ? followed by particular command .

Windows 7 introduces aero , gadgets etc in latest versions

The following editions of Windows 7 include Aero:

 Windows 7 Enterprise

 Windows 7 Home Premium

 Windows 7 Professional

 Windows 7 Ultimate

Aero is not included in Windows 7 Home Basic or Windows 7 Starter.
You can find out which edition of Windows 7 you have on your computer by
opening System in Control Panel.

The difference between Copy and Move is  When you make a copy a file
the file is in the source as well as in the destination, where as when you make a
move the file is only in the destination and no more in the source.

Model Questions
Short Answer Types Questions

1. Define an operating system.

2. What is GUI?

3. What is CUI?

4. Expand GUI, CUI, BIOS and MSDOS.

5. What are the main functions of  DOS?

6. What is an internal command?

7. What is an external command?

8. What is an aero?

9. What is search bar?

10. What is gadget?

11.What is help and support in windows?

12. What is multitasking?
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13. What is file system?

14. What are four default libraries in library?

15. What is an icon?

16. What is a folder?

17. What is desktop?

18. What is recycle bin?

19. What is control panel?

20. What is device manager?

21. What is notification area in taskbar?

Long Answer Types Questions
1. Write the main functions of an operating system?

2. Write the Booting process in MSDOS.

3. Write about some internal commands.

4. Write about format and fdisk commands.

5. Write about aero options.

6. Write about gadgets.

7. Explain the help and support in windows.

8. Write about file system.

9. Write about desktop components

10. Write about control panel

11. Write about device manager

12. Write about taskbar?
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3UNIT

Microsoft - Word

Structure
3.1 Introduction to Word Processing

3.2 Editing a document

3.3 Move and Copy text

3.4 Formatting text and Paragraph

3.5 Find and replace text and spell checking

3.6 Tabs

3.7 Enhancing a document(Page layout).

3.8 Tables

3.9 Graphics

3.10 Mail Merge

3.11 Miscellaneous features of word

Learning Objectives
After going through this unit you will be able to

 Explain office button, ribbon and screen layout.

 Open an existed document
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 Create a new document

 Saving a document

 Renaming a document

 Working with multiple documents

 Document views

 Closing a document

 Explain copy text

 Explain move a text

 Explain help system

 formatting text with   font style, size, colour

 formatting paragraph with styles, size, colour

 line spacing in paragraph

  add borders and shading to paragraphs

 Alignment to the paragraphs

 Find a text with options

 Find and replace a text

 Correct the spellings by spell checker

 Undo changes

 Thesaurus

 Autocorrect

 New default  dictionary

 Word count

 Using default tab positions

 Using define tab positions

 Alignments in tabs

 Explain page layout options

Themes
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Page setup

Page background

Header and footer

 Create tables

 Insert rows and columns

 Delete rows and columns

 Borders to tables

 Delete table

 Formatting

 Alignment and many more

 Draw the shapes , symbols , smart art , pictures

 Draw equations , illustrations , rotation of shapes, water marks

 Create a mail merge

 Here we are giving a simple  sample  mail merge with only two fields
candidate name and designation. The content is nearly same but
addressee’s and designations are different.

 Explain bullets and numbers

 Explain word art

3.1 Introduction to Word Processing
A word processor enables you to create a document, store it electronically

on a disk, display it on a screen, modify it by entering commands and characters
from the keyboard, and print it on a printer.

The great advantage of word processing over using a typewriter is that you
can make changes without retyping the entire document. If you make a typing
mistake, you simply back up the course and correct your mistake. If you want
to delete a paragraph, you simply remove it, without leaving a trace. It is equally
easy to insert a word, sentence, or paragraph in the middle of a document.
Word processors also make it easy to move sections of text from one place to
another within a document, or between documents. When you have made all
the changes you want, you can send the file to a printer to get a hardcopy.
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Screen Layout

Fig 3.1 Screen Layout

Menus

When you begin to explore Word 2007 you will notice a new look to the
menu bar. There are three features that you should remember as you work
within Word 2007: the Microsoft Office Button, the Quick Access Toolbar, and
the Ribbon. These three features contain many of the functions that were in the
menu of previous versions of Word. The functions of these three features will be
more fully explored below.

The Microsoft Office Button

Fig 3.2 Microsoft Office button
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The Microsoft Office button performs many of the functions that were located
in the File menu of older versions of Word. This button allows you to create a
new document, open an existing document, save or save as, print, send (through
email or fax), publish or close.

The Ribbon

Fig 3.3 Ribbon

The Ribbon is the panel at the top portion of the document. It has seven
tabs: Home, Insert, Page Layout, References, Mailings, Review, and View that
contain many new and existing features of Word. Each tab is divided into groups.
The groups are logical collections of features designed to perform functions that
you will utilize in developing or editing your Word document. Commonly used
features are displayed on the Ribbon, to view additional features within each
group, click on the arrow at the bottom right of each group.

Fig 3.4 Ribbon features

Each of the tabs contains the following tools:

Home: Clipboard, Fonts, Paragraph, Styles, and Editing.

Insert: Pages, Tables, Illustrations, Links, Header & Footer, Text, and
Symbols

Page Layout: Themes, Page Setup, Page Background, Paragraph, Arrange

References: Table of Contents, Footnote, Citation & Bibliography,
Captions, Index, and Table of Authorities

Mailings: Create, Start Mail Merge, Write & Insert Fields, Preview Results,
Finish
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Review: Proofing, Comments, Tracking, Changes, Compare, Protect

View: Document Views, Show/Hide, Zoom, Window, Macros

Quick Access Toolbar

Fig 3.5 Quick Access Toolbar

The quick access toolbar is a customizable toolbar that contains commands
that you may want to use. You can place the quick access toolbar above or
below the ribbon. To change the location of the quick access toolbar, click on
the arrow at the end of the toolbar and click on Show Below the Ribbon.

Fig 3.6

You can also add items to the quick access toolbar. Right click on any item
in the Office Button or the Ribbon and click on Add to Quick Access Toolbar
and a shortcut will be added to the Quick Access Toolbar.

Fig 3.7

Quick Access Toolbar
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 3.2 Editing a Document
Create a New Document

There are several ways to create new documents, open existing documents,
and save documents in Word:

 Click the Microsoft Office Button  and Click New  or

 Press CTRL+N (Depress the CTRL key while pressing the “N”) on the
keyboard

You will notice that when you click on the Microsoft Office Button and
Click New, you have many choices about the types of documents you can
create. If you wish to start from a blank document, click Blank.

Fig 3.8

If you wish to start from a template you can browse through your choices
on the left, see the choices on center screen, and preview the selection on the
right screen.

Opening an Existing Document

• Click the Microsoft Office Button   and Click Open, or

• Press CTRL+O (Depress the CTRL key while pressing the “O”) on the
keyboard, or

• If you have recently used the document you can click the Microsoft Office

Button  and click the name of the document in the Recent Documents
section of the window Insert picture of recent docs

Saving a Document
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• Click the Microsoft Office Button and Click Save or Save As
           (remember, if you’re sending the document to someone who does not
           have Office 2007, you will need to click the Office Button, click Save
          As, and Click Word 97-2003 Document), or

• Press CTRL+S (Depress the CTRL key while pressing the “S”) on the
          keyboard, or

• Click the File icon on the Quick Access Toolbar

Fig 3.9 Saving a Document

Renaming Documents

To rename a Word document while using the program:

• Click the Office Button  and find the file you want to rename.

• Right-click the document name with the mouse and select Rename from
            the shortcut menu.

• Type the new name for the file and press the ENTER key.

Fig 3.10 Renaming a Document
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Working on Multiple Documents

Several documents can be opened simultaneously if you are typing or editing
multiple documents at once.  All open documents will be listed in the View Tab
of the Ribbon when you click on Switch Windows.  The current document has
a checkmark beside the file name.  Select another open document to view it.

Fig 3.11 Working on Multiple Documents

Document Views

There are many ways to view a document in Word.

Print Layout:  This is a view of the document as it would appear when
printed.  It includes all tables, text, graphics, and images.

Full Screen Reading:  This is a full view length view of a document. 
Good for viewing two pages at a time.

Web Layout:  This is a view of the document as it would appear in a web
browser.

Outline:  This is an outline form of the document in the form of bullets.

Draft:  This view does not display pictures or layouts, just text.

To view a document in different forms, click the document views shortcuts
at the bottom of the screen or

Click the View Tab on the Ribbon

Click on the appropriate document view.

Fig 3.12
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Close a Document  :   To close a document:

Click the Office Button

Click Close

Typing and inserting Text

To enter text, just start typing! The text will appear where the blinking
cursor is located. Move the cursor by using the arrow buttons on the keyboard
or positioning the mouse and clicking the left button. The keyboard shortcuts
listed below are also helpful when moving through the text of a document:

Move Action                                             Keystroke

Beginning of the line                                     HOME
End of the line                                              END
Top of the document                                   CTRL+HOME
End of the document                                   CTRL+END

3.3 Move and Copy Text
Selecting Text

To change any attributes of text it must be highlighted first. Select the text
by dragging the mouse over the desired text while keeping the left mouse button
depressed, or hold down the SHIFT key on the keyboard while using the arrow
buttons to highlight the text. The following table contains shortcuts for selecting
a portion of the text:

Deselect the text by clicking anywhere outside of the selection on the page
or press an arrow key on the keyboard.

Inserting Additional Text

Text can be inserted in a document at any point using any of the following
methods:

Selection
Whole word
Whole paragraph
Several words or lines

Entire document

Technique
double-click within the word
triple-click within the paragraph
drag the mouse over the words, or hold down
SHIFT while using the arrow keys
choose Editing | Select | Select All from the
Ribbon, or press CTRL+A
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• Type Text:  Put your cursor where you want to add the text and begin
typing

Copy and Paste Text:  Highlight the text you wish to copy and right
click and click Copy, put your cursor where you want the text in the document
and right click and click Paste.

  Cut and Paste Text:  Highlight the text you wish to copy and right click
and click Cut, put your cursor where you want the text in the document and
right click and click Paste.

Drag Text:  Highlight the text you wish to move, click on it and drag it
to the place where you want the text in the document.

You will notice that you can also use the Clipboard group on the Ribbon.

Fig 3.13 Clipboard button

Rearranging Blocks of Text

To rearrange text within a document, you can utilize the Clipboard Group
on the Home Tab of the Ribbon.Insert picture of clipboard group labeled.

Move text:  Cut and Paste or Drag as shown above

     Copy Text:  Copy and Paste as above or use the Clipboard group on
the Ribbon.

Paste Text:  Ctrl + V (hold down the CTRL and the “V” key at the
same time) or use the Clipboard group to Paste, Paste Special, or Paste as
Hyperlink
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Fig 3.14 Paste button

Deleting Blocks of Text

Use the BACKSPACE and DELETE keys on the keyboard to delete
text. Backspace will delete text to the left of the cursor and Delete will erase text
to the right. To delete a large selection of text, highlight it using any of the methods
outlined above and press the DELETE key.

Help System

Click the Microsoft Office Help button  in the upper right or the F1
key on your keyboard to open Help on your computer. The first time you use
the Help feature in Microsoft Office programs, the online Help window appears
in a default location and size on your screen. You can change the way the Help
window is displayed. After that, when you open the Help window, the settings
that you made are maintained.

Each program in Microsoft Office has a separate Help window. This means
that when you open the Help window from one program, such as Microsoft
Office Word, and then go to another program, such as Microsoft Office Outlook,
and open Help, you see two separate Help windows. Microsoft Office maintains
unique settings for each of these Help windows. For example, the Help window
for Word maintains a different position, size, and Keep On Top state than the
Help window for Outlook.

3.4 Formatting Text and Paragraph
Introduction

Word allows you to format the text by applying various text styles, such as
bold, underline, italic, superscript, subscript, strike through etc.,



     Computer Graphics and Animation78

3.4.1  Formatting Text
A style is a format enhancing tool that includes font typefaces, font size,

effects (bold, italics, underline, etc.), colors and more.  You will notice that on
the Home Tab of the Ribbon, that you have several areas that will control the
style of your document:  Font, Paragraph, and Styles.

Fig 3.15 Home tab of the ribbon

Change Font Typeface and Size

To change the font typeface

Click the arrow next to the font name and choose a font.

Fig 3.16

Remember that you can preview how the new font will look by highlighting
the text, and hovering over the new font typeface.

Fig 3.17

To change the font size

Click the arrow next to the font size and choose the appropriate size, or

Click the increase or decrease font size buttons.
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Fig 3.18  To Change the size

Font Styles and Effects

Font styles are predefined formatting options that are used to emphasize
text.  They include:  Bold, Italic, and Underline.  To add these to text:

Select the text and click the Font Styles included on the Font Group of
the Ribbon, or

Select the text and right click to display the font tools.

Fig 3.19 Font Styles and effects

Change Text Color

To change the text color:

 Select the text and click the Colors button included on the Font Group
of the Ribbon, or

 Highlight the text and right click and choose the colors tool.

 Select the color by clicking the down arrow next to the font color button.

Fig 3.20 Change Text Color
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Highlight Text

Highlighting text allows you to use emphasize text as you would if you had
a marker.  To highlight text:

Select the text

 Click the Highlight Button on the Font Group of the Ribbon, or

 Select the text and right click and select the highlight tool

To change the color of the highlighter click on down arrow next to the
highlight button.

Fig 3.21 Highlight text

Copy Formatting

If you have already formatted text the way you want it and would like
another portion of the document to have the same formatting, you can copy the
formatting.  To copy the formatting, do the following:

 Select the text with the formatting you want to copy.

 Copy the format of the text selected by clicking the Format Painter
button on the Clipboard Group of the Home Tab.

Fig 3.22 Copy formatting

Apply the copied format by selecting the text and clicking on it.

Clear Formatting

To clear text formatting:

Select the text you wish to clear the formatting

Click the Styles dialogue box on the Styles Group on the Home Tab

Click Clear All
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Fig 3.23 Clear formatting

3.4.2 Formatting Paragraph
Formatting paragraphs allows you to change the look of the overall

document.  You can access many of the tools of paragraph formatting by clicking
the Page Layout Tab of the Ribbon or the Paragraph Group on the Home
Tab of the Ribbon.

Fig 3.24 Formatting paragraph
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Change Paragraph Alignment

The paragraph alignment allows you to set how you want text to appear. 
To change the alignment:

Click the Home Tab

Choose the appropriate button for alignment on the Paragraph Group.

Align Left:  the text is aligned with your left margin.

Center:  The text is centered within your margins.

Align Right:  Aligns text with the right margin.

Justify:  Aligns text to both the left and right margins.

Fig 3.25 Paragraph alignment

Indent Paragraphs

Indenting paragraphs allows you set text within a paragraph at different margins.

There are several options for indenting:

First Line:  Controls the left boundary for the first line of a paragraph

Hanging:  Controls the left boundary of every line in a paragraph except
the first one

Left:  Controls the left boundary for every line in a paragraph

Right:  Controls the right boundary for every line in a paragraph

To indent paragraphs, you can do the following:

Fig 3.26 Indent alignment
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 Click the Indent buttons to control the indent.

Click the Indent button repeated times to increase the size of the indent.

 Click the dialog box of the Paragraph Group

 Click the Indents and Spacing Tab

Select  your indents

Fig 3.27 Paragraph group

Add Borders and Shading

You can add borders and shading to paragraphs and entire pages.  To
create a border around a paragraph or paragraphs:

Select the area of text where you want the border or shading.

Click the Borders Button on the Paragraph Group on the Home Tab
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Choose the Border and Shading

Choose the appropriate options

Fig 3.28 Borders and Shading

Apply Styles

Styles are a present collection of formatting that you can apply to text. To
utilize Quick Styles:

 Select the text you wish to format. 

 Click the dialog box next to the Styles Group on the Home Tab.

 Click the style you wish to apply.

Fig 3.29 Paragraph group

Change Spacing Between Paragraphs and Lines

You can change the space between lines and paragraphs by doing the
following:

Select the paragraph or paragraphs you wish to change.
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 On the Home Tab, Click the Paragraph Dialog Box

Click the Indents and Spacing Tab

In the Spacing section, adjust your spacing accordingly.

Fig 3.30 Spacing between paragraph and lines

3.5 Find and Replace Text and Spell Checking
3.5.1 Find  and Replace Text

To find a particular word or phrase in a document:

Click Find on the Editing Group on the Ribbon

To  find and replace a word or phrase in the document, click Replace
on the Editing Group of the Ribbon.
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Fig 3.31 Editing Group

Undo Changes

To undo changes:

Click the Undo Button on the Quick Access Toolbar

Fig 3.31 Undo group
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3.5.2 Spell Checking
To check the spelling and grammar of a document

Place the cursor at the beginning of the document or the beginning of the
section that you want to check

Click the Review Tab on the Ribbon

Click Spelling & Grammar on the Proofing Group. 

Fig 3.32 Spelling & grammer

Any errors will display a dialog box that allows you to choose a more
appropriate spelling or phrasing.

Fig 3.33 Spelling & grammer

If you wish to check the spelling of an individual word, you can right click
any word that has been underlined by Word and choose a substitution.
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Fig 3.34 Substitution of spelling & grammer

Thesaurus

The Thesaurus allows you to view synonyms.  To use the thesaurus:

Click the Review Tab of the Ribbon

Click the Thesaurus Button on the Proofing Group.

The thesaurus tool will appear on the right side of the screen and you
can view word options.

Fig 3.35 Thesaurus

You can also access the thesaurus by right-clicking any word and choosing
Synonyms on the menu.
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Fig 3.36 Synonyms

Add AutoText to the Quick Access Toolbar

1.Click the Microsoft Office Button , and then click Word Options.

2. Click Customize.

3. In the list under Choose commands from, click All Commands.

4.Scroll through the list of commands until you see AutoText.

5. Click AutoText, and then click Add.

The AutoText button now appears in the Quick Access Toolbar. Click
AutoText to choose from a gallery of AutoText entries.

Create a new AutoText Entry

1.In your Word document, select the text that you want to add to your
gallery of AutoText entries.

2. In the Quick Access Toolbar, click AutoText, and then click Save
Selection to AutoText Gallery.

3. Fill out the information in the Create New Building Block dialog box:

Name Type a unique name for the building block.
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Gallery Select the gallery that you want the building block to show up
in.

Category  Select a category, such as General or Built-In, or create
a new category.

Description  Type a description of the building block.

Save in  Click the name of the template in the drop-down list. A
template must be open to be displayed in the drop-down list of template names.

Options  Choose one of the following:

Select Insert content in its own page to place the building block on
a separate page with page breaks before and after the building block.

Select Insert content in its own paragraph to make the content into
its own paragraph, even if the user’s cursor is in the middle of a paragraph.

Select Insert content only for all other content.Note: After typing  the
short name of autotext gallery,  press function key F3, then it is replaced by the
lengthy name.

Customize AutoCorrect

You can set up the AutoCorrect tool in Word to retain certain text the way
it is.  To customize AutoCorrect:

Fig 3.37 Customize Autocorrect

Click the Microsoft Office button

Click the Word Options Button
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Click the Proofing tab

Click AutoCorrect Options button

On the AutoCorrect Tab, you can specify words you want to replace
as you type.

Fig 3.38 Autocorrect tab

Create a New Default Dictionary

Often you will have business or educational jargon that may not be recognized
by the spelling and/or grammar check in Word.  You can customize the dictionary
to recognize these words.

Click the Microsoft Office button

Click the Word Options Button

Click the Proofing tab

Click the When Correcting Spelling tab

Click Custom Dictionaries

Click Edit Word List
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Fig 3.39  Default dictionary

Type in any words that you may use that are not recognized by the
current dictionary.

Fig 3.40 custom dictionaries

Check Word Count

To check the word count in Word 2007 look at the bottom left corner of
the screen.  It will give you a total word count or if you have text highlighted it
will tell you how many words are highlighted out of the total.
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Fig 3.41 Check Word Count

3.6 Tabs
Consider the document shown below. The figure contains a table. We

need to create a similar table. To type such a table you do not have to use the
space bar to align columns. Instead you should use tabs. When you start
word ,it automatically sets the tabs after every 0.5".  That is , the tabs are  set
as 0.5", 1.0",1.5",2.0"2.5",and so on positions. There four you just need to
press the Tab key to move the cursor to the   next 0.5" position.    We can
also define own tab position.

                           Employee List

S.Kavya             Doctor              Vizag

S.Chanukya        Engineer            Hyderabad

S.N.Ratna          Lecturer              Tekkali

Tab stop position: Type the position on the ruler where you want to create
a new tab stop, or select an existing tab stop from the list to modify its properties.

Default tab stops: Specifies amount of spacing that is applied each time
you press the TAB key.

Tab stops to be cleared: Displays tab stops that have been marked for
deletion from the Tab stop position list. Cleared tabs are deleted from the list
when you click OK.

Alignment

Left: Sets a left start position of text that will then run to the right as you
type.

Center: Sets the position of the middle of the text. The text centers on this
position as you type.
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Right: Sets a right start position of text that will then run to the left as you
type.

Decimal: Aligns numbers around a decimal point. Independent of the number
of digits, the decimal point will be in the same position. (You can align numbers
around a decimal character only; you cannot use the decimal tab to align numbers
around a different character, such as a hyphen or an ampersand symbol.)

Bar: Inserts a vertical bar at the tab position. Not used for positioning text.

Leader

1. Omits any lead characters to be added in front of the tab stop.

2. Specifies for a tightly dotted line to be added in front of the tab stop.

3. Specifies for a line of dashes to be added in front of the tab stop.

4. Specifies for a solid line to be added in front of the tab stop.

5. Specifies for a loosely dotted line to be added in front of the tab stop.

Set: Creates a new tab or updates a previously set tab stop position with
the options you specified.

Clear: Marks a selected tab stop position for deletion. Cleared tabs are
deleted from the list when you click OK.

Clear All: Marks all stored tab stop positions for deletion. Cleared tabs
are deleted from the list when you click OK.

3.7 Enhancing a Document(Page Layout)
Before printing  a document we have to set the pages by using page setup.In

this we can set margins, orientation(portrait or landscape),paper size, multiple
columns, page breaks, page borders, page colors ,water marks,   etc.,

Modify Page Margins and Orientations

The page margins can be modified through the following steps:

Click the Page Layout Tab on the Ribbon

On the Page Setup Group, Click Margins

Click a Default Margin, or

Click Custom Margins and complete the dialog box.
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Fig 3.42 Page layout margins

To change the Orientation, Size of the Page, or Columns:

Click the Page Layout Tab on the Ribbon

On the Page Setup Group, Click the Orientation, Size, or Columns
drop down menus

Click the appropriate choice

Fig 3.43 Page layout

Apply a Page Border and Color

To apply a page border or color:
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Click the Page Layout Tab on the Ribbon

On the Page Background Group, click the Page Colors or Page
Borders drop down menus.

Fig 3.44 Page colors nd borders

Insert Common Header and Footer Information

To insert Header and Footer information such as page numbers, date, or
title, first, decide if you want the information in the header (at the top of the
page) or in the Footer (at the bottom of the page), then:

Click the Insert Tab on the Ribbon

Click Header or Footer

Choose a style

Fig 3.45 Header & footer

The Header/Footer Design Tab will display on the Ribbon

Choose the information that you would like to have in the header or
footer (date, time, page numbers, etc.) or type in the information you would like
to have in the header or footer.

Fig 3.46 Design tab
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Create a Page Break

To insert a page break:

Click the Page Layout Tab on the Ribbon

On the Page Setup Group, click the Breaks Drop Down Menu

Click Page Break

Fig 3.47 Create a page break

Insert a Cover Page

To insert a cover page:

Click the Insert Tab on the Ribbon

Click the Cover Page Button on the Pages Group

Choose a style for the cover pageI
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Fig 3.48 Inserting of cover page

Insert a Blank Page

To insert a blank page:

Click the Insert Tab on the Ribbon

Click the Blank Page Button on the Page Group

Fig 3.49 Inserting a blank page
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 3.8 Tables
Look at he table Below. In word we create such  tables easily. The tables

facility in word is very powerful and flexible.   Table can have any number of
rows and columns.

Tables are used to display data in a table format.

Create a Table

To create a table:

     Place the cursor on the page where you want the new table

Click the Insert Tab of the Ribbon

Click the Tables Button on the Tables Group.  You can create a table
one of four ways:

Highlight the number of row and columns

Click Insert Table and enter the number of rows and
              columns.

Fig 3.50  Inserting table

Regd.No Name Maths marks Science marks Social marks

101 Rajesh 65 59 72

102 Bheemesh 85 75 81

103 Tejesh 76 78 80
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Click the Draw Table, create your table by clicking and
             entering the rows and columns.

Click Quick Tables and choose a table

Enter Data in a Table

Place the cursor in the cell where you wish to enter the information.  Begin
typing.

Modify the Table Structure and Format a Table

To modify the structure of a table:

Click the table and notice that you have two new tabs on the Ribbon: 
Design and Layout.  These pertain to the table design and layout.

Fig 3.51 Design and layout

On the Design Tab, you can choose:

Table Style Options

Table Styles

Draw Borders

To format a table, click the table and then click the Layout Tab on the
Ribbon.  This Layout tab allows you to:

View Gridlines and Properties (from the Table Group)

    Insert Rows and Columns (from the Rows & Columns Group)

Delete the Table, Rows and/or Columns (from the Rows & Columns
Group)

Merge or Split Cells (from the Merge Group)

Increase and Decrease cell size (Cell Size Group)

Align text within the cells and change text directions (Alignment
Group).
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Fig 3.52 Layout

3.9 Graphics
Word includes set of drawing tools that that you can use to create simple

graphics.The pictures, clip art , shapes , smart art , equations etc are available in
insert tab.Word 2007 allows you to insert special characters, symbols, pictures,
illustrations, and watermarks.

Fig 3.53

Symbols and Special Characters

Special characters are punctuation, spacing, or typographical characters
that are not generally available on the standard keyboard. To insert symbols and
special characters:

Place your cursor in the document where you want the symbol

Click the Insert Tab on the Ribbon

Click the Symbol button on the Symbols Group

Choose the appropriate symbol.

Fig 3.54 Symbols
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Fig 3.54 Shapes

Equations

Word 2007 also allows you to insert mathematical equations.  To access
the mathematical equations tool:

Place your cursor in the document where you want the symbol

Click the Insert Tab on the Ribbon

Fig 3.55 Equations

Click the Equation Button on the Symbols Group
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Choose the appropriate equation and structure or click Insert New
Equation

To edit the equation click the equation and the Design Tab will be
available in the Ribbon

Illustrations, Pictures, and SmartArt

Word 2007 allows you to insert illustrations and pictures into a document. 
To insert illustrations:

Place your cursor in the document where you want the illustration/
             picture

Click the Insert Tab on the Ribbon

Click the Clip Art Button

The dialog box will open on the screen and you can search for clip art.

Choose the illustration you wish to include

Fig 3.56 Clip art

To insert a Picture

Place your cursor in the document where you want the illustration/
picture

Click the Insert Tab on the Ribbon

Click the Picture Button

Browse to the picture you wish to include

Click the Picture

Click Insert
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Fig 3.57 Inserting of picture

Smart Art is a collection of graphics you can utilize to organize information
within your document.  It includes timelines, processes, or workflow. To insert
SmartArt.

Fig 3.58 Smart art
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Place your cursor in the document where you want the illustration/
picture

Click the Insert Tab on the Ribbon

Click the SmartArt button

Click the SmartArt you wish to include in your document

Click the arrow on the left side of the graphic to insert text or type the
text in the graphic.

Resize Graphics

All graphics can be resized by clicking the image and clicking one corner of
the image and dragging the cursor to the size you want the picture.

Fig 3.59 Resize graphics

Watermarks

A watermark is a translucent image that appears behind the primary text in
a document.  To insert a watermark:

Click the Page Layout Tab in the Ribbon

Click the Watermark Button in the Page Background Group

Click the Watermark you want for the document or click Custom
            Watermark and create your own watermark
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To remove a watermark, follow the steps above, but click Remove
Watermark

Fig 3.60 Watermark

3.10 Mail Merge
Mail Merge  is an important feature in msword and it is useful  to print

personalized form letters in the offices or in organizations.  Personalized  form
letters (addressee’s name and address on the letter), envelopes, mailing labels
etc., Many times we require  sending the same content of a letter to different
individuals. Business letters describing launch of new product, call letters for
interview, notice for a meeting,  invitation for a party ,etc are examples of form
letters. By using Mail Merge you can send the same letter to a number of persons
without typing the content of the letter again and again

Call Letter: 1

Director,

ABC Company Ltd.,

Dwarakanagr,

Visakhapatnam.
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Dear   «candidate name»

                  With reference to your application,  you  applied for the post
of  «designation»  .So please attend for written examination on 12-5-2012 in
the meeting hall of this  company.

Call Letter: 2

Director,

ABC Company Ltd.,

Dwarakanagr,

Visakhapatnam.

Dear   Rajesh

                            With reference to your application,  you  applied for the
post of  Legal  advisor .So please attend for written examination on 12-5-2012
in the meeting hall of this  company.

Call Letter: 3

Director,

ABC Company Ltd.,

Dwarakanagr,

Visakhapatnam.

Dear   Bheemesh

                            With reference to your application,  you  applied for the
post of  Computer operator .So please attend for written examination on 12-5-
2012 in the meeting hall of this  company.

Call Letter: 4

Director,

ABC Company Ltd.,

Dwarakanagr,

Visakhapatnam.

Dear   Tejesh
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                            With reference to your application,  you  applied for the
post of  Engineer .So please attend for written examination on 12-5-2012 in the
meeting hall of this  company.

Starting Your Mail Merge Document

Click Start Mail Merge on the Mailings ribbon and select the type of
document you’d like to create.

Fig 3.61 Starting Mailmerege

For example, you can select letters, envelopes, or labels. Or, select Step
by Step Mail Merge Wizard for more help creating your document.

Selecting Recipients for Mail Merge Letters

Click Select Recipients on the Mailings ribbon to add recipients to the
mailing.

Fig 3.62 Mail merege letters

You can opt to create a new database of recipients. You can also opt to use
an existing list or Outlook contacts.
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Adding Recipients to Your Mail Merge Database

In the New Address List Box, begin entering your contacts.

Fig 3.63 Mailmerge database

You can use the Tab key to move between fields. Each set of fields is
referred to as an entry. To add additional recipients, click the New Entry button.
To delete an entry, select it and click Delete Entry. Click Yes to confirm the
deletion.

Adding and Deleting Mail Merge Fields

You may wish to delete or add fields types to your mail merge document.

Fig 3.64 Mailmerge data fields

You can do that easily. Just click the Customize Columns button. The
Customize Columns dialog box opens. Then, click Add, Delete or Rename to
alter the field types. You can also use the Move Up and Move Down buttons to
rearrange the order of the fields. When you’re done, click OK.
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Once you’ve added all your recipients, click OK on the New Address List
dialog box. Name the data source and click Save.

Inserting a Merge Field in Your Document

Fig 3.65

To insert a field into your document, click Insert Merge Field on the Mailings
ribbon. Select the field you would like to insert. The field name appears where
you have the cursor located in your document.

You can edit and format the text surrounding the field. Formats applied to
the field will carry over to your finished document. You can continue to add
fields to your document.

Previewing Your Mail Merge Letters

Before you print your letters, you should preview them to check for errors.
In particular, pay attention to spacing and punctuation surrounding the fields.
You will also want to make sure you have inserted the correct fields in the
correct places.

Fig 3.66

To preview the letters, click Preview Results on the Mailings ribbon. Use
the arrows to navigate through the letters.

Correcting Errors in Mail Merge Fields

You may notice an error in the data for one of your documents. You cannot
alter this data in the merge document. Instead, you’ll need to fix it in the data
source.

Fig 3.67

To do this, click Edit Recipient List on the Mailings ribbon. In the box that
opens, you can alter the data for any of your recipients. You can also limit the
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recipients. Simply uncheck the box next to recipients’ names to omit them from
the merge operation. When you’re done, click OK.

Finalizing Your Mail Merge Documents

After you’ve reviewed your documents, you’re ready to finalize them by
completing the merge. Click the Finish & Merge button on the Mailings ribbon.

Fig 3.68

You can opt to edit individual documents, print the documents, or email
them. If you opt to print or email your documents, you’ll be prompted to enter
a range. You can opt to print all, one, or a set of contiguous letters. Word will
walk you through the process for each.

3.11  Miscellaneous Features of Word
Finally we have to cover some more features list(bullets and numbers) and

word art.In the documents if we want to explain  point wise ,then we can give
numbering or can give  bullets.

3.11.1 Lists
Lists allow you to format and organize text with numbers, bullets, or in an

outline.

Bulleted and Numbered Lists

Bulleted lists have bullet points, numbered lists have numbers, and outline
lists combine numbers and letters depending on the organization of the list.

To add a list to existing text:

Select the text you wish to make a list

From the Paragraph Group on the Home Tab, Click the Bulleted or
Numbered Lists button.
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Fig 3.69

To create a new list

Place your cursor where you want the list in the document

Click the Bulleted or Numbered Lists button

Begin typing

Nested Lists

A nested list is list with several levels of indented text. To create a nested
list:

Create your list following the directions above

Click the Increase or Decrease Indent button

Fig 3.70

Formatting Lists

The bullet image and numbering format can be changed by using the Bullets
or Numbering dialog box.

Fig 3.71



 Paper - I   Computer Fundamentals and MS-Office 113

Select the entire list to change all the bullets or numbers, orPlace the
cursor on one line within the list to change a single bullet

Right click

Click the arrow next to the bulleted or numbered list and choose a
bullet or numbering style.

3.11.2 Word Art
Word art is used to type the text with different styles and sizes. In the

documents some where we have to design the text matter with large size and
with different styles. Then we have to prefer word art. Suppose , here we enter
a word “computer” in word art, then it is displayed as follows.

Fig 3.71

1. On the Insert tab, in the Text group, click WordArt, and then click the
WordArt style that you want.

2.Type your text in the text boxWord

Fig 3.72
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Fig 3.72 Type your text in the text box

Do one or more of the following:

• To change the text, select it, and then make the changes that you want.

• To change the font, see Change the font, font size, or font color, or Apply
           bold, italic, or underline formatting to text.

• To add an effect to WordArt, see Add or delete a fill, outline, or effect for
          text or WordArt.

• To rotate the WordArt, see Rotate or flip a picture, shape, or WordArt in
         Word 2007.

• To resize the WordArt, see Change the size of a picture, shape, text box,
          or WordArt.

• To align the WordArt, see Align or arrange a picture, shape, text box, or
          WordArt.

• To move the WordArt, see Move a picture, shape, text box, or WordArt.
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 Summary
In windows 7 , the screen layout is different from the previous versions of

windows. In windows7 ribbon, tabs, groups and buttons  are also appear in
different.

To edit a document ,you need to open it. On selecting the file ,open command
,word displays the open dialogue box.  If the  file you want to open is not there
in the current directory, you can change the directory and then select the file for
opening.

To move the cursor to the desired location on the screen, you can either
take the help of the mouse or use the keyboard. you  can scroll the document
vertically or horizontally by using scroll bars. To fasten the editing we must know
the short cuts of keyboard. Suppose if you press ctrl+home   the cursor must be
beginning of the document. You  can use undo ,  redo etc for editing.

You can easily move the selected text to any part of the document.  word
allows you to move the text with the keyboard as well as mouse. When you
make copy(copy and paste) it is present at both places source and destination.
When you make a move(cut and paste) it is present only at the destination and
no more in the source.

Students  should practice copy and move only by using keyboard without
using mouse and also only by using mouse without keyboard.

Help system provides facility to the each and every feature  in word you
are using and it is readily available by showing the icon  .

Word allows you to format the paragraph by applying various font  styles,
colours ,highlighting, strikethrough, spacing between lines, borders and shading
,alignment etc.what ever the facility you used to the document looks better.

In the document we can use find with many options such as match case,
whole words only, pattern matching and sounds like etc., to find a text.

Spell checker is used to make error free document.  autocorrect
automatically fixes errors  based on a  list. Autotext is normally used to  quickly
type lengthy or difficult to type text that you need routinely in your document.

To create a multi column table ,you can use tabs. By default , word creates
tabs at every 0.5" position. However we can define our own tabs stop  position
.We can create four types tabs. These are left aligned, right aligned, centered
and decimal aligned.
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After completion of  setups in the page layout , we must see print preview
before printing a document . If there are any changes have to be made we can
change by using page  layout again.

When you enter text in the cell of a table ,word automatically changes the
cell height to accommodate the text you type. Use the tab key to move the
cursor to the next cell and Shift+tab  key to move the cursor to the previous cell.
Text entered in the table can be formatted by using the normal text formatting
commands.

With the help of this graphics ,you can create lines, rectangles, squares,
ellipses, circles, arcs, text  boxes, etc. You  can also control the line thickness ,
colour and styles of the lines you draw. You can also insert the pictures and also
you can drag the pictures as well as objects to the desired location.

In sample mail merge we have shown only three addresses but we can
perform many more.

We need not use the default fields and  also can change the field names as
we require such as designation, post, etc. For changing the name of a field
follow

Select recipients > type new list > customize columns > add > field name .

In the documents , some times  the sentences   may be required to give
numbering or marking . For this we have to use lists. If we want to make special
effects to any  text we prefer word art.

Model Questions
Short Answer Type Questions

1. What is a Ribbon?

2. What is office button?

3. What is quick access toolbar?

4. What are the tabs in the ribbon?

5. What are the shortcuts for open and save a file?

6. What are the shortcuts for new and close a file?

7. What is the difference between copy and move?

8. What is help system?

9. What are the alignments in paragraph?
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10. What are the indents in paragraph?

11.What is formatting a text?

12. What is autotext?

13. What is autocorrect?

14. What is word count?

15.  What is default dictionary?

16. What is thesaurus?

17. What is undo changes?

18. What are different types tab alignments?

19. What are the options in page layout?

20. What is orientation?

21. What is header and footer?

22. Draw a table with any data of your choice.

23. What is clip art?

24. What is smart art?

25. What is water mark?

26. What is mail merge?

Long Answer Type Questions
1. Write the stepwise procedure to create, edit and save a document in

word

2. Write about document views.

3. Write about move and copy.

4. Write about formatting the paragraph.

5. Write about find and replace.

6. Write about spell checker.

7. Write about tabs.

8. Explain the options in detail in  page layout
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9. Write about tables.

10. Write about graphics.

11.Write about mail merge.

 12. Write about bullets and numbering.

 13. Write about word art.



 

 Structure
4.1  Introduction to Spreadsheet

4.2  Creating a work book and feeding data.

4.3  Using functions(Formulae)

4.4  Editing cells and using commands and functions

4.5  Moving and copying , inserting and deleting  Rows  and Columns

4.6  Formatting a worksheet

4.7  Save a Workbook

4.8  Charts

4.9  Macros

4.10 Tables and Pivot Tables

Learning Objectives
After studying this unit, the student will be able to

• Create a work book, Undo and redo,  Find and replace, Go ToAuto
fill, Split the worksheet,  spell checker,  statistical functions, mathematical

 

4UNIT

Microsoft - Excel
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functions,   insert rows and columns, delete rows and columns,  copy and paste
, cut and paste(move), Add  borders and colours to cells,

• Cell alignments, Change row height and column width, Hide or unhide
rows or columns,  Merge cells, saving ,renaming a file, Opening a file, Print
work book, create  charts of different types, Formatting plot area by colours,
font style etc., Modifying charts, Copy chart into word,etc

• Explain recording a macro, Running a macro

• Explain create, format and  delete  a table, PivotTables

4.1 Introduction to Spread Sheets
Getting started with Excel 2007 you will notice that there are many similar

features to previous versions.  You will also notice that there are many new
features that you’ll be able to utilize. 

Fig. 4.1 Spread Sheet Preview

There are three features that you should remember as you work within Excel
2007:  the Microsoft Office Button, the Quick Access Toolbar, and the Ribbon. 
The function of these features will be more fully explored below.

Spreadsheets

A spreadsheet is an electronic document that stores various types of data. 
There are vertical columns and horizontal rows.  A cell is where the column and
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row intersect.  A cell can contain data and can be used in calculations of data
within the spreadsheet.  An Excel spreadsheet can contain workbooks and
worksheets.  The workbook is the holder for related worksheets.

Microsoft Office Button

The Microsoft Office Button performs many of the functions that were
located in the File menu of older versions of Excel.  This button allows you to
create a new workbook, Open an existing workbook, save and save as, print,
send, or close.

Fig. 4.2 Microsoft Office Button

Ribbon

The ribbon is the panel at the top portion of the document   It has seven
tabs:  Home, Insert, Page Layouts, Formulas, Data, Review, and View.  Each
tab is divided into groups.  The groups are logical collections of features designed
to perform function that you will utilize in developing or editing your Excel
spreadsheets. 

Fig. 4.3 Ribbon

Commonly utilized features are displayed on the Ribbon.  To view additional
features within each group, click the arrow at the bottom right corner of each
group.
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Fig. 4.4

Home:  Clipboard, Fonts, Alignment, Number, Styles, Cells, EditingInsert:
Tables, Illustrations, Charts, Links, TextPage Layouts: Themes, Page Setup,
Scale to Fit, Sheet Options, ArrangeFormulas: Function Library, Defined Names,
Formula Auditing, CalculationData:  Get External Data, Connections, Sort &
Filter, Data Tools, OutlineReview:  Proofing, Comments, ChangesView:
Workbook Views, Show/Hide, Zoom, Window, Macros

Quick Access Toolbar

The quick access toolbar is a customizable toolbar that contains commands
that you may want to use.  You can place the quick access toolbar above or
below the ribbon.  To change the location of the quick access toolbar, click on
the arrow at the end of the toolbar and click Show Below the Ribbon.

Fig. 4.5 Quick Access Toolbar
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You can also add items to the quick access toolbar.  Right click on any item
in the Office Button or the Ribbon and click Add to Quick Access Toolbar and
a shortcut will be added.

Fig. 4.6

Mini Toolbar

A new feature in Office 2007 is the Mini Toolbar.  This is a floating toolbar
that is displayed when you select text or right-click text.  It displays common
formatting tools, such as Bold, Italics, Fonts, Font Size and Font Color.

Fig. 4.7 Mini Toolbar

4.2 Creating a Work Book and Feeding data
What ever the data we want to enter in the work sheet , first we create a

new work sheet and then can enter data.

4.2.1 Create a Workbook

•  Click the Microsoft Office Toolbar

•  Click New

•  Choose Blank Document
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Fig. 4.8 Creating a Work Book

Choose Blank Document

 If you want to create a new document from a template, explore the
templates and choose one that fits your needs.

4.2.2 Feeding Data Introduction

Fig. 4.9 Feeding
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In the work sheet the rows are indicated by 1,2,3,4,…and the columns are
indicated by A,B,C,D,.. . The cell address referred by means of column number
and row number. Suppose  a cell A2 means row number 2 and column number
A. In  excel 2007, the work sheet contains  maximum no of rows is 10,48,576
and maximum no columns(XFD) is 16384.

There are different ways to enter data in Excel:  in an active cell or in the
formula bar.To enter data in an active cell:

• Click in the cell where you want the data

• Begin typing

Fig. 4.10

• Click the cell where you would like the data

• Place the cursor in the Formula Bar

• Type in the data

Fig. 4.11 Formula Bar

4.3 Using functions(Formulae)
A formula is a set of mathematical instructions that can be used in Excel to

perform calculations.  Formulae are started in the formula box with an = sign.
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Fig. 4.12 Using Functions

There are many elements to and excel formula.

References:  The cell or range of cells that you want to use in your
       calculation

Operators:  Symbols (+, -, *, /, etc.) that specify the calculation to be
        performed

Constants:  Numbers or text values that do not change

Functions:  Predefined formulas in Excel

To create a basic formula in Excel

• Select the cell for the formula

• Type = (the equal sign) and the formula

• Click Enter

Fig. 4.13 Using Functions

• Click the cell where you want the function applied

• Click the Insert Function button

• Choose the function
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• Click OK

Fig. 4.14

 • Complete the Number 1 box with the first cell in the range that you want
           calculated

• Complete the Number 2 box with the last cell in the range that you want
            calculated.

Fig. 4.15 Functions with Arguments

 Function Library : The function library is a large group of functions on
the Formula Tab of the Ribbon.  These functions include

AutoSum:  Easily calculates the sum of a range

Recently Used:  All recently used functions
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Financial: Accrued interest, cash flow return rates and additional financial
functions

Logical: And, If, True, False, etc.

Text: Text based functions

Date & Time: Functions calculated on date and time

Math & Trig:  Mathematical Functions 1.

Fig. 4.16 Functions

4.4 Editing cells and using commands and functions
 Excel allows you to many editing features such as undo, redo, find and

replace, go to ,spell check etc.Many Functions are also available in excel.

Undo and RedoTo undo or redo your most recent actions

• On the Quick Access Toolbar

• Click Undo or Redo

Fig. 4.17 Undo and Redo
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Auto Fill

The Auto Fill feature fills  cell data or series of data in a worksheet into a
selected range of cells. If you want the same data copied into the other cells,
you only need to complete one cell.  If you want to have a series of data (for
example, days of the week) fill in the first two cells in the series and then use the
auto fill feature.

• Click the Fill Handle

• Drag the Fill Handle to complete the cells

Fig. 4.18 Fill Handle

Find and Replace

To find data or find and replace data:

Fig. 4.19 Find and Replace
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• Click the Find & Select button on the Editing group of the Home tab

• Choose Find or Replace

• Complete the Find What text box

• Click on Options for more search options

Go To Command

The Go To command takes you to a specific cell either by cell reference
(the Column Letter and the Row Number) or cell name. 

• Click the Find & Select button on the Editing group of the Home tab

• Click Go To

Fig. 4.20 Goto Function

Spell Check

To check the spelling:

• On the Review tab click the Spelling button
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Fig. 4.21 Spell Check

Split the screen

Split the window into multiple resizable panes containing views of your
worksheet. You Can use this feature to view multiple distant parts of your
worksheet  at once.

It is in the view tab, click on split

Fig. 4.22 Split Screen
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Calculate with Functions

A function is a built in formula in Excel.  A function has a name and arguments
(the mathematical function) in parentheses.  Here we give a sample worksheet.
We explain the functions by using this figure

 Fig. 4.23 Calculate with Functions

Mathematical functions

1. FACT:     Returns the factorial of a number.

Syntax

FACT(number)

Number   is the nonnegative number for which you want the factorial. If
number is not an integer, it is truncated.

Example

 FACT(B2) gives 120 because B2 in Figure -1 contains 5 i.e (1 x 2 x 3 x
4 x 5 = 120).

2. POWER:   Returns the results of a number raised to a power

Syntax

POWER(number,power)

Number   is the base number. It can be any real number.

Power   is the exponent to which the base number is raised.

Example

POWER(B2,E2) gives result 25 because (52 = 25)

3. SQRT: Finds the square root of a value in the cell.
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Syntax

SQRT(number)

Number   is the number for which you want the square root.

Remark

If number is negative, SQRT returns the #NUM! error value.

Example

SQRT(C2) gives 2 because  square root of 4 is 2.

4. SUM

The SUM function adds all the numbers that you specify as
arguments (argument: A value that provides information to an action, an event, a
method, a property, a function, or a procedure.). Each argument can be a
range (range: Two or more cells on a sheet. The cells in a range can be adjacent
or nonadjacent.), a cell reference (cell reference: The set of coordinates that a
cell occupies on a worksheet. For example, the reference of the cell that appears
at the intersection of column B and row 3 is B3.), an array (array: Used to build
single formulas that produce multiple results or that operate on a group of
arguments that are arranged in rows and columns. An array range shares a
common formula; an array constant is a group of constants used as an argument.),
a constant (constant: A value that is not calculated. For example, the number
210 and the text “Quarterly Earnings” are constants. An expression, or a value
resulting from an expression, is not a constant.), a formula (formula: A sequence
of values, cell references, names, functions, or operators in a cell that together
produce a new value. A formula always begins with an equal sign (=).), or the
result from another function. For example, SUM(A1:A5) adds all the numbers
that are contained in cells A1 through A5. For another example, SUM(A1, A3,
A5) adds the numbers that are contained in cells A1, A3, and A5.

Syntax

SUM(number1, [number2],[number3],[number4],…)

The SUM function syntax has the following arguments:

number1  Required

number2, number3 are optional

example

SUM(A2:E2) Gives the result 20 because(3 + 5 +4 + 6 + 2 = 20)
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5. SUMIF

You use the SUMIF function to sum the values in a range (range: Two or
more cells on a sheet. The cells in a range can be adjacent or nonadjacent.) that
meet criteria that you specify.

SYNTAX

SUMIF(RANGE , CRITERIA)

Example:

SUMIF(A2:E2,”>4") Gives result 11 because (5 + 6).

6.MOD

Returns the remainder after number is divided by divisor. The result has the
same sign as divisor.

Syntax

MOD(number,divisor)

Number   is the number for which you want to find the remainder.

Divisor   is the number by which you want to divide number.

Ex1: MOD(B2,A2) gives result 2 because remainder is 2 when 5 is divided
       by 3.

Ex2: MOD(10,6) gives result 4 because remainder is 4 when 10 is divided
       by 6.

Statistical functions

1. Average:  Returns average(arithmetic mean) of its arguments

The AVERAGE function syntax has the following arguments (argument: A
value that provides information to an action, an event, a method, a property, a
function, or a procedure.):

Number1  Required. The first number, cell reference (cell reference: The
set of coordinates that a cell occupies on a worksheet. For example, the reference
of the cell that appears at the intersection of column B and row 3 is B3.), or
range for which you want the average.

Number2

Syntax:  average(number1,number2,..)
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Example:

Average(a2:e2) gives result 4 because (3+5+4+6+2)/5 = 4

2. Count

   The COUNT function counts the number of cells that contain numbers,
and counts numbers within the list of arguments. Use the COUNT function to
get the number of entries in a number field that is in a range or array of numbers.

Syntax

Count(value1,[value2] ,...)

The COUNT function syntax has these arguments (argument: A value that
provides information to an action, an event, a method, a property, a function, or
a procedure.):

value1  Required. The first item, cell reference, or range within which you
want to count numbers.

value2, ...  Optional. Up to 255 additional items, cell references, or ranges
within which you want to count numbers.

Example

Count(a4:e4) gives result 3 because (12,8,4 are 3 values)

3. Count A

The COUNTA function counts the number of cells that are not empty in a
range (range: Two or more cells on a sheet. The cells in a range can be adjacent
or nonadjacent.).

Syntax

COUNTA(value1, [value2], ...)

The COUNTA function syntax has the following arguments (argument: A
value that provides information to an action, an event, a method, a property, a
function, or a procedure.):

value1  Required. The first argument representing the values that you want
to count.

value2, ...  Optional

Ex: counta(A4:E4) gives the result 4 because the range contains 4 values.
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4. Count Blank

: Counts empty cells in a specified range of cells.

Syntax

COUNTBLANK(range)

Range   is the range from which you want to count the blank cells.

Example:

 Countblank(A4:E4) gives result 1 because the range contains one blank.

5.Count If

The COUNTIF function counts the number of cells within a range that
meet a single criterion that you specify. For example, you can count all the cells
that start with a certain letter, or you can count all the cells that contain a number
that is larger or smaller than a number you specify. For example, suppose you
have a worksheet that contains a list of tasks in column A, and the first name of
the person assigned to each task in column B. You can use the COUNTIF
function to count how many times a person’s name appears in column B and, in
that way, determine how many tasks are assigned to that person. For example:

=COUNTIF(F2:F25,”Nancy”)

COUNTIF(range, criteria)

The COUNTIF function syntax has the following arguments (argument: A
value that provides information to an action, an event, a method, a property, a
function, or a procedure.):

range  Required. One or more cells to count, including numbers or names,
arrays, or references that contain numbers. Blank and text values are ignored.

criteria  Required. A number, expression, cell reference, or text string that
defines which cells will be counted. For example, criteria can be expressed as
32, “>32”, B4, “apples”, or “32”.

Ex:

Countif(A4:E4,”>10") gives result 1 because the range contains only one
value that is greater than 10.
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6.MAX:

Returns the maximum value in the range

MAX(number1,number2,...)

Number1, number2, ...   are 1 to 255 numbers for which you want to find
the maximum value.

Ex : max(A2:E2) gives result 6 because 6 is the maximum value in
that range.

7.MIN: Returns the minimum value in the range

MIN(number1,number2,...)

Number1, number2, ...   are 1 to 255 numbers for which you want to find
the minimum value.

Ex : max(A2:E2) gives result 2 because 6 is the minimum value in
that range.

4.5 Moving and copying , inserting and deleting  Rows  and
      Columns

Excel allows you to move, copy, and paste cells and cell content through
cutting and pasting and copying and pasting.

Select Data

To select a cell or data to be copied or cut:

Click the cell

Fig. 4.25
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 Click and drag the cursor to select many cells in a range

Fig. 4.26

Select a Row or Column

To select a row or column click on the row or column header.

Fig. 4.27

Copy and Paste

To copy and paste data:

• Select the cell(s) that you wish to copy

• On the Clipboard group of the Home tab, click Copy

Fig. 4.28 Copy and Paste Buttons
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• Select the cell(s) where you would like to copy the data

• On the Clipboard group of the Home tab, click Paste

Fig. 4.29 Paste Buttons
Cut and Paste

To cut and paste data:

• Select the cell(s) that you wish to cut

• On the Clipboard group of the Home tab, click Cut

Fig. 4.30 Cut Buttons
• Select the cell(s) where you would like to cut the data

• On the Clipboard group of the Home tab, click Paste

To insert cells, rows, and columns in Excel

• Place the cursor in the row below where you want the new row, or in
the column to the left of where you want the new column

• Click the Insert button on the Cells group of the Home tab

• Click the appropriate choice: Cell, Row,  or Column
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Fig. 4.31 Insert Commands

Delete Cells, Rows and Columns

To delete cells, rows, and columns:

• Place the cursor in the cell, row, or column that you want to delete

• Click the Delete button on the Cells group of the Home tab

• Click the appropriate choice:  Cell, Row, or Column

Fig. 4.32 Delete Cells and Rows

4.6 Formatting a Worksheet
Formatting the worksheet contains six options   numbers, alignment, font,

border, fill and protection to the work sheet.

Modifying fonts in Excel will allow you to emphasize titles and headings. To
modify a font:

• Select the cell or cells that you would like the font applied

• On the Font group on the Home tab, choose the font type, size, bold,
italics, underline, or color
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Fig. 4.33 Modifying Fonts

In Excel, you can also apply specific formatting to a cell. To apply formatting
to a cell or group of cells:

• Select the cell or cells that will have the formatting

• Click the Dialog Box arrow on the Alignment group of the Home tab

Fig. 4.34 Formatting Cells
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There are several tabs on this dialog box that allow you to modify
properties of the cell or cells. 

Number :  Allows for the display of different number types and decimal
places

Alignment :  Allows for the horizontal and vertical alignment of text,
wrap text, shrink text, merge cells and the direction of the text.

Font :  Allows for control of font, font style, size, color, and additional
features

Border :  Border styles and colors

Fill :  Cell fill colors and styles

Add Borders and Colors to Cells

Borders and colors can be added to cells manually or through the use of
styles.  To add borders manually:

Fig. 4.35  Adding Borders to Cells
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• Click the Borders drop down menu on the Font group of the Home
tab

• Choose the appropriate border

Fig. 4.36 Adding Colors

To apply borders and colors using styles:

Fig. 4.37 Applying Borders and Color



     Computer Graphics and Animation144

• Click Cell Styles on the Home tab

• Choose a style or click New Cell Style

Change Column Width and Row Height

To change the width of a column or the height of a row:

• Click the Format button on the Cells group of the Home tab

• Manually adjust the height and width by clicking Row Height or Column
Width

• To use AutoFit click AutoFit Row Height or AutoFit Column Width

Fig. 4.38 Changing Column Width and Row

Hide or Unhide Rows or Columns
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To hide or unhide rows or columns:

• Select the row or column you wish to hide or unhide

• Click the Format button on the Cells group of the Home tab

• Click Hide & Unhide

Fig. 4.39  Hide and Unhide Rows and Columns

Merge Cells

To merge cells select the cells you want to merge and click the Merge &
Center button on the Alignment group of the Home tab.  The four choices for
merging cells are:

Merge & Center: Combines the cells and centers the contents in the new,
larger cell

Merge Across: Combines the cells across columns without centering data

Merge Cells: Combines the cells in a range without centering

Unmerge Cells: Splits the cell that has been merged
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Fig. 4.40 Merge and Unmerge Cells

Align Cell Contents

To align cell contents, click the cell or cells you want to align and click on
the options within the Alignment group on the Home tab.  There are several
options for alignment of cell contents:

Top Align:  Aligns text to the top of the cell

Middle Align:  Aligns text between the top and bottom of the cell

Bottom Align:  Aligns text to the bottom of the cell

Align Text Left:  Aligns text to the left of the cell

Center:  Centers the text from left to right in the cell

Align Text Right:  Aligns text to the right of the cell

Decrease Indent:  Decreases the indent between the left border and the
        text

Increase Indent:  Increase the indent between the left border and the text

Orientation:  Rotate the text diagonally or vertically

Fig. 4.41 Alignments
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 1.7 Save a Workbook
The work sheet that you have type so far has been stored in RAM (Random

Access Memory) of your system. The RAM is volatile. i.e., it loses its contents
,if the electric power is switched off to your system.  Therefore you  must save
the work sheet for future reference.  It is not a good habit  of saving the worksheet
after completion of entire data entering. Instead of this save the worksheet in the
middle of data entering with little gaps.   You can also change the name of file
and location of file by using  “save as” .

When you save a workbook, you have two choices: Save or Save As.

To save a document:

• Click the Microsoft Office Button

• Click Save

Fig. 4.41 Saving a File
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You may need to use the Save As feature when you need to save a
workbook under a different name or to save it for earlier versions of Excel. 
Remember that older versions of Excel will not be able to open an Excel 2007
worksheet unless you save it as an Excel 97-2003 Format. To use the Save As
feature:

• Click the Microsoft Office Button

• Click Save As

• Type in the name for the Workbook

• In the Save as Type box, choose Excel 97-2003 Workbook

Fig. 4.42 Saving A File

Open a Workbook

To open an existing workbook:

• Click the Microsoft Office Button

• Click Open
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• Browse to the workbook

• Click the title of the workbook

• Click Open

Fig. 4.43 Opening a File

Print a worksheet or workbook

You can print entire or partial worksheets and workbooks, one at a time,
or several at once. And if the data that you want to print is in a Microsoft Office
Excel table, you can print just the Excel table.

You can also print a workbook to a file instead of to a printer. This is useful
when you need to print the workbook on a different type of printer from the one
that you originally used to print it.

Print a workbook to a file

1. Click Microsoft Office Button , and then click Print.

Keyboard shortcut  You can also press CTRL+P.

2. In the Name box, select the printer on which you want to print the file.
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3. Select the Print to file check box, and then click OK.

4. In the Print to File dialog box, under Output File Name, type a name
for the file that you want to print.  

4.8 Charts

Often a work sheet contains so much numeric data that is becomes difficult
to accurately analyse  it and to take a correct decision. In such cases , the facility
to represent data in the form of charts(graphs) comes very handy. Because
charts convey the message clearly and quickly, they play important role in the
business world.Charts allow you to present information contained in the
worksheet in a graphic format. Excel offers many types of charts including:
Column, Line, Pie, Bar, Area, Scatter and more.  To view the charts available
click the Insert Tab on the Ribbon.

   Suppose there is a table  of a company containing area wise sales details
as shown below. For this to draw a simple chart , select the range B4 : E7,click
insert tab, click on charts in the columns group . if you select 2D  , then chart has
to be displayed as follows.

Fig. 4.44  Bar Chart
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Create a Chart

To create a chart:

• Select the cells that contain the data you want to use in the chart

• Click the Insert tab on the Ribbon

• Click the type of Chart you want to create

Fig. 4.45 Creating Chart

Modify a Chart

Once you have created a chart you can do several things to modify the
chart. 

To move the chart:

• Click the Chart and Drag it another location on the same worksheet,
or

• Click the Move Chart button on the Design tab

• Choose the desired location (either a new sheet or a current sheet in the
workbook)

Fig. 4.45 Modifying a Chart

To change the data included in the chart:
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• Click the Chart

• Click the Select Data button on the Design tab

Fig. 4.46 Selecting a Data Source

To reverse which data are displayed in the rows and columns:

• Click the Chart

• Click the Switch Row/Column button on the Design tab

Fig. 4.47 Reverseing the data chart
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To modify the labels and titles:

• Click the Chart

• On the Layout tab, click the Chart Title or the Data Labels button

• Change the Title and click Enter

Fig. 4.48 Chart Layouts

Chart Tools

The Chart Tools appear on the Ribbon when you click on the chart.  The
tools are located on three tabs:  Design, Layout, and Format. 

Within the Design tab you can control the chart type, layout, styles, and
location.

Fig. 4.49 Chart Tools

Within the Layout tab you can control inserting pictures, shapes and text
boxes, labels, axes, background, and analysis.

Within the Format tab you can modify shape styles, word styles and size
of the chart.

Fig. 4.50  Format Tab
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Copy a Chart to Word

• Select the chart

• Click Copy on the Home tab

• Go to the Word document where you want the chart located

Click Paste on the Home tab

Fig. 4.51 Copy Button

4.9 Macros
The macro is a useful feature of excel that helps to automatic key

strokes(commands) required to execute any command or task. Macros can be
used for numeric tasks such as

· Formatting of ranges

· Printing a worksheet range

· Creating charts

· Accepting data from the user and putting that in a database

Macros are advanced features that can speed up editing or formatting you
may perform often in an Excel worksheet. They record sequences of menu
selections that you choose so that a series of actions can be completed in one
step.

Recording a Macro

To record a Macro:

•  Click the View tab on the Ribbon

•  Click Macros

•  Click Record Macro
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•  Enter a name (without spaces)

•  Enter a Shortcut Key

•  Enter a Description

Fig. 4.52 Recording a Macro

• Perform the Macro

• Click Macros

• Click Stop Recording

                                                                                   Fig. 4.53 Stoping a Macro
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Running a Macro

To run a Macro from the Keyboard shortcut, simply press the keys that
you have programmed to run the Macro.  Or you can view all macros and run
by:

• Click Macros

• Click View Macros

• Choose the Macro and click Run

   Fig. 4.54 Saving a Macro

4.10 Tables and Pivot Tables
4.10.1 Tables

The data can be shown in the form of tables as shown below. It is a sample
table for a company containing area wise sales details. Table contains rows and
columns.
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ABC COMPANY LIMITED

AREA WISE SALES

Create a Table

You can use one of two ways to create a table. You can either insert a table
in the default table style or you can format your data as a table in a style that you
choose.

Insert a table

1. On a worksheet, select the range of cells that you want to include in the
table. The cells can be empty or can contain data.

2. On the Insert tab, in the Tables group, click Table.

  Fig. 4.55 Inserting a Table

Keyboard shortcut  You can also press CTRL+L or CTRL+T.
1. If the selected range contains data that you want to display as table

headers, select the My table has headers check box.

Table headers display default names if you do not select the My table has
headers check box. You can change the default names by typing the text that
you want.

 Note  :  If you do not want to display table headers, you can turn them off
later. For more information about how to turn table headers off, see Turn Excel
table headers on or off.
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Tips

After you create a table, the Table Tools become available, and a Design
tab is displayed. You can use the tools on the Design tab to customize or edit
the table.

Unlike lists in Office Excel 2003, a table does not have a special row
(marked with *) for quickly adding new rows. For more information about how
to add or insert rows in a table, see Add or remove table rows and columns in
an Excel table.

Format data as a table

1. On the worksheet, select a range of empty cells or cells that contain the
data that you want to quickly format as a table.

2. On the Home tab, in the Styles group, click Format as Table.

  Fig. 4.56 Formatting data as table

When you use Format as Table, Office Excel automatically inserts a table.

1. Under Light, Medium, or Dark, click the table style that you want to
use.

 Note :    Custom table styles are available under Custom after you create
one or more of them. For information about how to create a custom table style,
see Format an Excel table.

Tips

After you create a table, the Table Tools become available, and a Design
tab is displayed. You can use the tools on the Design tab to customize or edit
the table.

Unlike lists in Office Excel 2003, a table does not have a special row
(marked with *) for quickly adding new rows. For more information about how
to add or insert rows in a table, see Add or remove table rows and columns in
an Excel table.
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Convert a table to a range of data

1. Click anywhere in the table.

Tip :  This displays the Table Tools, adding the Design tab.

2. On the Design tab, in the Tools group, click Convert to Range.

 Fig. 4.57 Coverting a Table

Note    Table features are no longer available after you convert the table
back to a range. For example, the row headers no longer include the sort and
filter arrows, and structured references (references that use table names) that
were used in formulas turn into regular cell references.

Tips

You can also right-click the table, point to Table, and then click Convert
to Range.

Immediately after you create a table, you can also click Undo on the Quick
Access Toolbar to convert that table back to a range.

Delete a table

1. On a worksheet, select a table.

2. Press DELETE.

Tip  You can also click Undo on the Quick Access Toolbar to delete a
table that you just created.

 4.10.2 PivotTables

PivotTables are used to looking   at data in several dimensions; For example,
sales by region, sales by sales representatives, sales by product category, sales
by month, etc. Such capability is provided in numerous decision support
applications under various function names. For example, in a spreadsheet , a
pivot table provides these views and enables quick switching between them.
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A PivotTable report is an interactive way to quickly summarize large
amounts of data. Use a PivotTable report to analyze numerical data in detail and
to answer unanticipated questions about your data. A PivotTable report is
especially designed for:

• Querying large amounts of data in many user-friendly ways.

• Subtotaling and aggregating numeric data, summarizing data by categories
and subcategories, and creating custom calculations and formulas.

• Expanding and collapsing levels of data to focus your results, and drilling
down to details from the summary data for areas of interest to you.

• Moving rows to columns or columns to rows (or “pivoting”) to see
different summaries of the source data.

• Filtering, sorting, grouping, and conditionally formatting the most useful
and interesting subset of data to enable you to focus on the information that you
want.

• Presenting concise, attractive, and annotated online or printed reports.

You often use a PivotTable report when you want to analyze related totals,
especially when you have a long list of figures to sum and you want to compare
several facts about each figure. In the PivotTable report illustrated below, you
can easily see how the third-quarter golf sales in cell F3 compare to sales for
another sport, or quarter, or to the total sales.

Fig. 4.57 Graph showing Figures
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1. Source data, in this case, from a worksheet

2.The source values for Qtr3 Golf summary in the PivotTable report

3.The entire PivotTable report

4. The summary of the source values in C2 and C8 from the source data

In the above pivotTable grand total for golf and qtr3 is
$7,930($1500+$6430).

In a PivotTable report, each column or field in your source data becomes a
PivotTable field that summarizes multiple rows of information. In the preceding
example , the Sport column becomes the Sport field, and each record for Golf
is summarized in a single Golf item.

A value field, such as Sum of Sales, provides the values to be summarized.
Cell F3 in the preceding report contains the sum of the Sales value from every
row in the source data for which the Sport column contains Golf and the Quarter
column contains Qtr3. By default, data in the Values area summarize the
underlying source data in the PivotChart report in the following way: numeric
values use the SUM function, and text values use the COUNT function.

To create a PivotTable report, you must define its source data, specify a
location in the workbook, and lay out the fields.

For more information, see Create or delete a PivotTable or PivotChart
report and Create and change the field layout in a PivotTable report.

Ways to work with a PivotTable report

After you create the initial PivotTable report by defining the data source,
arranging fields in the PivotTable field List, and choosing an initial layout, you
can perform the following tasks as you work with a PivotTable report:

Explore the data   by doing the following:

Expand and collapse data, and show the underlying details that pertain to
the values.

Sort, filter, and group fields and items.

Change summary functions, and add custom calculations and formulas.

Change the form layout and field arrangement by doing the following:

Change the PivotTable report form: compact, outline, or tabular.

Add, rearrange, and remove fields.
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Change the order of fields or items.

Change the layout of columns, rows, and subtotals by doing the following:

Turn column and row field headers on or off, or display or hide blank lines.

Display subtotals above or below their rows.

Adjust column widths on refresh.

Move a column field to the row area or a row field to the column area.

Merge or unmerge cells for outer row and column items.

Change the display of blanks and errors  by doing the following:

Change how errors and empty cells are displayed.

Change how items and labels without data are shown.

Display or hide blank lines

Change the Format  by doing the following:

Manually and conditionally format cells and ranges.

Change the overall PivotTable format style.

Change the number format for fields.

Include OLAP Server formatting.

You can automatically create a PivotChart report when you first create a
PivotTable report, or you can create a PivotChart report from an existing
PivotTable report.

Summary
When ever if we want to enter some matter in the tabular form such row

wise and column wise details, the work sheet  is very much applicable because
it includes automatic recalculations of all formulae , several built in functions,
formatting work sheet.etc. It gives professional look of data in the work sheet
and also can show in the form of graphs.

 A worksheet is a single spreadsheet page and a workbook is a collection
of all the worksheets in a single file. A workbook contains worksheets, in the
same way that a book contains pages. A workbook consists of one or more
worksheets.
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   After opening a work book it contains default 3 work sheets. We may
change the no of work sheets and also can rename the work sheets. There is a
facility to know The maximum  no of rows (ctrl + down arrow )   and maximum
no of columns    (ctrl + right arrow ) in excel 2007 .

   When we starts to enter a  formula , automatically shows the formulae
matching the first character of the formula  which  we are trying to enter. So it is
very easy to enter the formula and the arguments of that formula.

While working on a work sheet , if you make any mistake , you can use the
undo command in the quick access toolbar to undo the last action.

We can also find a particular word in the work sheet and also can be
replaced by another word by using find and replace.  If there is any spelling
mistake, we can correct it by using spell check.

     The functions are very helpful for calculations in the worksheets.

Excel allows you to copy a cell or range of cells to any location  with in the
work sheet or to another work sheet. In the same way you can move a cell or
range of cells to any part of any work sheet. For copy and paste  you can use
commands or buttons.

We can insert and delete  rows and columns as we require and then excel
automatically  numbering rows and columns

To give professional look to your work sheet, you can use various formatting
commands. Commonly used formatting styles such as bold, italic and underline
can be applied by clicking the corresponding buttons on the formatting toolbar.

Alternatively press the keyboard shortcut keys to apply same these styles.
e.g  Ctrl+B for Bold, Ctrl+I for Italic and Ctrl+U for underline.

Save is used to store the file with same name but save as is used to store
with another name and also in another location.

If you print a workbook to a file so that you can later print the file on a
different type of printer from the one that was originally used to print the document,
the page breaks and font spacing may change.

To give professional look to the chart, we can add titles as well as axes.
Titles can also formatted by different styles of fonts, sizes etc.,

The macro is useful feature to automate common tasks. Once a macro has
been created either by recording or writing , we can run it any number of times.
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To run a macro , we can press its shortcut keys or select its name from a list of
macros.

In the Tables we can have grand totals row wise or column wise very easily
but , if we want to know the totals of subfields we have to use Pivottables.

Short Answer Type Questions
1. What is a spread sheet?

2. What is a Ribbon?

3. What is mini toolbar?

4. How many rows and columns in excel 2007?

5. What is the difference between workbook and worksheet?

6. How the columns and rows are represented in a work sheet?

7. What is a formula?

8. What is undo and redo?

9. What is auto fill ?

10. What is find and replace?

11. What is Go To command?

12. What is spell check?

13. What is split screen?

14. What is the difference between copy and move?

15. What are the six  options in format cells ?

16. What are the alignments?

17. What are merge cells?

18. What are the shortcut keys for bold, italic and underline?

19. What is the importance of saving a worksheet?

20. What is the difference between save and save as ?

21. What is the importance of charts?

22. What are the different types of charts?

23. What is a macro?
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24. What is a table?

25. What is a PivotTable?

Long Answer Type  Questions
1. Write the 7 tabs in excel and write the groups in each tab.

2. Write and explain any six functions.

3. Write and explain any five mathematical functions.

4. Write and explain any five statistical functions.

5. Explain   copy and move the range of cells with an example.

6. Write the procedure to open, save and print a worksheet.

7. Write about charts.

8.  Write about macors.

9. Write about tables in excel.

10. Write about PivotTables in excel.
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 Structure
5.1   Introduction

5.2   Creating presentations

5.3   Working with contents

5.4   Formatting text

5.5   Adding content

5.6   Graphics

5.7   Slide transition and animation

5.8   Printing

5.9   Conclustion and Tips

Learning Objectives
After going through this lesson you will be have a brief idea for

Presentations, Microsoft office button

Ribbon, quick access toolbar, mini toolbar, navigation, slide views.

 Creation a presentation by using template, from word ouline and by OLE.

 

5UNIT

Microsoft - Powerpoint
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Saving a presentation, add slides, themes, preview of presentation, enter
           text.Copy and move, undo and redo, spell check and font type size,
          style and colour.

Word art, Alignment, indents, text direction, resize a textbox, add bullets
          and numbering, adding video and audio and adding picture

Clip art, Basic shapes, Smart art, Photo album, Slide transition, slide
          animation

Animation preview, slide show options, record narration, rehearse timings,
           speaker’s notes, handouts, print preview and package a presentation.

5.1 Introduction
In today’s extremely competitive business environment , the expectations

that companies have of the professional skills of their employees continue to
grow making  a presentation to clients, colleagues ,superiors or your subordinates
requires presentation skills , confidence , communication skills and knowledge
of presentation software. The era of giving presentations using whiteboard and
marker pens  or overhead projectors  and transparencies is over.  Today , a
number of software packages allow the users to conceive ,create and deliver
visually stunning and dazzling presentations. These applications vary with respect
to the level of technical skills required to create a presentation,  it’s  sophistication,
the infrastructure required to run them and the features that can be incorporated
therein and soon.

There are three features that you should remember as you work within
PowerPoint 2007:  the Microsoft Office Button, the Quick Access Toolbar,
and the Ribbon.  The function of these features will be more fully explored below.

Presentations

A presentation is a collection of data and information that is to be delivered
to a specific audience.  A PowerPoint presentation is a collection of electronic
slides that can have text, pictures, graphics, tables, sound and video.  This
collection can run automatically or can be controlled by a presenter.

Microsoft Office Button

The Microsoft Office Button performs many of the functions that were
located in the File menu of older versions of PowerPoint.  This button allows
you to create a new presentation, Open an existing presentation, save and save
as, print, send, or close.
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Fig 5.1 Powerpoint page

Ribbon

The ribbon is the panel at the top portion of the document   It has seven
tabs:  Home, Insert, Design, Animations, Slide Show, Review and View.  Each
tab is divided into groups. 

Fig 5.2 Microsoft office button

Fig 5.3 Ribbon
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 The groups are logical collections of features designed to perform function
that you will utilize in developing or editing your PowerPoint slides.  Commonly
utilized features are displayed on the Ribbon.  To view additional features within
each group, click the arrow at the bottom right corner of each group.

Home:  Clipboard, Slides, Font, Paragraph, Drawing, and Editing

Insert: Tables, Illustrations, Links, Text, and Media Clips

Design: Page Setup, Themes, Background

Animations: Preview, Animations, Transition to this Slide

Slide Show:  Start Slide Show, Set Up, Monitors

Review:  Proofing, Comments, Protect

View: Presentation Views, Show/Hide, Zoom, Window, Macros

Quick Access Toolbar

The quick access toolbar is a customizable toolbar that contains commands
that you may want to use.  You can place the quick access toolbar above or
below the ribbon.  To change the location of the quick access toolbar, click on
the arrow at the end of the toolbar and click Show Below the Ribbon.

Fig 5.4 Quick Access Toolbar
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You can also add items to the quick access toolbar.  Right click on any item
in the Office Button or the Ribbon and click Add to Quick Access Toolbar and
a shortcut will be added.

Fig 5.5 cutomize quick access toolbar

Mini Toolbar

A new feature in
Office 2007 is the Mini
Toolbar.  This is a floating
toolbar that is displayed
when you select text or
right-click text.  It displays
common formatting tools,
such as Bold, Italics, Fonts, Font Size and Font
Color.

Navigation

Navigation through the slides can be
accomplished through the Slide Navigation menu on
the left side of the screen.  Also, an outline appears
from materials that have been entered in the
presentation.  To access the outline, click the outline
tab.

Fig 5.6 Mini Toolbar

Fig 5.7 Navigation
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Slide Views

Presentations can be viewed in a variety of manners.  On the View tab, the
Presentation Views group allows you to view the slides as Normal, Slide Sorter,
Notes Page, Slide Show, Slide Master, Handout Master, and Notes Master.

Fig 5.8 Slide Views

5.2 Creating Presentation
In this chapter, we discussed the creation ,saving and preview of

presentation.

New Presentation

You can start a new presentation from a blank slide, a template, existing
presentations, or a Word outline.  To create a new presentation from a blank
slide:

Fig 5.9 New Presentation
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   Click the Microsoft Office Button

   Click New

Click Blank Presentation

To create a new presentation from a template:

What is a PowerPoint 2007 template?

A Microsoft Office PowerPoint 2007 template is a pattern or blueprint of
a slide or group of slides that you save as a .potx file. Templates can contain
layouts (layout: The arrangement of elements, such as title and subtitle text, lists,
pictures, tables, charts, shapes, and movies, on a slide.), theme colors (theme
colors: A set of colors that is used in a file. Theme colors, theme fonts, and
theme effects compose a theme.), theme fonts (theme fonts: A set of major and
minor fonts that is applied to a file. Theme fonts, theme colors, and theme effects
compose a theme.), theme effects (theme effects: A set of visual attributes that is
applied to elements in a file. Theme effects, theme colors, and theme fonts
compose a theme.), background styles, and even content.

Click the Microsoft Office Button

   Click New

   Click Installed Templates or Browse through Microsoft Office
Online Templates

Fig 5.10 powerpoint template
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 Click the template you choose

To create a new presentation from an existing presentation:

Click the Microsoft Office Button

Click New

Click New from Existing

Browse to and click the presentation

Fig 5.11 Blank presentation

To create a new presentation from a Word outline:

Fig 5.12 Slides from outline
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Click the slide where you would like the outline to begin

   Click New Slide on the Home tab

Click Slides from Outline

Browse and click the Word Document that contains the outline

Save a Presentation

When you save a presentation, you have two choices: Save or Save As.To
save a document:

Click the Microsoft Office Button

Click Save

Fig 5.13 Save a presentation

You may need to use the Save As feature when you need to save a
presentation under a different name or to save it for earlier versions of PowerPoint. 
Remember that older versions of PowerPoint will not be able to open PowerPoint
2007 presentation unless you save it as a PowerPoint 97-2003 Format.

To use the Save As feature:

Click the Microsoft Office Button

Click Save As

Type in the name for the Presentation

In the Save as Type box, choose Excel 97-2003 Presentation
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Fig 5.14 Save As a presentation

Add Slides

There are several choices when you want to add a new slide to the
presentation: Office Themes, Duplicate Selected Slide, or Reuse Slides.

Fig 5.15 Adding of slides
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To create a new slide from Office Themes:

Select the slide immediately BEFORE where you want the new slide

Click the New Slide button on the Home tab

Click the slide choice that fits your material

To create a slide as a duplicate of a slide in the presentation:

Select the slide to duplicate

Click the New Slide button on the Home tab

Click Duplicate Selected Slides

Fig 5.16 Duplicate selected slides

To create a new slide from another presentation:

Select the slide immediately BEFORE where you want the new slide

Click the New Slide button on the Home tab
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Click Reuse Slides

Click Browse

Click Browse File

Locate the slide show and click on the slide to import

Fig 5.17 Reuse of slides

Themes

Themes are design templates that can be applied to an entire presentation
that allows for consistency throughout the presentation.  To add a theme to a
presentation:

   Click the Design tab

Choose one of the displayed Themes or click the Galleries button

Fig 5.18 Themes
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To apply new colors to a theme:

Click the Colors drop down arrow

Choose a color set or click Create New Theme Colors

Fig 5.19 Create new theme

To change the background style of a theme

Click the Background Styles button on the Design tab

Fig 5.20 Background styles
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Add hyperlinks(OLE- Object Linking and Embedding)

You can use hyperlinks to move from one slide to another, to a network or
Internet location, or even to another file or program altogether.

1. Select the text that you want to click to activate the hyperlink. Alternatively,
you can select an object (a piece of clip art, for example, or a SmartArt graphic)

2. On the Insert tab, in the Links group, click Hyperlink.

3. In the Insert Hyperlink dialog box, click the appropriate button in the
My Places box for the target of your link (that is, the place where the link takes
you).

To go to another slide in your presentation, for example, click Place in
This Document.

4. Find and click the target location, make any changes that you want in the
Text to display and Address boxes, and then click OK.

Preview your presentation as a slide show

To view your presentation on your computer screen exactly the way that it
will look to   your audience when you are presenting, do the following:

1. On the Slide Show tab, in the Start Slide Show group, do one of the
            following:

To start with the first slide in the presentation, click From Beginning.

To start with the slide that currently appears in the Slide pane, click
                From Current Slide.The presentation opens in Slide Show view.

2. Click to advance to the next slide.

TIP: To return to Normal view at any time, press ESC.

Of course, you can also preview your presentation at any time while you
are creating it.

5.3 Working with Content
Editing the presentation by means of entering text, copy and move a text,

and also check the spellings by spell check.

Enter Text

To enter text:

Select the slide where you want the text
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Click in a Textbox to add text

Fig 5.21 Content

To add a text box:

Select the slide where you want to place the text box

On the Insert tab, click Text Box

Click on the slide and drag the cursor to expand the text box

Type in the text

Fig 5.22 Text box

Select Text

To select the text:

Highlight the text

            Fig 5.23 Select Text
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Copy and Paste

To copy and paste data:

 Select the item(s) that you wish to copy

On the Clipboard Group of the Home Tab, click Copy

     Select the item(s) where you would like to copy the data

On the Clipboard Group of the Home Tab, click Paste.

  Fig 5.24 Copy and paste

Cut and Paste

To cut and paste data:

 Select the item(s) that you wish to copy

 On the Clipboard Group of the Home Tab, click Cut

 Select the items(s) where you would like to copy the data

 On the Clipboard Group of the Home Tab, click Paste

 Fig 5.25 Cut and paste

Undo and Redo

To undo or redo your most recent actions:

On the Quick Access Toolbar

Click Undo or Redo
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Fig 5.26 Undo and Redo

Spell Check

To check the spelling in a presentation:

   Click the Review tab

Click the Spelling button.

Fig 5.27 Spell Check

5.4 Formatting Text
To make a better look of presentation, we must format the presentation by

using font type, size and colour. Word art also used to make the text more
stylish. We can also use alignments, indents and text directions  to texts.

Change Font Typeface and Size

Fig 5.28 Fonts
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To change the font typeface:

Click the arrow next to the font name and choose a font.

Remember that you can preview how the new font will look by highlighting
             the text, and hovering over the new font typeface.

To change the font size:

Click the arrow next to the font size and choose the appropriate size, or

Click the increase or decrease font size buttons.

Fig 5.29 Increase or decrease

Font Styles and Effects

Font styles are predefined formatting options that are used to emphasize
text.  They include:  Bold, Italic, and Underline.  To add these to text:

Select the text and click the Font Styles included on the Font group of
            the Home tab or

Select the text and right click to display the font tools.

Fig 5.30 Font styles and effects

Change Text Color

To change the text color:

Select the text and click the Colors button included on the Font Group
             of the Ribbon, or

 Highlight the text and right click and choose the colors tool.
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Select the color by clicking the down arrow next to the font color
            button.

Fig 5.31 Change text color

WordArt

WordArt is a text modifying feature. It includes effects such as shadows,
outlines, colors, gradients, and 3D effects that can be added to a word or phrase.
WordArt can also bend, stretch, skew, or otherwise modify the shape of the
text.

WordArt has styles that can
be applied to text to create a
visual effect. To apply Word Art:

Select the text

Click the Insert tab

Click the WordArt
              button

Choose the WordArt

To modify the styles of
WordArt

Select the WordArt

Click the Format tab for
the Drawing Tools

    Click the WordArt Fill button, the WordArt Outline button, or the
Text Effects button

Fig 5.32 Word Art
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Fig 5.32

Change Paragraph Alignment

The paragraph alignment allows you to set how you want text to appear. 
To change the alignment:

Click the Home Tab

Choose the appropriate button for alignment on the Paragraph Group.

Align Left:  the text is aligned with your left margin

Center:  The text is centered within your margins

Align Right:  Aligns text with the right margin

Justify:  Aligns text to both the left and right margins.

Fig 5.33 Change paragraph alignment

Indent Paragraphs

Indentation determines the distance of the paragraph from either the left or
the right margin. Within the margins, you can increase or decrease the indentation
of a paragraph or group of paragraphs.

Fig 5.34 Indent paragraphs
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To indent paragraphs, you can do the following:

Click the Indent buttons to control the indent.

Click the Indent button repeated times to increase the size of the
             indent.

Text Direction

To change the text direction:

Select the text

Click the Text Direction button on the Home tab

Click the selection

Fig 5.35 Text direction

5.5 Adding Content
To make more effective of a presentation , we can add video and audio

effects to the  presentation.

Resize a Textbox

To resize a textbox:

Click on the textbox

Click the corner of the box and drag the cursor to the desired size.

Fig 5.36 Resize a texbox
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Bulleted and Numbered Lists

Bulleted lists have bullet points, numbered lists have numbers, and outline
lists combine numbers and letters depending on the organization of the list.

To add a list to existing text:

Select the text you wish to make a list

Click the Bulleted or Numbered Lists button

Fig 5.37 Bulledted and Numberedlists

To create a new list:

Place your cursor where you want the list in the document

Click the Bulleted or Numbered Lists button

 Begin typing

Nested Lists

A nested list is list with several levels of indented text. To create a nested
list:

Create your list following the directions above

Click the Increase or Decrease Indent button.

Fig 5.38 Nested Lists

Formatting Lists

The bullet image and numbering format can be changed by using the
Bullets or Numbering dialog box.

Select the entire list to change all the bullets or numbers, or
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Place the cursor on one line within the list to change a single bullet.

Click the arrow next to the bulleted or numbered list and choose a
bullet or numbering style.

Fig 5.39 Formatting lists

Adding Video

Video clips can be added to the presentation.  To add a video clip:

Click the Movie button on the Insert tab

Choose Movie from File or Movie from Clip Organizer

Fig 5.40 Formatting lists

To edit the video options:

Click the movie icon

Click the Format tab

Adding Audio

Audio clips can be added to the presentation.  To add an audio clip:

Click the Audio button on the Insert tab

Choose Sound from File, Sound from Clip Organizer, Play CD
Audio Track, or Record Sound



 Paper - I   Computer Fundamentals and MS-Office 189

 

Fig 5.41 Adding audio

To edit the audio options:

Click the audio icon

Click the Format tab

Fig 5.42 Editing the audio

5.6 Graphics
We can add graphics(pictures, objects, basic shapes, clip art, smart art,

photo album) to the presentation for more and more effective.

Adding Picture

Fig 5.43 Adding picture
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To add a picture:

Click the Insert Tab

Click the Picture Button

Browse to the picture from your files

Click the name of the picture

Click insert

To move the graphic, click it and drag it to where you want it

Adding Clip Art

Clip art is a collection of pictures or images that can be imported into a
document or another program.

To add Clip Art:

Click the Insert Tab

Click the Clip Art Button

Search for the clip art using the search Clip Art dialog box

Click the clip art

To move the graphic, click it and drag it to where you want it.

Fig 5.44 Adding Clip Art
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Editing Pictures and Clip Art

When you add a graphic to the presentation, an additional Tab appears
on the Ribbon.  The Format Tab allows you to format the pictures and
graphics.  This tab has four groups:

Adjust:  Controls the picture brightness, contrast, and colors

Picture Style:  Allows you to place a frame or border around the picture
and add effects.

Arrange:  Controls the alignment and rotation of the picture

Size:  Cropping and size of graphic.

Fig 5.45 Editing Clip Art & Pictures

Adding a Shape

Fig 5.46 Adding a shape

To add Shapes:

Click the Insert Tab

Click the Shapes Button

Click the shape you choose
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Click the Slide

Drag the cursor to expand the Shape

Fig 5.47 Drag the cursor to expand the shape

To format the shapes:

Click the Shape

Click the Format tab

Fig 5.48 Format tab

Adding SmartArt

SmartArt is a feature in Office 2007 that allows you to choose from a
variety of graphics, including flow charts, lists, cycles, and processes.

Fig 5.49 Smart Art
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To add SmartArt:

Click the Insert Tab

Click the SmartArt Button

Click the SmartArt you choose

Click the SmartArt

Drag it to the desired location in the slide

To format the SmartArt:

Click the SmartArt

Click either the Design or the Format tab

Click the SmartArt to add text and pictures.

Fig 5.50 Format of Smart Art

Adding a Photo Album

The photo album feature is new in PowerPoint 2007 and allows you to
easily create a photo album to share pictures. To create a photo album:

Fig 5.51 Adding a photo album
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Click the Photo Album button on the Insert tab

Click New Photo Album

Click File/Disk to add pictures to the photo album

Move the pictures up and down in the order of the album but clicking
the up/down arrows

5.7  Slide Transition and Animation
It is the main stage of  the  presentation.  It includes slide transition and

animation with the features of  Record Narration and Rehearse Timings.

Slide Transitions

Transitions are effects that are in place when you switch from one slide to
the next.  To add slide transitions:

Select the slide that you want to transition

Click the Animations tab

Choose the appropriate animation or click the Transition dialog box

Fig 5.52  Slide transitions

To adjust slide transitions:

Add sound by clicking the arrow next to Transition Sound

Fig 5.53  to adjust Slide transitions
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Modify the transition speed by clicking the arrow next to Transition
Speed

Fig 5.54 Transition speed

To apply the transition to all slides:

Click the Apply to All button on the Animations tab.

Fig 5.55 Apply to all slide

To select how to advance a slide:

Choose to Advance on Mouse Click, or

Automatically after a set number of seconds.

Fig 5.56 Advance a slide

Slide Animation

Animation means to add a special visual or sound effect to text or an
object. Slide animation effects are predefined special effects that you can add
to objects on a slide.   To apply an animation effect:

Select the object

Click the Animations tab on the Ribbon

Click Custom Animation
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Click Add Effect

Choose the appropriate effect.

Fig 5.57 Slide animations

Animation Preview

To preview the animation on a slide:

Click the Preview button on the Animations tab

Fig 5.58 Animation preview

Slide Show Options

The Slide Show tab of the ribbon contains many options for the slide
show.  These options include:

Preview the slide show from the beginning

Preview the slide show from the current slide

Set up Slide Show

Fig 5.59 Slide show option
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Set Up Slide Show

This option allows you to set preferences for how the slide show will be
presented. The options include:

Whether the show will run automatically or will be presented by a
             speaker

The looping options

Narration options

Monitor resolutions

Fig 5.60 Setup slide show

Record Narration

When you want to record narration for the slides:

Click the Record Narration button

Click Set Microphone Level to check the levels of audio input

Click OK to record the narration
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Fig 5.61 Record Narration

Rehearse Timings

Use Rehearsed Timings to rehearse the timings of slide with audio.

Click the Rehearse Timings button

Practice speaking and advance the slides as you would in the
presentation

When you have completed this click through the end of the slide

Choose whether or not to keep this timing or to retry.

Fig 5.62 Rehearse Timings

5.8 Printing
It is the final stage of presentation by making speaker’s notes, handouts

and printing and then copy the entire presentation to the CD or to a file folder.
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Speaker notes

By using two monitors, you can view your notes, or run other programs
that your audience will not see, and you can do this by using Presenter view.

Create Speaker Notes

Speaker Notes can be added to allow you to create notes for each
slide.  To add speaker notes:

Select the slide

Click View

Click Note Pages

Click the Click to add Notes section of the screen

Type in the Notes for that slide.

Fig 5.63 Speaker Notes

Print a Presentation

There are many options for printing a presentation.  They are

Slides: These are slides that you would see if you were showing the
presentation, one slide per page

Handouts: 1, 2, 3, 4, 6 or 9 per page, this option allows for more
slides per page.



     Computer Graphics and Animation200

Notes Page: This includes the slides and the speaker notes

Outline View: This will print the outline of the presentation

To access the print options:

Click the Microsoft Office Button

Click Print

In the Print Dialog Box, click the arrow next to Print what

Choose the format and click OK to print

Fig 5.64 Printing a page

To print preview:

Click the Microsoft Office Button

Place the cursor over Print

Click Print Preview

Click the arrow next to Print What to change print options

To print from Print Preview, click Print
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Fig 5.65 Print preview

To Exit Print Preview:

Click the Close Print Preview button

Fig 5.66 Close Print preview

Package a Presentation

There are times when you want to package a presentation with all of the
additional files attached as well. 

Fig 5.67 Package a presentation
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To package a presentation for CD:

Click the Microsoft Office Button

Click Publish

Click Package for CD

Type a name for the CD

Click Copy to CD or Copy to Folder

5.9 Conclusion and Tips
To  be successful in any environment , there is a need to communicate

effectively through the presentation. A good presentation has an introduction,
body and conclusion. There are different types of presentations as there are
situations. A successful presentation leaves both the presenter and listener
happy and content.   It appraises  and  notifies ,  surprise and stimulates ,
reduces uncertainty , reveals additional alternatives or  helps in eliminating
irrelevant poor ones, and influences  individuals and motivates  them to action.
Successful presentations are the result of careful research, thorough
preparation, repeated rehearsals and reflect intellectual talent and the ability to
sell new ideas in an interesting and exciting way and all of this topped with a
little luck!

The ingredients of any successful presentation are the same

You and your audience are clear about the aim and purpose of the
event.

You understand the audience and their needs.

You know the subject and have done your research.

You  have planned the presentation  and have used the presentation
aids that are best suited for  the situation.

You have rehearsed properly

You are confident in manner and style.

Today the most presentations are created by a group rather than a single
person. But , the ultimate responsibility of making the success of presentation
lies with the person who takes a vital role.

In presentation there are two parties involved – the presenter and the
audience. The presenter is the person who makes the presentation. The
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audience is the group of people to whom the presentation is addressed. It is
very important for the success of the presentation that the details of the
audience are researched. The presentation  style , content, depth , and details
vary with the audience. In fact , the presentation should be prepared keeping
in mind the taste , the knowledge level and other details of the audience. For
an example ,  a presentation that is aimed at young people will not be well
received by a group of middle-aged people.

Presentations should be in the correct length. You should convey what
you want to tell and when you have made your point it is time to stop. Good
presentations eliminate those which are not essential to the point that you are
making. So, the presentation is a great responsibility.

Even though there are many software packages in the market for
presentations,  the  power point designed by Microsoft is best suited  for
presentations. It is powerful and easy to use.

The presenter has to follow some tips while designing presentations.

Design Tips

Slides should be of a consistent design throughout the presentation

Use graphics and pictures when possible

Remove unnecessary information and graphics

Use contrasting background and text colors

Keep the number of fonts used in the presentation to 3

Keep the fonts consistent throughout the presentation

Presentation Tips

Identify the critical information for your presentation

Use no more than 6 bullets per page

Bullets should be short ideas, not complete sentences (these should
be your talking points)

   To start the Slide Show, Click Slide Show on the Presentation
Views group on the View tab

Use the arrow keys to move forward or backward in a presentation
Press the Escape (Esc) key to end the slide show
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A pen tool is available for drawing on the screen with the mouse.
Press CTRL+P or click the right mouse button at any time and a popup
window will appear. Choose Pen and the pointer will change to a pen that
allows you to draw freehand on the screen using the mouse. Press the E key
to erase all pen strokes. Press CTRL+A to disable the pen feature and revert
the pen back to a pointer arrow.

If you would like to use the pen to draw on a blank screen during a
presentation, press the B or W keys, or select Screen/Black Screen from
the popup menu and the screen will turn black. Press B or W again or choose
Next from the popup menu to return to the presentation when you are
finished drawing.

To hide the pointer and button from the screen press the A key.

Be sure to preview the slide show using a projector if one will be
used during the presentation. Words or graphics that are close to the edge of
the screen may be cut off by the projector.

Spell Check

To check the spelling throughout a presentation:

Click the Spelling button in the Proofing group on the Review tab.

Fig 5.68 Spell check

Summary
The Ribbon and other groups are not same as we used in word or excel.

So you must notice the differences in the ribbons and groups of particular
component such as word or excel of ms office. One more thing to remember
that  PowerPoint 2007 has  many similar features to previous versions.  You will
also notice that there are many new features that you’ll be able to utilize.

The difference between themes and PowerPoint design templates

Beginning with Office PowerPoint 2007, templates are “starter” documents,
just like those in Office Word 2007 and Office Excel 2007, and can contain
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starting content or boilerplate text. Themes replace the PowerPoint slide designs
and contain one or more slide masters.

A slide master isn’t actually a slide and it doesn’t store theme information.
The slide master is a separate layer that only looks like a slide. It is where you
can set the master layout and design elements, such as slide background
appearance and graphics that all slide layouts follow by default. For example,
you can specify a slide background, the layout of content placeholders, and add
your company logo on a slide master to have all of those elements apply by
default to all slide layouts that are attached to that slide master.

You can undo and redo up to 100 actions in Microsoft Office programs,
such as Microsoft Office Word 2007, Microsoft Office PowerPoint 2007,
Microsoft Office Excel 2007, and Microsoft Office Access 2007. You can repeat
actions as many times as you want.

We  can also make tighten or lose the text , that is the required space can
be provided between the characters . Strike through and shadow facilities can
also be applied to the text.

When you insert a sound on a slide, an icon that represents the sound
file appears. To play the sound while you give your presentation, you can set the
sound to start automatically when the slide is displayed, start on a mouse-click,
start automatically but with a time delay, or play as part of an animation sequence.
You can also play music from a CD or add narration to your presentation.You
can add sounds from files on your computer, a network, or Microsoft Clip
Organizer. You can also record your own sounds to add to a presentation or use
music from a CD.

Movies are desktop video files with formats such as AVI (Audio Video
Interleave)or MPEG(Moving Picture Experts Group) and file extensions
such as .avi, .mpg, and .mpeg. A typical movie can include a speaker talking,
such as an executive who cannot attend the actual presentation. You can use a
movie to train others or to perform a demonstration.

You can add one shape to your presentation  or combine multiple shapes
to make a drawing or a more complex shape. Available shapes include lines,
basic geometric shapes, arrows, equation shapes, flowchart shapes, stars,
banners, and callouts.

Slide transitions are the animation-like effects that occur in Slide Show
view when you move from one slide to the next during an on-screen presentation.
You can control the speed of each slide transition effect, and you can also add
sound.
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Animate: To add a special visual or sound effect to text or an object. For
example, you can have your text bullet points fly in from the left, one word at a
time, or hear the sound of applause when a picture is uncovered.) the text or
objects (object: A table, chart, graphic, equation, or other form of information.
Objects created in one application, for example spreadsheets, and linked or
embedded in another application are OLE objects.) in your presentation to give
them sound effects or visual effects, including movement. You can use animation
to focus on important points, to control the flow of information, and to increase
viewer interest in your presentation.

You can print your entire presentation — the slides, outline, notes pages,
and audience handouts — in color, grayscale (grayscale: A series of shades from
white to black used in displaying or printing text and graphics.), or pure black
and white. Most often, however, you will probably choose to print in either
black and white or grayscale.

Before printing handouts or slides, consider placing the presentation in a
shared location. Just prior to the delivery time, advise viewers of the location
and those who require hard copies, can print and bring them to the presentation
delivery meeting. This can help to conserve paper and printer ink.

Model Question
Short Answer Type Question

1 What is power point presentation?

2. What is Microsoft office button?

3. What are the seven tabs in Ribbon in power point?

4. What is quick access toolbar?

5. What is mini toolbar?

6. What are the seven  slide views in  presentation views  group in view
            tab?

7. What are the themes?

8. What is a template?

9. Expand  and write the concept of  OLE.

10. What is meant by copy and move a text?

11. What is meant by undo and redo?
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12. What is spell check?

13. What is word art?

14. What are the four alignments?

15. What is indentation?

16. What are text directions

17. Expand  AVI AND MPEG

18. What is clip art?

19. What is SmartArt?

20. What is Photo album?

21. What is a slide transition?

22. What is a slide animation?

Long Answer Type Question
1.   Write the groups in each tab of a ribbon in power point.

2. Write the steps to create, save and preview  a presentation.

3. Write about formatting a text in power point.

4. What are the steps to add video and audio  to the presentation?

5. Write about graphics in power point.

6. Write the steps for animation of slides.

7. What is speaker’s notes?

8. What are handout and notes page?

9. Write  about  the  printing  of  a  presentation
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6.1 Introduction

6.2  Introduction to Database management systems

6.3 Creating a Database

6.4 Integrity Constraints and table relationships

6.5 Designing Tables

6.6 Queries

6.7 Forms & Reports

Learning Objectives
• Explain data and information

• Essential qualities of information

• Explain database

• Dbms, tuple, attribute, domain, degree, cardinality and relation.

• Add records to a table

• Find and replace

 

6UNIT

Microsoft - Access
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• Totals

• Sort records

6.1 Introduction
MS-Access in ms office is used for database applications. It is particularly

designed to store the database and for retrieval of required information as we
desire.

Information is nothing but refined data – data that have been put into a
meaningful and useful context and communicated to a recipient who uses it to
take decisions.  In business , information gives warning signals  when something
starts going wrong, or even  better , before something  stars going wrong. It
should predict the future with reasonable level of accuracy and help the managers
make optimal choices , or more importantly prevent them from taking wrong
decisions. In effect , it should help the organization to survive ,grow and beat the
competition.

Information consists of  data, images, text, documents, and  voice, but
always organized  in a meaningful context. It is important to remember that
information is more than mere data. This is explained in below Figure. Notice
that  the data is being processed or refined can be input , stored or both. Another
point to remember is the cycle of information. Data are processed through models
to create information. The recipient receives the information and then makes a
decision to take an action. This triggers other actions or events, which in turn
will create lot of scattered data that are captured and serve as  input and cycle
starts all over again.

Fig. 6.1 Essential qualities of information
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By quality information we mean , information that is accurate, timely and
relevant. Accuracy ,timeliness and relevance are the key attributes of information.

Accuracy

Accuracy means more than numerical correctness. It means that the
information is free from mistakes  and errors.  The information must not be
unambiguous and accurately reflects the meaning of data on which it is based.

Timeliness

Timeliness means provides the information to the recipients at the right point
of time. For an example yesterday newspaper received today is no use.

Relevance

Relevance means the usefulness of a piece of information for a person. It is
very subjective matter. Information relevant to one person may  not be relevant
for another person.

6.2 Introduction to Database Management Systems
A collection of  data designed to be used by different people is called a

database. It is collection of interrelated data with controlled redundancy to serve
one or more applications in an optimal fashion.

Database system is basically just a computerized record keeping system.
It is repository or  container  for a collection of  computerized data files.

File A file is an ordered arrangement of records in which each record is
stored in a unique identifiable location. The file is a collection of records.

The sequence of the record is then the means by which the record will be
located.

In most computer systems, the sequence of records is either alphabetic or
numeric based on field common to all records such as name or number. The file
is in the form of a table as shown below.

Tuple

Tuple is a  record (row)  is a complete set of related fields.

Attribute

An attribute(field) is a property or characteristics that hold some information
about an entity. For an example a  ‘Student ’ is an entity , has attributes such as
a Stno, stname.  mm, pm, and cm.
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Domain

Domain is a pool of values of a specific attribute. Separate   domains for
separate attributes.

Degree

Number of  attributes is called degree.

Cardinality

Number of   tuples is called cardinality.

Relation

In the relational data model, the data in a database is organized in relations.
A relation is synonymous with a ’table’. A table consists of columns and rows,
which are referred as field and records in DBMS terms, and attributes and
tuples in Relational DBMS terms.

Database

A Database is a structured collection of data that is managed to meet the
needs of a community of users. The structure is achieved by organizing the data
according to a database model. The model in most common use today is the
relational model. Other models such as the hierarchical model and the network
model use a more explicit representation of relationships.
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Database Management System(DBMS)

A computer database relies upon software to organize the storage of data.
This  software  is  known  as  a  database  management  system (DBMS).
Databases management systems are categorized according to the database model
that they support. The software of DBMS are Access,Oracle,Foxpro Etc.,

6.3 Creating a Database
Microsoft Office Access 2007 features a number of improvements that

make the process of creating a new database easier. Even if you have created
databases before, it is likely that you will appreciate these features for their
ability to speed up the creation process.

Get to know the Getting Started with Microsoft Office Access page

When you first start Access, or if you close a database without closing
Access, the Getting Started with Microsoft Office Access page is displayed.

Fig. 6.2 Getting Started with Microsoft Office Access
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This page is a starting point from which you can create a new database,
open an existing database, or view featured content from Microsoft Office Online.

Create a database by using a template

Access provides you with a wide variety of templates that you can use to
speed up the database creation process. A template is a ready-to-use database
containing all the tables, queries, forms, and reports needed to perform a specific
task. For example, there are templates that you can use to track issues, manage
contacts, or keep a record of expenses. Some templates contain a few sample
records to help demonstrate their use. Template databases can be used as they
are, or you can customize them to better fit your needs.

If one of these templates fits your needs, using it is usually the fastest way to
get a database started. However, if you have data in another program that you
want to import into Access, you might decide it is better to create a database
without using a template. Templates have a data structure already defined, and
it might require a lot of work to adapt your existing data to the template’s structure.

1. If you have a database open, click the Microsoft Office Button and
then click Close Database to display the Getting Started with Microsoft
Office Access page.

2. Several featured templates are displayed in the middle of the Getting
Started with Microsoft Office Access page, and more become available
when you click the links in the Template Categories pane.

3. Click the template that you want to use.

4. Access suggests a file name for your database in the File Name box —
you can change the file name, if you want. To save the database in a different
folder from the one displayed below the file name box, click , browse to the
folder in which you want to save it, and then click OK.

Create a database without using a template

If you are not interested in using a template, you can create a database by
building your own tables, forms, reports, and other database objects. In most
cases, this usually involves one or both of the following:

Entering, pasting, or importing data into the table that is created when you
create a new database, and then repeating the process with new tables that you
create by using the Table command on the Create tab.

Importing data from other sources and creating new tables in the process.
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Create a blank database

1. On the Getting Started with Microsoft Office Access page, under
New Blank Database, click Blank Database.

Fig. 6.3

2. In the Blank Database pane, type a file name in the File Name box.
If you do not supply a file name extension, Access adds it for you. To change the
location of the file from the default, click Browse for a location to put your
database (next to the File Name box), browse to the new location, and
then click OK.

3. Click Create.

Access creates the database with an empty table named Table1, and then
opens Table1 in Datasheet view. The cursor is placed in the first empty cell in
the Add New Field column.

4. Begin typing to add data, or you can paste data from another source, as
described in the section Copy data from another source into an Access table.

Entering information in Datasheet view is designed to be very similar to
working in a Microsoft Office Excel 2007 worksheet. The table structure is
created while you enter data — any time you add a new column to the table, a
new field is defined. Access automatically sets each field’s data type, based on
the data you enter.

If you do not want to enter information in Table1 at this time, click Close
. If you made any changes to the table, Access prompts you to save changes

to the table. Click Yes to save your changes, click No to discard them, or click
Cancel to leave the table open.

Note: If you close Table1 without saving it at least once, Access deletes the
entire table, even if you have entered data in it.

Add a table

You can add new tables to an existing database by using the commands in
the Tables group on the Create tab.
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Fig. 6.4 Creation of Table design

Create a table, starting in Datasheet view  In Datasheet view, you can
enter data immediately and let Access build the table structure behind the scenes.
Field names are assigned numerically (Field1, Field2, and so on), and Access
automatically sets each field’s data type, based on the data you enter.

1. On the Create tab, in the Tables group, click Table. 

Access creates the table and selects the first empty cell in the Add New
Field column.

 Note : If you don’t see an Add New Field column, you might be in Design
view instead of Datasheet view. To switch to Datasheet view, double-click the
table in the Navigation Pane. Access prompts you to save the new table, and
then switches to Datasheet view.

2. On the Datasheet tab, in the Fields & Columns group, click New
Field. 

Access displays the Field Templates pane, which contains a list of
commonly used field types. If you double-click or drag one of these fields into
your datasheet, Access adds a field by that name and sets its properties to
appropriate values for that type of field. You can change the properties later, if
you want. If you drag the field, you must drag it onto an area of the datasheet
that contains data. A vertical insertion bar appears, showing you where the field
will be placed.

3. To add data, begin typing in the first empty cell, or paste data from
another source, as described in the section Copy data from another source into
an Access table.

4. To rename a column (field), double-click the column heading, and then
type the new name.

It is a good practice to give a meaningful name to each field, so that you can
tell what it contains when you see it in the Field List pane.
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5. To move a column, click its heading to select the column, and then drag
the column to the location you want.

You can also select multiple contiguous columns and then drag them to a
new location all at once. To select multiple contiguous columns, click the column
header of the first column, and then, while holding down SHIFT, click the column
header of the last column.

Create a table, starting in Design view  In Design view, you first create
the new table’s structure. You then switch to Datasheet view to enter data, or
enter data by using some other method, such as pasting, or importing.

1. On the Create tab, in the Tables group, click Table Design. 

2. For each field in your table, type a name in the Field Name column,
and then select a data type from the Data Type list.

 Note    If you don’t see the Field Name and Data Type columns, you
might be in Datasheet view instead of Design view. To switch to Design view,
right-click the table in the Navigation Pane, and then click Design View .
Access prompts you for a name for the new table, and then switches to Design
view.

3. If you want, you can type a description for each field in the Description
column. The description is then displayed on the status bar when the cursor is
located in that field in Datasheet view. The description is also used as the status
bar text for any controls in a form or report that you create by dragging the field
from the Field List pane, and for any controls that are created for that field
when you use the Form Wizard or Report Wizard.

4. After you have added all of your fields, save the table:

Click the Microsoft Office Button and then click Save, or press
CTRL+S.

5. You can begin typing data in the table at any time by switching to Datasheet
view and clicking in the first empty cell. You can also paste data from another
source, as described in the section Copy data from another source into an Access
table.

Create a table by using a template  Access provides templates for
commonly-used types of tables. With a single mouse click, you can create a
complete table structure with fields already configured and ready for use. If
needed, you can then add or remove fields so that the table fits your needs.
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1. On the Create tab, in the Tables group, click Table Templates and
then select one of the available templates from the list.

2. To add data, begin typing in the first empty cell or paste data from
another source, as described in the section Copy data from another source into
an Access table.

To delete a column  

Right-click the column heading, and then click Delete Column .

To add a new column  

On the Datasheet tab, in the Fields & Columns group, click New Field.

Access displays the Field Templates pane, which contains a list of
commonly used field types. If you double-click or drag one of these fields into
your datasheet, Access adds a field by that name and sets its properties to
appropriate values for that type of field. You can change the properties later, if
you want. If you drag the field, you must drag it onto an area of the datasheet
that contains data. A vertical insertion bar appears, showing you where the field
will be placed.

3. Save the table:

Click the Microsoft Office Button and then click Save, or press CTRL+S.

Open an existing Access database

1. Click the Microsoft Office Button , and then click Open.

2. In the Open dialog box, browse to the database that you want to open.

 Delete a Table

To delete a table:

Open the desired database by clicking the Microsoft Office Button and
clicking Open

Right click on a table and choose Delete
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Fig. 6.5 Deleting a Table

Rename a Table

To rename a table:

• Open the desired database by clicking the Microsoft Office Button
and clicking Open

• Right click on a table and choose Rename

• Type in the new name

Fig. 6.6 Renaming a Table
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 6.4 Integrity constraints and Table relationships
 Introduction

A constraint establishes a logical condition that a field or combination of
fields must meet when values are inserted. For example a UNIQUE constraint
prevents the constrained field from accepting a value that would duplicate an
existing value for the field.

Constraint Clause

You use the CONSTRAINT clause in ALTER TABLE and CREATE
TABLE statements to create or delete constraints. There are two types of
CONSTRAINT clauses: one for creating a constraint on a single field and one
for creating a constraint on more than one field.

Syntax

Single-field constraint:

CONSTRAINT name {PRIMARY KEY | UNIQUE | NOT NULL |

REFERENCES foreign table [(foreignfield1, foreignfield2)]

[ON UPDATE CASCADE | SET NULL]

[ON DELETE CASCADE | SET NULL]}

Multiple-field constraint

CONSTRAINT name

{PRIMARY KEY (primary1[, primary2 [, ...]]) |

UNIQUE (unique1[, unique2 [, ...]]) |

NOT NULL (notnull1[, notnull2 [, ...]]) |

FOREIGN KEY [NO INDEX] (ref1[, ref2 [, ...]]) REFERENCES
foreigntable [(foreignfield1 [, foreignfield2 [, ...]])]

[ON UPDATE CASCADE | SET NULL]

[ON DELETE CASCADE | SET NULL]}
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The CONSTRAINT clause has these parts:

Remarks

You use the syntax for a single-field constraint in the field-definition clause
of an ALTER TABLE or CREATE TABLE statement immediately following the
specification of the field’s data type.

You use the syntax for a multiple-field constraint whenever you use the
reserved word (reserved word: A word that is part of a language, such as Visual
Basic. Reserved words include the names of statements, predefined functions
and data types, methods, operators, and objects.)

 CONSTRAINT outside a field-definition clause in an ALTER TABLE or
CREATE TABLE statement.

Using CONSTRAINT you can designate a field as one of the following
types of constraints:

You can use the UNIQUE reserved word to designate a field as a unique
key. This means that no two records in the table can have the same value in this
field. You can constrain any field or list of fields as unique. If a multiple-field
constraint is designated as a unique key, the combined values of all fields in the
index must be unique, even if two or more records have the same value in just
one of the fields.

Part
Name
primary1, primary2

unique1, unique2

notnull1, notnull2

ref1, ref2

Foreign table

foreignfield1, foreignfield2

Description
The name of the constraint ot be created
The name of the field or fields to be
designated the primary key.
The name of the field or fields to be
designated as a unique key.
The name of the field or fields that are
restricted to non-Null  values.
The name of the foreign key field or fields
that refer to fields in another table.
The name of the foreign table containing
the field or fields specified by foreign field.
The name of the field or fields in foreign
table specified by ref1, ref2. You can omit
this clause if the referenced field in the
primary key of foreign table.
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You can use the PRIMARY KEY reserved words to designate one field or
set of fields in a table as a primary key. All values in the primary key must be
unique and not Null, and there can be only one primary key for a table.

Note

Do not set a PRIMARY KEY constraint on a table that already has a
primary key; if you do, an error occurs.

You can use the FOREIGN KEY reserved words to designate a field as a
foreign key. If the foreign table’s primary key consists of more than one field,
you must use a multiple-field constraint definition, listing all of the referencing
fields, the name of the foreign table, and the names of the referenced fields in the
foreign table in the same order that the referencing fields are listed. If the referenced
field or fields are the foreign table’s primary key, you do not have to specify the
referenced fields. By default the database engine behaves as if the foreign table’s
primary key is the referenced fields.

Primary Key

The primary key is a unique identifier for a record.  The primary key cannot
be the same for two records.  This field can never be blank.

Composite Key

A composite key is a primary key that is comprised of two or more fields. 
It can also be called a compound or concatenated key. 

Unique key

A key which identifies only one body of information out of several.

Foreign Key

A foreign key is a field or combination of fields that are related to the
primary key of another table.

Types of table relationships

There are three types of table relationships.

A one-to-many relationship: Consider an order tracking database that
includes a Customers table and an Orders table. A customer can place any
number of orders. It follows that for any customer represented in the Customers
table, there can be many orders represented in the Orders table. The relationship
between the Customers table and the Orders table is, therefore, a one-to-many
relationship.
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To represent a one-to-many relationship in your database design, take the
primary key on the “one” side of the relationship and add it as an additional field
or fields to the table on the “many” side of the relationship. In this case, for
example, you add a new field — the ID field from the Customers table — to the
Orders table and name it Customer ID. Access can then use the Customer ID
number in the Orders table to locate the correct customer for each order.

A many-to-many relationship: Consider the relationship between a
Products table and an Orders table. A single order can include more than one
product. On the other hand, a single product can appear on many orders.
Therefore, for each record in the Orders table, there can be many records in the
Products table. In addition, for each record in the Products table, there can be
many records in the Orders table. This type of relationship is called a many-to-
many relationship because, for any product, there can be many orders and, for
any order, there can be many products. Note that to detect existing many-to-
many relationships between your tables, it is important that you consider both
sides of the relationship.

To represent a many-to-many relationship, you must create a third table,
often called a junction table, that breaks down the many-to-many relationship
into two one-to-many relationships. You insert the primary key from each of the
two tables into the third table. As a result, the third table records each occurrence,
or instance, of the relationship. For example, the Orders table and the Products
table have a many-to-many relationship that is defined by creating two one-to-
many relationships to the Order Details table. One order can have many products,
and each product can appear on many orders.

A one-to-one relationship: In a one-to-one relationship, each record in
the first table can have only one matching record in the second table, and each
record in the second table can have only one matching record in the first table.

Fig. 6.7 A One-to-one relationship
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This type of relationship is not common because, most often, the information
related in this way is stored in the same table. You might use a one-to-one
relationship to divide a table with many fields, to isolate part of a table for security
reasons, or to store information that applies only to a subset of the main table.
When you do identify such a relationship, both tables must share a common
field.

Table relationships are the associations of data between tables.  By defining
table relationships, you can pull records from related tables based on matching
fields.

One-to-One Relationship: A one-to-one relationship is between two
tables where the primary key in one table and the foreign key in another table
are the same.  For each record in the first table, there is a single matching record
in the second table.

Fig. 6.8 One-to-one relationship

6.5 Designing Tables
 After completion of  creation of a table ,    it may be  necessary to modify

the structure of a table or add some records to a table or delete some records
from a table. The records may need to be sorted or filtered etc.,

Add Records to a Table

To add a new record to a table:

Open the table in Datasheet View

Fig. 6.9 Add records to a table
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Click the New Cell

Type in your new record

Find and Replace

To find data:

Click the Find button on the Home tab

Fig. 6.10 Find and replace

To find and replace data:

Click the Replace button on the Home tab

When you are searching for data for a find, replace or go to, you have
several options in the Find Dialog Box.  These options are:

Fig. 6.11 Find and replace

Find What Text Box
Link in Drop Drop-Down
List
Match Drop-Down List

Search Drop-Down List

Match Case Check Box

Type the text you wish to find
Use the drop-down list to specify a table or a
column to search
Use the drop-down list to narrow down the
search to a field or the beginning of a field
Use this drop-down to specify the direction to
search.
Use this check box to specify whether to search
by the same upper and lower case letters.
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Totals

The totals button provides you the opportunity to add a totals row to your
database.  The total can be the sum, average, a count, minimum, maximum,
standard deviation, or the variance.  To set up a totals row:

Click the Totals button on the Home tab

Click the down arrow of the cell where you want the totals

Click the appropriate choice

Fig. 6.12 Total

Sort Records

You can sort records in a datasheet by a single column or by two adjacent
columns.  To sort records by a single column:

Select the field you wish to sort

Click the Sort Ascending or Sort Descending button

Fig. 6.13 Sort Records
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To sort two columns:

 Move the columns to they are adjacent to each other

Select the desired columns for sorting by holding the shift key and
clicking the columns

Click the Sort Ascending or Sort Descending button

Fig. 6.14 Ascending or descending

To clear the sort:

Click the Clear Sort button

Fig. 6.15 Clear Sort

Filter

You can filter records to include only records that you want to display.  To
filter by a column:

Open the database in Datasheet View

Click the down arrow in the field label

Choose the appropriate filter criteria

Click OK
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Fig. 6.16 Filter

To remove a filter:

Click the filter button on the field label

Click Clear Filter

Click OK

Fig. 6.17 Remove a Filter

6.6 Queries
Using a query, you can answer very specific questions about your data that

would be difficult to answer by looking at table data directly. You can use queries
to filter your data, to perform calculations with your data, and to summarize
your data. You can also use queries to automate many data management tasks
and to review changes in your data before you commit to those changes.

A query allows you to select and filter data from multiple tables.  Queries
can be saved and utilized as often as you need them.
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Query Wizard

You can use the Query Wizard to automatically create a select query. When
you use the wizard, you have less control over the details of the query design,
but the query is usually created faster than if you did not use the wizard. Moreover,
the wizard can catch some simple design mistakes and prompt you to perform a
different action.

The Query Wizard walks you through the steps to set up a query.  To run a
query using the query wizard:

Click the Create tab

Click the Query Wizard button

Fig. 6.18 Query wizard

Choose the type of query you wish to run

Click OK

Fig. 6.19

Choose the fields you wish to include from each table

To select fields from different tables, click the Tables/Queries down
            arrow
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Click Next

Fig. 6.20

Insert pic of query wizard

Type in a title for the query

Click Finish

The query will display

Fig. 6.21

To switch between tables and queries:

Open the Navigation Pane

Double click the name of the table or query you wish to view
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Fig. 6.22

Query Design Feature

You can also design a query with the  Query Design Button.  To design a
query using the Query Design Button:

Click the Query Design Button on the Create tab

Fig. 6.23

Select the tables that you would like to query

Click Add

Fig. 6.23
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Double click the name of the field you would like to query

Repeat this process for as many fields as you would like in the query.

Fig. 6.24

Click Run

Fig. 6.25

Query Criteria

Query criteria are search conditions used in a query to retrieve specific
data.  You can set query criteria to be a specific number or data set, or you can
set the criteria to be a range of data.
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To specify search criteria:

Click the query that you wish to add conditions

Type in the appropriate query criteria in the Criteria Box

6.7 Forms and Reports
6.7.1 Forms

Forms are designed to display certain fields in a convenient format. Suppose
there is a table as shown below.

Fig. 6.26 Forms

The forms generated for three records in the above table are as shown
below.

Forms allow you to control the look and feel of the screen for the input of
data.

“value”

=
< 
<=
> 
>=
<> 
Between  X  And Y
Is Null
And
Or
Not

Will only display items that are that exact value
(replace the word value with what you want to search
by)
Is equal to
Less than
Less than or equal to
Greater than
Greater than or equal to
Not equal to
Within a range (replace X & Y with values)
Null values
True only if both conditions exist
True if either condition exists
True if the single instance is not true
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Fig. 6.27

Fig. 6.28

Fig. 6.29
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Form Views

There are three ways to view forms in Access:

Design View Allows you to design a form that includes a header, a footer,
and details in the form.  You can also add images and control which fields appear
on the form.

Form View: This is a dynamic page which allows the user to enter and edit
data or navigate through data in a field.

Layout View: This view allows you to design the form and manipulate
data.

Create a Form

You can create a form from a table or a query.  To create a form:

Click the Create tab

Click the Form Design button

Fig. 6.30 Form

Click the Format tab

Click the Add Existing Fields Button

Design View

Form View

Layout View

Allows you to design a form that
includes a header, a footer, and details
in the form.  You can also add images
and control which fields appear on the
form.
This is a dynamic page which allows the
user to enter and edit data or navigate
through data in a field. 
This view allows you to design the form
and manipulate data.
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In the Field List box on the right, click and drag the fields you would
like on the form

Fig. 6.31 Field box

To change the colors and fonts, click the Property Sheet button on the
Arrange tab

Fig. 6.32

Insert pic of property sheet button

Choose the Section you wish to modify

Choose the properties you wish to modify

Fig. 6.33
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To preview the form:

Click the Views button on the Home tab

Click the Form View button

Fig. 6.34 Preview form

Form Wizard

Form Wizard  creates a form from one or more tables or queries. It will ask
you detailed questions about the fields, layout and record sources, and the desired
format and creates a form based on those responses.

You can create forms with the help of the Form Wizard.  To use the form
wizard:

On the create tab, click the More Forms down arrow

Click Form Wizard

Fig. 6.35 Form wizard
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Choose the Tables/Queries that you wish to have on the form

Choose the fields you wish to have on the forms

Click Next

Fig. 6.36

Chose the layout for the form

Click Next

Fig. 6.37
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Choose a style

Click Next

Fig. 6.38

Create a title for the form

Choose whether you want to open the form to view it or modify the
form’s design

Click Finish

Fig. 6.39
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6.7.2 Reports
Reports are used to display and/or print information. With access you can

produce spectacular reports by including graphics ,charts and variety of type
styles and fonts.

The report for table given in the previous chapter  is shown below.

Reports are a means to view and analyze large amounts of data.You can
use the Report Wizard or create a custom report that meets your specific needs.

Report Views

Reports can be displayed in four views:

Design View: This view provides you with the structure of your report. 
You can add, modify or delete components of the report but you cannot
manipulate the data in the tables associated with the report

Report View: This view allows you to view the data from the table but not
to change any layout of the report.

Layout View: This view allows you to see data from the table and add,
modify, and delete components of the report.

Print Preview: This view allows you to see what your report will look like
when it is printed.
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To change report views:

   Click the View button on the Home tab.

Fig. 6.40

Create a  Report

To create a blank report:

Click the Blank Report button on the Create tab

Fig. 6.41

Click the Add Existing Fields button

From the field list, Click and drag the fields to the report

Fig. 6.42
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Report Wizard

The Report Wizard presents you with a series of questions, and then
generates a report based on your answers. Among those questions is one that
asks for the field or fields to use to group your report. After the report is created,
you can use it as-is or modify it to better suit your needs. Before you begin with
the Report Wizard, you need to decide upon a data source.

To create a report using the report wizard:

On the Create tab, click the Report Wizard button

Fig. 6.43

Choose the Tables/Queries that you wish to have on the form

Choose the fields you wish to have on the forms

Click Next 

Fig. 6.44

Choose the sort order for your report
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Fig. 6.45

Chose the layout for the form

Click Next

Fig. 6.46

Choose a style

Click Next

Create a title for the form
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Fig. 6.47

Choose whether you want to open the form to view it or modify the
form’s design

    Click Finish

Fig. 6.48

Custom Calculated Fields

You can create reports that include calculated fields.  These reports will
display information that you wish to report with an arithmetic calculation.

To add a custom calculated field to a report:
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Open the Report that you wish to add to

Click the View button

Click Design View

                               Fig. 6.48

Click the Design tab

Click the Text Box button

Fig. 6.49

Click the section on the report where you would like to locate the
             textbox

Click the Property Sheet Pane
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  Fig. 6.50

Click the Data tab

Click the three dots next to Control Source

Fig. 6.51
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     Insert the fields you wish to include in the calculation and the mathematical
operations.

Click OK

Fig. 6.52

After you have generated a report, you can print the report.  To print the
report:

Print a Report

To print a report:

Select the report you wish to print

Right-click on the Report Name

Click Print Preview

Choose the appropriate layout, margins, and paper size in the Page
Layout group

Click Print

Click OK

Summary
Data  is Unprocessed figures and elements where as Information is

Processed figures and elements.Information is derived from Data. Suppose if
we give a cloth to the tailor to make it as a shirt , the tailor has to follow the step
wise Procedure  (cutting, stitching, putting buttons etc.,) according to our taste.
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In this example  Cloth is data , after processing we got  shirt is called
information.  Information is useful for the Users.     In the database, information
of an organization is stored in the form of  tables or files.Suppose in an organization
, sales details in sales table, purchasing details in purchase table, stock details in
stock table and employee details in employee table etc, and all these tables must
be interrelated.

The procedure explained in this chapter to give a basic idea  for creating a
table ,deleting a table, renaming a table  in access. If it is clear ,then you can go
to depth in access.

Creating tables with constraints are necessary to avoid duplicate data entry.
The  relationshipsare used to retrieval of data from tables from  multiple
directions.When the data are large , find and replace is very useful to find the
particular field and also if we want we can replace with some field. Totals and
filtering is also very useful when data are large.Queries are used to  summarize
the results in a table or group of tables . Queries are used for row wise totals,
column wise totals, display some fields based on criteria(condition),etc.,    For
creating a form , it is better to go through the form wizard first, because you can
have an idea of a form. Next , you can go through the form design to design the
form as you like..The Form Wizard can create a variety of results depending on
the options that you select. As a result, we recommend that you run the wizard
several times, experimenting with different options each time, until you get the
results that you want.

For creating  a Report , It is better to go through the report wizard first
because you can have an idea of  a report. Next,  you can go to Report design
to design  the report as you like.

Model Questions
Short Answer Type Questions

1. What is data?

2. What is information?

3. Define database

4. What is a template?

5. Define DBMS

6.  What is a constraint?

7. What is a primary key?
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8. What is a unique key?

9. What is a composite key?

10. What is a foreign key?

11. What are the types of relationships?

12. What is find and replace?

13. What is totals button in home tab?

14. What is meant by sort records?

15. What is form wizard?

16. What are form views?

17. What is a query wizard?

18. What is query criteria?

19. What is report wizard?

20. What are the views in report design?

21. What is a filter?

Long Answer Type Questions
1.What is the concept of data and information?

2. What are the essential qualities  of information?(3 marks)

3. Explain the terms  tuple,  attribute, cardinality, degree, domain and relation.

4. Write the steps to create a simple table and enter three records.

5. Write about the relationships of tables.

6. Write about query wizard.

7. Write the steps to create form by using form wizard.

8. Write about creating a form.

9. Explain the steps for creating a report by using  Report wizard.

10. Write about creating a report.
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